Phone rings but you can't hear the caller

  • 2
  • 1
  • Question
  • Updated 1 month ago
We have been having a problem the last few weeks.  The phone rings.  You can see who the caller is but when you answer the call it's dead air.  The call is logged.  What could be causing this?
Photo of Christine Salmon

Christine Salmon

  • 90 Points 75 badge 2x thumb

Posted 1 month ago

  • 2
  • 1
Photo of Brandon

Brandon, Champion

  • 24,382 Points 20k badge 2x thumb
This is almost undoubtably a network issue of some sort.

Does it happen just for one user or many?  
Desktop phone on computer or hard phone or both?
Has it always happened or started recently?

Do you have any knowledge of your internal network setup?


Photo of Christine Salmon

Christine Salmon

  • 90 Points 75 badge 2x thumb
Happens for many users on all of our desktop phones.  This started a couple weeks ago.  Not sure of our network set up but I can find out if you tell me what to ask.
Photo of Brandon

Brandon, Champion

  • 23,762 Points 20k badge 2x thumb
The reason I asked when it started happening is that it might correlate to some change that was made on your network.  Like a configuration change or software upgrade on your firewall, etc.

I would share this link with whomever works on your network and ask them if any changes had been made around the time you started having the issue.  

The two most common mistakes I see are having ALG enabled and unnecessary inbound port forwarding.  Good luck.

https://success.ringcentral.com/articles/en_US/RC_Knowledge_Article/9233?_ga=1.61344552.588645583.14...
(Edited)
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 36,228 Points 20k badge 2x thumb
Can the caller hear you? If so, you’re describing one-way audio. The most common reason for this occurrence is having SIP ALG activated/turned on in your router configuration. SIP ALG is also known as SIP Forwarding. SIP ALG can change/modify and mess with voice (read VoIP) packets. It should be turned off or deactivated.

As stated, this is only one reason (although usually the main one). If yours is turned off and you are still experiencing this issue I recommend starting a ticket with RingCentral support.
Photo of Christine Salmon

Christine Salmon

  • 90 Points 75 badge 2x thumb
Not sure if they can hear me or not.  I'll have IT check.
Photo of Chris Agri

Chris Agri

  • 70 Points
IT here. Is this guide still accurate for configuring rules on a Meraki MX64?
https://netstorage.ringcentral.com/guides/meraki_mx64.pdf
Photo of Brandon

Brandon, Champion

  • 23,782 Points 20k badge 2x thumb
I use Meraki regularly and it looks good to me.  Setting the advertised bandwidth and per client limit are both good ideas.  The traffic shaping rule is not really necessary.  I usually use the default QoS rule.  I would also make sure there are no inbound port forwards related to voip too.  ALG is no available on Meraki so you are good there.

I would also look at the appliance status page and see if you have a public IP on the MX.  If you are using something like Comcast in NAT mode I would change it to bridge mode.  It is almost always better to not have a modem doing NAT (or anything else to your packets) upstream from you.
Photo of Chris Agri

Chris Agri

  • 70 Points
Great, thank  you.