Plantronics Hub - Target Softphone selection? (Device Controls Disabled)

  • 0
  • 1
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
Using latest Plantronics Hub (Ver 3.13.2 build 41952) with Voyager Focus UC.  Under Settings - Software Settings - Target Softphone there is no option for RingCentral.  What should I select?  I'm having constant issues with the popup "Plantronics Device Controls Disabled".  RingCentral KB ID 10726 is not helpful at all.  I'm thinking that the proper selection of "Target Softphone" with the Hub software might help.  

Photo of MileHighWelch

MileHighWelch

  • 602 Points 500 badge 2x thumb

Posted 2 months ago

  • 0
  • 1
Photo of Nicole Orlanzo

Nicole Orlanzo

  • 452 Points 250 badge 2x thumb
You actually don't need to tell HUB about the Target Softphone for that error that comes up.

In the RingCentral Phone application go into Settings > Sound and make sure your microphone and speakers (and ringer too, if that's what you prefer) are set to the Voyager direct (not "Same as System"). Also make sure the Plantronics headset option is turned on (blue). 



If that doesn't help, I think that your issue might be that the headpiece is losing connection with the computer (going to sleep?), but once it reconnects/wakes up it should figure itself out and re-enable the setting above.
Photo of MileHighWelch

MileHighWelch

  • 602 Points 500 badge 2x thumb
Thanks Nicole, switching from "Same as System" now and will give it a go.
Photo of alfm

alfm

  • 1,682 Points 1k badge 2x thumb
I use Plantrionics Hub and have my 'target softphone' set to 'None' and just changed the sound settings as Nicole has said - works well for me.
Photo of MileHighWelch

MileHighWelch

  • 602 Points 500 badge 2x thumb
I have applied the setting recommended above however I still randomly get "Plantronics Device Controls Disabled"...of course right when I'm trying to answer a call.  When I go to Settings - General and slide the "Plantronics headset" slider off and then back on I can't, I get the "...Controls Disabled" again.  I have to fully close both RingCentral Desktop App and Plantronics Hub down and restart before the slider will re-engage.   Any thoughts???
Photo of Nicole Orlanzo

Nicole Orlanzo

  • 308 Points 250 badge 2x thumb
Voyager is a bluetooth headset, right? I'm thinking the issue is less with RingCentral and more that the device is going to sleep or having issues connecting with your computer constantly. 

These are my settings in HUB under General. Make sure these match yours? Worth a shot. Difference being I use a Savi W740, which uses a base connected via USB. So your HUB might not have all the same options.



Essentially, I believe the "Plantronics Device Controls Disabled" comes up because the headset is not actively(?) connected anymore. So the issue, if I'm correct, is that the headset has a low power mode or is programmed to disconnect after x amount of time not being used.

I would sift through your HUB settings under "Wireless" as well. Mine are definitely tailored to the fact I have a USB base, so not worth showing you mine. I would just keep your eyes peeled for any sort of "auto disconnect" or "battery saver" related options.

When I was having issues with mine constantly being disabled it ended up being that the microphone/speaker settings were Same As System instead of the headset direct. So if that didn't fix it and my other half-measure suggestions above don't, I'm out of ideas - lol.
Photo of MileHighWelch

MileHighWelch

  • 602 Points 500 badge 2x thumb
Nicole, regardless you have been a great forum contributor, Thank You!!!

I believe you are correct or at least on the right track due to the thing works flawlessly after jumping through my reconnect hoops...all be it short lived.  I will keep investigating and see if and how to maintain a connection.  You are also on point with this being a Bluetooth device which is power conservative. 
Photo of Nicole Orlanzo

Nicole Orlanzo

  • 308 Points 250 badge 2x thumb
Aww, thank you! 

Yeah, definitely let me know how you make out - I'm emotionally invested in this now because I know how frustrating it was when it was happening to me - lol!