Plantronics wireless headset no longer beeps/alerts for incoming call.

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
My Plantronics wireless headset will no longer beep in my ear to alert me to an incoming call on my PC or Macbook Pro via headset OR built in computer speaker. This must be a setting somewhere. RingCentral phone support was not able to figure out this problem and no one in my office with the same systems are having this problem. It's not an issue with the headset.
Photo of Michael Glovik

Michael Glovik

  • 182 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Mike

Mike, Official Rep

  • 91,080 Points 50k badge 2x thumb
Can you reply back here and let us know what OS versions, PC and Mac you are running and the model of Plantronics device. 
Also what version of RingCentral Desktop app is giving you this problem? 
Did this problem start after upgrading the RC Desktop app? 
Mike 
Photo of Michael Glovik

Michael Glovik

  • 182 Points 100 badge 2x thumb
Thank you Mike for your quick response.

This happens if I just use the ring central program on my Mac and on my PC. It will not ring through my speakers. Which I tried this to make sure it wasn't an issue with my Plantronics wireless headset. My PC is running Windows 10 and my Macbook Pro is running 10.11.6. I also notice the audio on the PC is choppy when I use it so I mainly use the laptop. Ring Central sent me a link to download 
 8.3.5.24028 as they think it was a new update that may have been causing the issue sense all of my co workers head sets and computers work fine. 

Thank you,

Michael G.
Photo of Mike

Mike, Official Rep

  • 88,774 Points 50k badge 2x thumb
This really sounds like a configuration issue on the Desktop app or the computer, or maybe a combination of the two.  Can you reply back and supply the requested screenshots below. 


1. From the Desktop app, go to Settings > Sound and let us see what you have set for Ringer

2.  On the computer take a look at the default sound settings 
Photo of Michael Glovik

Michael Glovik

  • 182 Points 100 badge 2x thumb
The settings are also the same on my PC (Windows 10). I work on computers for a living and this one has me stumped. Everything functions property on both platforms just not a sound notifying me of incoming call. Which, again, leads me to believe this is a ring central issue.
Photo of Mike

Mike, Official Rep

  • 91,080 Points 50k badge 2x thumb
This is indeed an interesting one.  Normally I would agree that this sounds like an RC software issue, except that if it were, we'd have thousands of users reporting the problem.  What is the model of Plantronics device you were using?  And, did you install any Plantronics Hub software?  I'm starting to wonder if the Plantronics software is overriding the two settings we've checked above. 
If you've installed any Plantronics software let us know what version it is.

Mike 
Photo of Michael Glovik

Michael Glovik

  • 182 Points 100 badge 2x thumb
I agree Mike, very odd! Ring Central works great on my co workers computers and they all have the same headset. We have around 15-20 computers in the office. Go figure I would be the only one with this problem! LOL. 


Yes, I do have Plantronics  "hub" installed. 
Photo of Mike

Mike, Official Rep

  • 91,080 Points 50k badge 2x thumb
Thanks!  Next can you check the software version.  It looks like they've had several releases.   View here: http://www.plantronics.com/us/support/software/archive/
Then can you compare your version to anyone else in the office who's is working normal and see if they are running a different version?
Mike 
Photo of Luke

Luke, U.S. Tier 1 Support

  • 3,794 Points 3k badge 2x thumb
Hi Michael, I have some suggestions on things you can do to try and resolve this.

First, try going to the RingCentral for Mac app and toggle the Plantronics Headset option off and then back on. If that doesn't help, next try uninstalling the Plantronics Hub software, you can find instructions on Plantronics guide for uninstalling Hub software page. If you still experience the issue, try changing the setting in the RingCentral for Mac app to show "Ringer: Plantronics Savi 7xx". If the issue still continues try going to System Preference > Audio > Output/Input and change both of those settings to the Plantronics Savi 7xx.

If you still experience the issue after all this then please open a ticket with us through the Contact Support page. We may want to get some diagnostic logs from your Mac and look into the problem further. 
Photo of Michael Glovik

Michael Glovik

  • 182 Points 100 badge 2x thumb
I reset the hub and downloaded new firmware update. I also totally un-installed the software and re-installed it. It seems to be working fine now. Still not working on the PC but I'm sure I just need to re-install like I did on the Macbook Pro. Thank you guys so much for your help in regards to this issue.

Michael
A happy RingCentral customer =)