Polycom Firmware

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Merged

This conversation has been merged. Please reference the main conversation: Polycom Firmware Issue: Drastic internet speed difference

What is the latest approved Firmware for a Polycom VVX310 to run properly with RingCentral ?
Photo of Claudio (Customer)

Claudio (Customer)

  • 14,090 Points 10k badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Brandon

Brandon, Champion

  • 24,678 Points 20k badge 2x thumb
I'm not sure, but my RC supplied VVX410 is running 4.1.8.0628 so I would tend to want to use that.  I would say only use 5.x release at your own risk.

Any reason you want/need to upgrade?
Photo of Claudio (Customer)

Claudio (Customer)

  • 14,090 Points 10k badge 2x thumb
Thanks, the phone was working fine yesterday but today I moved to other location, different building, same network and it didn't work. I found out the version was soo behind so I tried with the latest 5.4.2... , same problem, does not get the provisioning...
Photo of David Lethe

David Lethe

  • 204 Points 100 badge 2x thumb
My polycom VVX410 runs just fine and it is on latest version as of today (5.4.3.1014)
Photo of David Lethe

David Lethe

  • 204 Points 100 badge 2x thumb
In fact, i used the GUI with the embedded phone microbrowser to change some things, including uploading a new display logo and even though the phone warned the logo would be lost on a reboot, it survived a reboot.


BUT - this is not a ring central branded polycom vvx410, it is the plain vanilla polycom version.
(Edited)
Photo of Nathan Malone

Nathan Malone, U.S. Tier 3 Support

  • 4,770 Points 4k badge 2x thumb
Hello Claudio,

5.4.2 is too high for what is supported by the RingCentral system at this time. The correct version for the VVX310 for the RingCentral system is 4.1.8.

If you log into the IP address of the phone you should be able to set it to the correct firmware version. The steps are below:

1) Once logged into the IP address of the phone Select "Utilities"
2) Select "Software Update"
3) Select "Check for Updates"
4) Then use the drop down arrow to select version 4.1.8.0628

Once the phone gets on that version you will more than likely need to re-provision the phone because the firmware change will probably delete all the provisioning info that may be in the phone.

Thanks!
Nate Malone, Tier 2 Technical Support
(Edited)
Photo of Claudio (Customer)

Claudio (Customer)

  • 14,090 Points 10k badge 2x thumb
Perfect, case solved! Thanks!
Just wondering... what we are missing since we do not have the "latest and the greatest version" ?
(Edited)
Photo of David Lethe

David Lethe

  • 204 Points 100 badge 2x thumb
Download the latest firmware update and read the release notes to see what bugs/features they addressed in builds after 4.1.8.0628  (Hint:  there are a lot of them)

This conversation is no longer open for comments or replies.