Polycom Phone Firmware Update (VVX Model)

  • 8
  • Announcement
  • Updated 2 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution has become inactive, or information contained in this thread is no longer accurate. If you have a related question on this subject, please post a new topic.

Beginning the evening of September 7th, a new version of the Polycom firmware will be available on our registration server. During the week of September 12th, between the hours of 11 p.m. and 3 a.m. Pacific Time, we will update your phones. 

If you restart your Polycom VVX devices after September 7th, but before your scheduled maintenance, the phone will automatically update with the new firmware. 

Important:  This process can take up to 30 minutes to complete depending on the network speed. Do not interrupt (unplug the phone) during the installation process. The reboot can happen any time during the service window. If you are on the phone during the reboot, the call will get disconnected. 

To identify the version of the phones please check Menu > Settings > Status > Platform > Application > Main

             


Changes in this release:

• Improved Call Transfer User Experience - For details visit: Transferring calls via IP phones

• Improved bandwidth when using PC port on VVX device
Photo of Mike

Mike, Official Rep

  • 92,204 Points 50k badge 2x thumb

Posted 2 years ago

  • 8
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Polycom VVX310 not working after firmware update.

We've been using ringcentral and polycom VXX310 handsets for quite a few months and all has been great.

I was asked by RC to update the emergency contact information on my account/lines. I did this and saved before exiting and all the phones rebooted. All phones downloaded the new firmware 5.4.2.6722.

After the reboot, two of our handsets wouldn't reconnect to the service.. but ALL of our handsets were no longer visible on the network to enable me to log into them with the web config utility. All phones have been allocated an IP, I can ping all of them with no issues, but if I open a browser and type the IP address, none of them can be seen.
Before this update I've had no issues what so ever, all phones are visible.

I've just spent nearly three hours with online chat who have failed to find what's causing it except to point me to a page about port forwarding.. but as I said, I've been using the service for months without issue, it's only this firmware that has introduced three issues:

1. Two handsets refuse to register to the network, even entering the log in server details etc. manually, it just sits there saying trying to log in..

2. ALL handsets are now no longer visible on the web config utility

3. ALL remaining handsets apart from the two above have a flashing exclamation mark in the top left of the display

Does any one have any ideas please?
Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
Thank you for the additional details.  
  • How many times have you rebooted the hardphone?
  • The phones are pulling IP Address that you are able to ping, but you are unable to access the IP Address online? Is this correct?
  • Are all the hardphones down, or are any of them online and working?  
Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
Roy - I think I misunderstood. The hardphones are working but not the headsets
I also see you have two cases open with our UK Support team: 04978547 & 04978369.  I will note your case. 
(Edited)
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
Kim. We don't use headsets. Just handsets or hard phones as you call them. Some of the hard phones make and receive calls. But two don't.. all hard phones are not visible on the Web configuration utility
Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
What is the last 4 digits of the Serial Numbers of the 2 devices that are not working? 
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
Kim.. rebooted many times today. Yes. All phones are getting ip addresses from our server but I can't view any of them using the Web configuration utility
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
E1EE is one of them. I'd have to go to another building for the other. Sorry that is closed now. This phone is currently displaying signing in on the display and has been doing this for nearly 1 hour now
(Edited)
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
Kim EC9F is the other hand set that is not working at all....
Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
Thank you
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Same here.  After update to new firmware, flashing exclamation symbol on Polycom VVX 300 at the top of the display.  Can make calls ok.
Photo of FRYE

FRYE

  • 60 Points

I am having the same issue with the flashing exclamation symbol.  Phone seems to work fine but I have the same alert.

  

Photo of Mike

Mike, Official Rep

  • 92,154 Points 50k badge 2x thumb
The flashing exclamation mark is a message.  You can clear it by going to Settings > Status > Diagnostics > Warnings
Photo of SEAN KELLY

SEAN KELLY

  • 70 Points
This reply was created from a merged topic originally titled Polycom Firmware Issue: Drastic internet speed difference.

Polycom Firmware Issue: Drastic internet speed difference (direct connect to switch VS. switch-phone-PC)

Hello there,

I am with a small business and we have Ring Central and have had it for over a year now.

RingCentral Case # 04786865

So, this issue has only popped up about 2 weeks ago. I intially thought the issue was our Time Warner service because there was construction happening near our building on several lines. After that cleared up and we continued to have issues, I investigated further.

I must preface this with the fact that we have not had any issues of this sort until recently. The issue is that our phones cut out and the lines will display an "x" for approximately 10-20 seconds every few hours. There is also a delay in internet response on the PC connected to the phone during this time. The router we have in the office has been configured since the system was initially set up for the port triggers and forwards it needs, so there are no configuration issues.

This was verified by a RC tech support rep logging into my PC and checking the router settings.

After the initial problems with the phone cutting out for short, random periods of time I noticed that the internet response on my PC was rather slow in general. After I noticed this issue, I started running speed tests from different computers in the office to make sure this wasn't just an issue for me or my network card. We have 50MBps/5MBps cable internet service. Most of the time I run a speed test during heavy hours, we still are able to get between 35-45Mbps consistently. After this issue has occurred, I noticed the speed coming from my PC was extremely low. It finished the test and gave me 1.55Mbps/2.89Mbps. I then ran the test from our server, which is hooked directly to the router. The speeds were normal, in fact faster than the rated speed. (60Mbps/6Mbps).

I decided to unplug my phone and hook the Ethernet cable directly to my PC and perform the same test. I received similar speeds to the test run on the server. It is clear somehow the switch in the phone is causing a huge drop off in connection speed. I do not understand how.

The tech support rep suggested if the configuration wasn't working correctly I needed to purchase a new router. The speeds were fine prior to a couple of weeks ago, and I have run several speed tests from PC in the last few months and never reported any performance issues. The router we have is a Netgear R6100 and while it is a few years old, I have not noticed any other internet related issues (aside from the 2.4 wireless band cutting out about once a week).

Does anyone have any ideas or suggestions on why we are having such a hard time lately?
Photo of Treppa

Treppa

  • 132 Points 100 badge 2x thumb
Link to "Transferring calls via IP phones" doesn't work.  Please fix link or send URL so we can determine what has changed.  We have one customer who apparently got the update and is now unable to transfer to voicemail successfully.
Photo of Treppa

Treppa

  • 132 Points 100 badge 2x thumb

The customer has done that and they are claiming the Default Transfer Type no longer appears. This is why I thought they may have gotten the new update as we rebooted the phone and it appeared to download new code.


Photo of Mike

Mike, Official Rep

  • 92,144 Points 50k badge 2x thumb
Treppa,  Just letting you know the link has been fixed: Transferring calls via IP phones
Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb

On all my phones (VVX-410) it is option 10 to change the default transfer type, not 9 as shown in your document.

Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
Official Response
To update the Transfer settings, go into the phone and set the settings: 

      Menu > Settings > Basic > Preferences > Default Transfer Type
(Edited)
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Same problem described above here.  After update I cannot browse the web configuration utility with the ip address, and the phone, VVX300, has a flashing exclamation mark in the top of the display, Phone appears to be functioning properly (can make calls) otherwise, but seems to be an issue with the update. Please don't update the rest of my phones until this is sorted out.
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Figured out that I can get to the web config utility via https. 
Photo of Mike

Mike, Official Rep

  • 92,204 Points 50k badge 2x thumb
The flashing exclamation mark is a message.  You can clear it by going to Settings > Status > Diagnostics > Warnings
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Thanks Mike!  That took care of it.
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
Likewise. Thanks Mike. Surprised first line support doesn't know about this simple issue. Anyway. All I need to do now is find out how to connect to the phones with Web configuration tool
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Roy, try https://   (followed by ipaddress).
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
Will have to wait until Monday now but I'm sure I tried both HTTP and HTTPS and neither worked. I will report back when I can
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
OK thanks the HTTPS worked on some of the phones. I've still got one phone that is completely unresponsive are still not able to log in via the web config utility.
I do believe this has something to do with the phone having the built in Skype/Lynx utility that seems to default to ON everytime an update is applied. I've tried disabling the utility on the phone itself by not allowing auto log in but still no luck.

If I reboot this phone the display shows as the phone is trying to log into ringcentral it says " Sign in, Signing in as 44xxxxxxxxxx this might take a few minutes"  and just sits there for hours saying the same message. I literally left it all weekend and this morning arrived to the same message on the display.

As far as I can see, none of the other handsets say or said this message.. Does anyone know why this happens?

Just to clarify.. the other handset that I can't log into is now visible via HTTPS.. I still need to set it up again as it seems to have lost all it's settings.

I've never known an update to cause so much work.. is there a way to turn off the auto update as I really don't fancy being a test house for the next roll out....I did ask support and they said no.
Photo of Roy Fox

Roy Fox

  • 290 Points 250 badge 2x thumb
an update.

Weve ran a program called Nmap and scanned the IP address that the phone has been allocated by our DHCP server. According to this program, the phone that is not communicating has failed to start any HTTPS service. Hence why we can't talk to it.

The other handset that i'm now able to talk to via the web config utility has a HTTPS service started but I still can't get this phone to log into ringcentral.com

I've been waiting for higher support level to contact me now since Friday. How long must a customer wait to get support from Ringcentral??? It's not like I'm not paying you.. at this precise moment, I have nearly a quarter of my users unable to use their communications to customers.
Photo of Kim

Kim, Alum

  • 43,340 Points 20k badge 2x thumb
Roy - I have contacted your case owner and someone will contact you shortly.  

To update your case with further information please login to http://success.ringcentral.com/RCContactSupp and select “contact support”.  You will be able to see “view: all open cases” at the bottom of the page.  Select the case number and “add comment”.

 

(Edited)
Photo of Chris Sawatsky

Chris Sawatsky

  • 152 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Network: slow network when connecting computer via phone - any ideas?.

Hello,

I am IT consultant for an office that uses ring central phones. Recently some of the users have started having issues with very slow network speeds (< 5mbps) and I have narrowed it down to SOME of the phones. They use VVX-500 desk phones, connected to a network switch. They use power adapters, not POE. So far I've confirmed that TWO of the phones are causing the issue, and have confirmed that some (I tested two) are fine (full 100mbps throughput) 


When I take the network cord out of the phone, plug right into a computer, it tests at 100mbps. Put same network line into phone, then run network line from computer to the back of phone, it tests < 5mbps. This seems to have started recently, the users move a lot of data so they would have noticed it quickly. One user claims his phone did a "large update" shortly before the slow network speed was noticed. I am not sure how to get the firmware versions out of the phones

I talked to ring central support, they didn't have a lot of ideas but suggested taking HD Voice off of the phones. This did not help. 


Can anyone else advise? 

phones are in canada, though I doubt that's relevant. phones have been rebooted. 

Please let me know if you need any additional information to assist

thanks!
Photo of Matt Mikolajczyk

Matt Mikolajczyk

  • 1,384 Points 1k badge 2x thumb
Chris,
1. To get the firmware version, go to Settings > Status > Platform > Application > Main and it will list the version.

2. You may need to pull the power on the phones to reboot the device. This is a hard reboot, which is different then going through the menu to reboot the phone. We had this issue before. Even though the firmware on the phone was correct, we were getting slow speeds until we pulled the power on them and plugged back in. Then, all speeds were normal. (This was all an issue in fw ver 4.1.8.0628, which updated to ver 4.1.8.0983 to resolve).
(Edited)
Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb

The slow network issue still existed in the 4.1.8.0983 firmware, and this new version 5.4.2.6722 is supposed to fix it.  We found in older versions that even after a power cycle the network speed would be good initially, but would degrade again, especially after soft resets of the phone.  We have had the 5x version since Friday, and network speeds seem OK now, but it is still too early to tell.

Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb
In the new 5x version, it appears there is now a "Yellow Circle" around the number of calls on the line.  Generally "Yellow" indicates a warning, so users have asked what the problem is when they see the Yellow Circle during an active call.  A "Green Circle" would have been a better choice.
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Polycom Firmware Update - Blind Transfer Very Confusing Since Update.

After the Polycom VVX firmware update, It is extremely confusing making a blind transfer directly to someones voicemail.  The previous instructions had you to press "Blind", then "*0, Ext".  That wasn't so bad.  Now just to get to "Blind" you have to remember to "long press" transfer first, then hit Blind, then *0+Ext.  Are there any plans to bring back the "Blind" softkey??  We are new to RingCentral (1 month) and this added level of complexity is enough to make us go back to our old provider.  Help!
Photo of Deborah Jennings

Deborah Jennings

  • 100 Points 100 badge 2x thumb
We MUST have the BLIND transfer button back.  It makes it extremely difficult to manage calls from reception.  This should ABSOLUTELY NOT have been taken away. 
Photo of Mike

Mike, Official Rep

  • 92,154 Points 50k badge 2x thumb
Deborah Jennings,   The blind transfer feature was not taken away.  In the original post above, there was added functionality, so you can change the default option.  Take a look at this article for instructions on how to change the default setting and how to use the long-press function. Transferring calls via IP phones
(Edited)
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Mike I have to agree  wholeheartedly with Deborah.  I don't see any 'added functionality', only a non-intuitive way to change the default transfer behavior.  The 'Blind' softkey was a much easier method to accomplish a blind transfer. Now you have to remembering to 'long press' without any visual clue. A definite step backwards.  Just my opinion.
Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb
If you set your default transfer type to "Blind" then whenever you transfer a call it will be a Blind transfer.  You then have to perform the "Long Press" to choose "Consultative".
Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
Slicktop: Fully aware of the above.  It's not intuitive that is the point.  It was working fine with the softkeys and didn't need to be fixed.  Now the phone doesn't give you a clue as to blind vs. warm.  You have to remember what the default is and how to change it.  Was there a technical issue why the softkeys couldn't be left on there?  What is the 'added' functionality (that it didn't do before). ?  I would think with all of the comments by CUSTOMERS, RingCentral would hear.
Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb

I think the "added functionality" is that now you can select the default transfer type, where before the default was always consultative.  I was glad we were given the option as users were not selecting "blind" but instead just hitting the transfer button 2 times and that performed a pseudo-blind transfer.  The caller was transferred, but the caller ID was of the phone that performed the transfer, not the original callers.  This led to lots of confusion.  Now that we set blind as the default on all phones, when a transfer is done, the original callerID is displayed on the recipients phone.  I do agree that now getting the consultative transfer is way more cumbersome, but most of my users hardly ever use it.  I think the reason they didn't/can't set it as a softkey, is because they don't have a way to determine what the default is set to so that the softkey can be the alternative option, so they made the long press option to allow the default to be overridden per call.

Photo of BRENNSKAG

BRENNSKAG

  • 672 Points 500 badge 2x thumb
ok....thank you for that lengthy explanation.  It makes more sense now.  
Photo of PJC

PJC

  • 62 Points
If the programmers were smart enough allow users to change the default transfer type, then they should have been smart enough to realize that a "long press" on the device is not intuitive at all and a very poor solution. If they don't want to check to see what the current default is on the device, they could have thought about providing users with two soft keys, one for each option.
Photo of Arias

Arias

  • 254 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Polycom Warm and Cold Transfer button.

No more Blind transfer button after hitting Transfer with the new version for Polycom VVX 410, please bring it back.  The only way to do Blind transfers is to long press Transfer during the call - choose Blind - and then hit select key before entering the extension which is very cumbersome.
Photo of Joshua

Joshua, Alum

  • 328 Points 250 badge 2x thumb
With the steps that Kim posted above you can switch the Blind Transfer to be the default option when hitting transfer. You will then be able to hit transfer and the ext# and it will go through as a blind transfer.
Photo of Alex

Alex

  • 112 Points 100 badge 2x thumb
So the only way to do the different transfer methods is to change the default now? This seems like a step backward in functionality compared to making the decision on a call by call basis, with ready to go soft-keys.
Photo of Slicktop

Slicktop

  • 882 Points 500 badge 2x thumb

Alex, if the user sets the default to "Blind" and wants to perform the "Consultative", they can just press and hold the Transfer button or softkey.  They are presented an option to choose the type of transfer for that call.

Photo of Gears Admin

Gears Admin

  • 60 Points
Ever since this firmware update we are getting the flashing explanation point on our VVX410's that others have mentioned here.  While it can reset as per instructions listed above, It will return the next time the phone is rebooted.  It indicates that the admin password is at default and should be set to something else.  I have tried changing the password, but it goes back to default after a reboot and then warning comes back.  Is there any way to permanently remove this warning?
Photo of Nathan Malone

Nathan Malone, U.S. Tier 2 Support

  • 4,740 Points 4k badge 2x thumb
Hello Gears Admin,

I would assume that the phones in question are 3rd party phones that were not purchased from RingCentral. If this is the case, when the phone registers as a VVX410 model we give the phone a configuration file which includes a password. This password is the default password for the phone and causes the error warning you are describing.

When you change the password on the phone, our configuration file overwrites the password next time it registers and the error message comes back. There is one way to fix it which is probably not a good option for you, however, you can change the phone from a VVX410 to an "Existing Phone". This will resolve the issue but remove presence and softkey functions from the phone.

There is another potential way to fix the problem. You can call into support and ask them to lock the phone on our back end. A locked phone is given a different password than the default, this may fix the issue, generally, the locked function is used for devices purchased from RingCentral so I cannot guarantee that it will resolve the issue but we can give it a try for you. If you give support a call make sure you explain your issue and why you are asking for the phone to be locked.

Thanks!
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 17,624 Points 10k badge 2x thumb
Polycom VVX500 phones firmware update that began 01-09-2017 --apparently it has worked its way to our system last week, and is displaying these error conditions on the handsets
Missing Config File
Red blinking triangle in the top right corner

This is happening on both varieties of Polycom VVX500 phones we have - ones purchased via RingCentral and ones we had purchased before we changed over to using RingCentral. 


Screenshots attached 
(Edited)
Photo of Mike

Mike, Official Rep

  • 92,204 Points 50k badge 2x thumb
not related to original post. moving to new thread.

Please reference the new conversation here: Missing Config File

This conversation is no longer open for comments or replies.