Desktop App: disable inbound call pop-up notification

  • 0
  • 23
  • Idea
  • Updated 7 months ago
  • Implemented
  • (Edited)
With the newer version of the softphone, there is now a pop up notification for a new incoming call. This is great for call screening and sending the call to voicemail if the user is not available to answer, but can there be an option to turn this off? Turning off the setting to bring the application to the foreground leaves the softphone anchored on the taskbar, but does not stop the incoming call pop up.

For users in call queue's the softphone is getting answered while they are typing on their keyboard and a new call comes to their extension. Mostly because they are hitting the enter key. If we could disable this pop up on the softphone for the call queue users that would be helpful.

Thank you!
Photo of Lauren Denman

Lauren Denman

  • 350 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 23
Photo of Danno

Danno, Champion

  • 26,248 Points 20k badge 2x thumb
very popular request.
Photo of Claudio (Customer)

Claudio (Customer)

  • 13,776 Points 10k badge 2x thumb
Depending on the version of your software, you should ask for a previous version to be installed and wait for a new release with this problem fixed.
(Edited)
Photo of Lauren Denman

Lauren Denman

  • 350 Points 250 badge 2x thumb
We actually tried that and we were having issues with the older versions so that is not an option for us at this time unfortunately, but thank you for the note! 
Photo of SamuraiSam

SamuraiSam

  • 586 Points 500 badge 2x thumb
This is what I experienced. I was forced to downgrade to be able to answer calls correctly as my computer only sometimes gives the pop up window priority, more often it doesnt come to foreground and is lost behind other windows. I had to revert to an older version to be able to answer calls, but the older versions have issues of their own so the only way to fix it was abandon the application for a physical phone :/ Waiting is not always an option when you have customers to help every day.
Photo of Regina

Regina

  • 2,708 Points 2k badge 2x thumb
Yes, we are waiting to upgrade until you (the Community) get this figured out :-)
Photo of Lauren Denman

Lauren Denman

  • 350 Points 250 badge 2x thumb
We've had several complaints from our support team that they are trying to open support tickets and answering calls instead which has been disruptive as they are essentially typing into a second monitor and not realizing the the phone has been answered. I wish that there was at least an option to turn this off and on as previous versions had. Is there a reason that this option was removed? 
Photo of Howard

Howard

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Please reinstate the Ring Central window popping up when a new fax comes in verse....

The old version of Ring Central fax App popped up when a new fax was coming in.  Apparently, the new version only in its a sound when a new fax is coming in.  As we do not use speakers on our computers in this office, we prefer for the window to pop up when a new fax comes in.  Please it provides that feature.
(Edited)
Photo of William Avon

William Avon

  • 132 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Desktop App: disable Pop Up for Incoming Calls.

With the latest desktop app update, incoming calls now have a "new" pop up window instead of being able to answer the call in the app.  Even though "Bring the app to the foreground" AND "on top of other windows" are both "ON", the app opens the incoming call in a new window which is behind the others.   This is a TERRIBLE feature.  Put the incoming calls back in the app. There is NO reason for extra windows to pop up.
(Edited)
Photo of Greg S. Holecek

Greg S. Holecek

  • 232 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Desktop App: disable popup.

I keep the softphone app running in the taskbar. It has
happened several times where I'm typing an email, and a call comes in. The
Softphone app pops up and immediately steals focus, and any keys I'm typing
start controlling the softphone app. This is really annoying, and I'm afraid
one of the keys will auto-dial or auto-answer and cause disruption to some of
my contacts. I really can't have that.


Can you please fix this app so it doesn't steal
focus? It is still very useful to know visually when a call is coming in
because I don't always have my headphones on, and that tells me someone is
calling. Ideally a noticeable but unobtrusive alert would appear in a corner of
my screen similar to Outlook email alerts that would allow me to answer.
(Edited)
Photo of Brandon Scivolette

Brandon Scivolette

  • 1,854 Points 1k badge 2x thumb
This reply was created from a merged topic originally titled Desktop App: Disable Inbound Call Popup -turn off popup to front of screen.

Account Type: Office
Desktop App Version: 7.3.1.16173
OS: WIndows 10

I currently use the desktop app along with the undocked HUD to monitor my staff and calls. As you can see from my screenshot, I have a total of three windows displaying when a call is inbound.

Problem: The notification window (farthest left in my screenshot) always pops up, it never remains stationary like the other two windows. I've tested the various settings in the desktop app and nothing seems to change this. At the moment I have "on top of other windows"  and "bring the application to the foreground" set to OFF. The fact that it pops up is a problem because I accidentally interact with it while I am typing.

Question: The popup issue aside, I noticed that the information given to me in the notification window is similar to the data shown on the desktop app itself (farthest to the right in my screenshot). Assuming I can just see the data in my desktop app under the 'calls' tab I wouldn't even have a need for the notification. However, when I turn off the 'notify my desktop app' feature I find that I don't receive the notification window OR the information in my desktop app.

Goal: To either find a way to stop the incoming call notification window from popping up or to stop the notification altogether if I can see the incoming call information in my desktop app (as shown in my screenshot).

 
(Edited)
Photo of [none]

[none]

  • 112 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Desktop App: Incoming Call Pop Up moves cursor from to app.

Incoming Call Pop Up moves cursor from my email or document into the app - very annoying. Please stop this from happening. Ridiculous process.
(Edited)
Photo of Claudio (Customer)

Claudio (Customer)

  • 13,776 Points 10k badge 2x thumb
This reply was created from a merged topic originally titled Desktop App 7.2.4 goes to front.

Is just us or is a known issue?
We have the switches off to keep the app at the background when an incoming call is ringing. Works fine with internal calls directly to the extension but if is a Ring Group call goes to the front again...
(Edited)
Photo of John Younggreen

John Younggreen

  • 318 Points 250 badge 2x thumb
The call appearance pop up should really be reworked.We are in a commissioned environment where users are competing for calls, and it is nice to be able to just hit enter when the box pops up, but that is where the benefit ends. Other soft phones have shortcut keys or key combinations, some user definable, that allow for quick answering. Additionally, as noted repeatedly, the call appearance box disrupts the users activity frequently and significantly. For users who are attached to several queues and ring groups, it can be quite maddening when you are also trying to continually type notes in a CRM or process credit card payments, not to mention the frequent accidental answering of calls when hitting enter. One other issue we encounter is the incoming call box will freeze a current RDP session. Sometimes the softphone app just needs to be minimized and maximized to unlock the RDP session, but in other instances it is frozen to a degree that "end task" in Task Manager and a re-login to the RDP session is the only resolution.

There has to be a better, less disruptive way to present the call, and an easy "answer" keyboard shortcut to avoid having to click on an answer button. 
Photo of SUTTON

SUTTON

  • 102 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Windows Desktop APP url.

I am using the Windows Desktop app to launch a url for my online scheduling cloud based service. When a client calls in, it automatically displays their profile. The problem is it keeps opening up new windows and interrupts my work every time a new call comes in. How do I have open in the same window each time?
(Edited)
How can i stop this kind of notification from my setting? I am using window 10. Please assist
Photo of Brandon Scivolette

Brandon Scivolette

  • 1,854 Points 1k badge 2x thumb
That's a Windows setting. Easy fix. Go to your settings > system > notifications and actions (see screenshot)
Thank you so much, really, appreciated.
Photo of Hue Tang

Hue Tang

  • 186 Points 100 badge 2x thumb
this is horrendous. 2 years and still no resolution. everytime i'm in the middle of typing something, a call comes in and the ringcentral soft phone takes focus, cutting me off from what i'm doing abrubtly. when will be there a resolution for this?
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,318 Points 20k badge 2x thumb
Hello Hue, are you using a single monitor or multiple?

See if disabling this setting will satisfy your need: