Problem with calls been put on hold when answering remotly via headset in a dual softphone/desk phone enviroment.

  • 0
  • 1
  • Question
  • Updated 10 months ago
  • Acknowledged
We are a new office of 30 that has just signed with Telus Business Connect. We use Polycom VVX411 Desk phones with EHS and a Plantronics Savi w710 headset that supports both desk and softphones. Our office is on fully updated Windows 10 Pro and Softphones are up to date with 9.2.4.27921. 

1. Problem: Incoming call straight from outside or transferred from receptionist are answered by staff members using the button on the headset ear piece. The call is answered by the default stream/channel to the PC, but is immediately put on hold and headset clicks over and establishes a new outgoing call via desk phone. This is happening with no input from staff member short of answering the call with the headset originally. This happens both when user is at his desk or away from his desk, so not distance related.

2. This is a very random issue that happens to only a handful of staff and even on an individual case, it may happen 2 or 3 times in a row then be fine for a bit.

3. Exchanging headsets with one that hasn't exhibited the troubles does not do anything. The same user with a new headset will have same issues (effectively ruling out headset for time being)

4. Checked users settings and nothing I can see that is any different than other users in the system that work fine.

5. Have restarted softphone and computer with no success

6. Have moved USB connector to different USB ports on PC.

7. I have not had software long enough to know if it is an issue with newest 9.2.4 release. Essentially installed and updated to newest software release.

Anyone else have similar troubles currently or in the past? Any thoughts on possible solutions?
Thank you in advance!
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
  • frustrated

Posted 10 months ago

  • 0
  • 1
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,420 Points 20k badge 2x thumb
Hey there,

I'm curious, the users that experience this, do they have RingCentral Meetings open on their computer or use it often?
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
No, I have only installed Meetings on a couple computers in the office. The users experiencing this particular problem are not using either of those computers.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,114 Points 20k badge 2x thumb
Hmmm....have you tried switching out the base for the ones that are experiencing this issue? 
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
Yes. This screams of a headset issue, but when I change out the base with a known working one, the same issue is still prevalent. And the base that I replaced, works fine on the workstation I pulled the good one from.... I'm starting to wonder if it may be related to some of the other problems we are having. Working with our system rep on this, but the issue is quality of outgoing calls via the Softphone. And the issues are 95% the recipient having tough time understanding the caller due to hollow/tinny/poor link. The caller has no issues with the call coming the other way. Knowing this issue is involved, I wonder if its possibly causing the troubles with headset kicking over... Just a theory. Not sure how the signaling works for what device answers the phone, but sense that maybe that signal is being corrupted somehow and the headset tries to answer with both channels. The PC first and a split second later the desk phone. Hence the problematic behavior.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,114 Points 20k badge 2x thumb
It's a valid theory! I don't see any open cases with us right now. Have you looked at verifying your Network according to our recommendations? That might help with the QoS issues you're experiencing. 
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
As we are in Canada and the system is through Telus, I'm assuming I would need to go through them for support channels. I have been working with our rep at Telus to try and get QoS sorted out. I'm no network engineer... :(   and its been a bit of an uphill battle. I have dabbled with some specific port triggering settings, but when I tried to put traffic shaping in place, I took the office offline... oops. Good thing I had a backup config file for my Fortigate. Telus sent us a simplified breakdown of required port mappings that was significantly less involved than the document above. I had browsed through that regardless prior to today, but was relying on info from Telus foremost.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,114 Points 20k badge 2x thumb
Ah, gotcha. You are correct, you will need to talk with Telus :/

I totally understand, if you're not familiar with networking our document can be a little daunting. 
Photo of Sam - U.S. Support

Sam - U.S. Support, Employee

  • 1,558 Points 1k badge 2x thumb
Hey Big Papa J,

Currently, this is a limitation on the Plantronics headset. 

The predecessor to the Savi series, w0300 for example, had the ability to globally set the default line, however, the Savi series only has the ability to set the default outbound line when making calls. What's currently happening is it's trying to answer both, and putting one on hold. I'm honestly surprised the call doesn't end altogether at this point - In theory based on the Plantronics documentation, it should.

There are a couple of workarounds I could advise. Which device is the one that you would like the headset to answer/accept the call on?

Thanks,
Sam
(Edited)
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
Sorry, I hope this didn't sound like I was criticizing RC on this issue, it certainly wasn't. I was just a little surprised at some of the comments coming from Plantronics front end support.
Photo of Sam - U.S. Support

Sam - U.S. Support, Employee

  • 1,558 Points 1k badge 2x thumb
No worries at all, I try not to interpret comments that way :)

I know you're simply trying to improve the environment for your users and customers, and as someone who's job description does not include helping out on the community forums, I can appreciate that 100%.

We're both here simply trying to work towards a solution for a smoother experience all around. If there's any way I can assist with that, I'll always try to.

Thanks,
Sam
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
As far as suggestions below, I appreciate your time in trying them out. I'm not 100% sure yet on how we are going to move with this. At some point I would like to see us on Softphones as much as possible. But as mentioned above, we are still fighting some call quality bugs. This has forced many of the people to rely on desk phones at this time. Everyone is in the same office, so its not a big deal for me to walk around and work with people, I may just do so next week and get them on 1 or the other and implement your suggestions. The toughest part is going to be those few people that use one part of time and the other the rest of the time.
Photo of Sam - U.S. Support

Sam - U.S. Support, Employee

  • 1,558 Points 1k badge 2x thumb
If able to, for a user that experiences call quality issues on the softphone while using their savi headset, could you disable the Plantronics integration and let me know if the issue still persists? This won't allow them to answer the call with their headset button, but I'm more trying to pinpoint the issue specifically.The reason I ask is due to what i was alluding to before. One of the bug fixes in the 9.3 softphone release addresses call quality issues when using the Plantronics integration. If the issue doesn't persist after turning off the integration, the upcoming 9.3 release could fix this problem, and your users would only need to stay using their desk phones as primary until then.If this doesn't fix the issue, I'd be more than happy to take a look at screen shots of your current firewall configuration to see if I can spot any issues(only the sections specific to our requirements, I would not need to see any settings you have configured).Signing off for the night, it's been a long day and I still have a training scenario to configure for tomorrow! Have a great night, BPJ!Thanks,Sam
(Edited)
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
Thanks again, I will be out of office till Tuesday now, but just to clarify. By turning off Plantronics Integration this does not allow you to use headset at all through Softphone for either initiating or receiving a call? I'm not at office to check, but I'm sure this is the case when I tried this before. Using the headset strictly through the desk phone seems to have very few problems. Not perfect, but immensely better than any calls initiated through softphone with headset. Hence why most my staff have gone to using the desk phone only.
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
I think in most cases I would choose to answer the call via the softphone. But having said that it would be nice to maintain the choice depending on the situation the user is in. I've though to just set a delay, before ringing through to the desk phone via users/ Call Handling - First Ring. Only problem is if someone is sitting at desk and wants to answer via desk phone they can't till the delay expires and desk phone starts to ring. Alternately I suppose I could turn 'first ring' off altogether and only have the desk phone ring, but this poses same problem. It would force the user to do a call flip to get back to their soft phone if they needed.  I guess I'll need to decide on one channel or the other and approach Plantronics about possibly changing their call handling. Was this the options you were going to suggest, or is there other changes I could look into?
Photo of Sam - U.S. Support

Sam - U.S. Support, Employee

  • 1,558 Points 1k badge 2x thumb
Hey Big Papa J,

Working with Plantronics on this would be a great step, however depending on your users exact situation, I have 2 workaround that would work for you.

1. If your users normally answer via the softphone for hours on end, and intermittently make a conscious choice prior to an incoming call to start using the desk phone, then the solution is simple: On the desk phone, push the DND button. This will allow the softphone to ring, but the deskphone would be ignored by the system. This does not work in reverse however, as setting DND on the softphone syncs with our system and sets the entire extension to DND. Whenever your user wants to switch back to the deskphone, prior to a call coming in they would simply need to push the DND button on the desk phone again to turn it off. This would turn it back into a situation where it is trying to answer both devices at the same time, however I'm assuming the user would be using the handset in this scenario. Alternatively they could then follow my next suggestion after this.

2. If your users would like to switch to the deskphone at any point for a longer duration instead of using the softphone, if you pull up the settings menu of the softphone, select the Sound tab, and turn off Plantronics headset support. This will not allow the headset to see the incoming call from the softphone, and will instead answer via the deskphone. The call will still show up on the softphone as normal, the headset simply won't answer it.



Hopefully one of these solutions works for you. I know not the most elegant of solutions, however I believe it would work based on the scenario described.

Thanks,
Sam