Provisioning: Manually provisioning Cisco ATA

  • 0
  • 1
  • Question
  • Updated 8 months ago
  • Answered
  • (Edited)
I have a Cisco Spa112 2 Port Phone Adapter and want to know how to use it with my existing analog phone and my current ringcentral account? I currently have a ringcentral polycom 310 but would like to use my analog phone as a cordless option.
Photo of Ron Stephens

Ron Stephens

  • 130 Points 100 badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of RC-Installer

RC-Installer, Champion

  • 27,822 Points 20k badge 2x thumb
Hey Ron, just provision the device using the assisted tool.  Did you purchase the device from RC or third party.

If third party you need to factory reset and follow the directions.  You need to connect your PC to the adapter then the adapter to your router in order to provision it.

You will also need the IP address.
You will enter this in the provisioning process

Under phones and devices is where you will provision the device to a digital line on your system

Photo of Ron Stephens

Ron Stephens

  • 130 Points 100 badge 2x thumb
Also, what's my ringcentral accounts proxy? Thanks.
Photo of Mike

Mike, Official Rep

  • 94,790 Points 50k badge 2x thumb
Also, if it helps, here is an knowledge base article with video: [Video] RingCentral Office 1 Line - Cisco SPA-122 ATA

Photo of Ron Stephens

Ron Stephens

  • 130 Points 100 badge 2x thumb
Thanks Mike, that definitely helps!

Photo of Ron Stephens

Ron Stephens

  • 130 Points 100 badge 2x thumb
... although my ATA is an SPA112 and that video is for an SPA122. Also, what do I put in the "proxy" field of my ATA config panel? And what do I put in the "dial plan" field?
Photo of Antonio Saavedra

Antonio Saavedra

  • 60 Points
Ron, did you ever get to set up your SPA112. I am having the same situation, calling RC has not help, I have also try Google. There are instructions for numerous companies but RC.
We have an SPA112... the trick seemed to be the factory reset.  We tried every combination of settings we thought could impact it to no avail, until the factory reset.

Happened to catch a video of someone doing it twice and the lights did blink differently as described below.

0) Detach phone line - hold in reset button and the power and internet lamp blink.  Do this a second time and the line 1 and 2 will blink.  Now you can attach your phone.

After you connect your phone, get the IP and follow the steps (of course change your admin password (admin->UserList), and make certain to update the local time server (Network->Time Settings) )

1) Go to Voice -> Line 1 -> Proxy and Registration, enter the SIP Domain in the Proxy, outbound in outbound. Select Yes for Use Outbound, Use OB, Register. and Use DNS SRV.
2) Go to Voice -> Line 1 -> SubScriber, enter anything in Display Name, User Name -> UserID, Password->Password, Authorization ID -> AuthId, and set Use Auth ID = Yes.
3) Submit to Save.

For full disclosure, we did update the firmware somewhere in the mix of trying a ton of configuration changes, but we didn't get the "registered" until after the reset and going back through the steps.

Any questions, just ask.
Photo of Bo You

Bo You

  • 62 Points
Misco Products Super Admin is correct. If you just follow the instruction on RingCentral, it may not work. You need to turn on more settings.

The major reasons are:
1. There is no "SIP domain" in the setting, you need to input the value in Proxy.
2. The default setting of three fields are "no", you need to change them to "yes". They are "Use Outbound Proxy" , "Use OB Proxy in dialog" and "Use DNS SRV".
3. If you update the setting, always use the correct Password (in the Subscriber information section), instead of the default "******"

The following is the screen shot of my setting. Good luck!

Photo of Jim Templin

Jim Templin

  • 70 Points

So there a few things I found helpful in addition to what is stated in this thread.

I set the "display name" by copy and pasting the RC "assigned" field in "phones and devices"

Second you must the "Use Auth ID:" field to yes. Kind of intuitive but not stated directly in this thread.

Photo of Jim Templin

Jim Templin

  • 70 Points
Cisco SPA112: 

first thing is update the firmware to the latest and greatest

(Ringcentral value on the left, cisco value on the right

quick setup:  

sip domain = proxy 
RingCentral phone user (i.e. name) = display name  
user ID = user Name 
password = password

PRESS SUBMIT - go get coffee

network setup:
connection type should be set to "automatic configuration - DHCP"
If you are a nerd and need to access this from a remote terminal then setup a static IP with DNS.

PRESS SUBMIT - go get more coffee

Voice: (line 1 or line 2 - NOT USER1 or USER2)
     Line 1
       set "line enable" to yes
     Line 2
disable line 2 if you are not using it
   Proxy and Registration
      Outbound Proxy= Outbound Proxy
      set "use outbound proxy" to yes
      set "Use OB proxy in Dialog" to yes
      set "register" to yes
      set "Use DNS SRV" to yes
    Subscriber Information
      Authorization ID = Auth ID
      set Use Auth ID to yes

PRESS SUBMIT -  wait for reboot to complete

test the line using a single analog telephone.  
Photo of Collin Anderson

Collin Anderson

  • 60 Points
I just want to add - My previous provider used TLS for "SIP Transport". I needed to change that back to UDP. Otherwise this worked. Thanks!