Mobile App: incompatible with my LG F7 device

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution has become inactive, or information contained in this thread is no longer accurate. If you have a related question on this subject, please post a new topic.

I have a LG F7 and when I try to download the app through the Play Store it says that my device is not compatible. I tried updating my software, but it was all up to date. How can I install this app on my phone?
Photo of ATRS LLC

ATRS LLC

  • 70 Points

Posted 2 years ago

  • 0
  • 1
Photo of Kim

Kim, Alum

  • 43,000 Points 20k badge 2x thumb
RingCentral System Requirements for the Mobile apps: • iOS 7.0 or later (iOS 9.0 supported)
• Android OS 4.4 or later (Android M supported)

It looks like your LG F7 Platform OS is v4.1.2 (Jelly Bean). 

This conversation is no longer open for comments or replies.