Desktop App: Changing Default Printer to RingCentral Internet Fax

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I am using the latest version of RingCentral Desktop (8.1.1.21232) and am not always logged in to RingCentral Desktop on my Windows 10 Pro PC.  However, when I do log in, frequently my default printer gets changed from its current setting to RingCentral Internet Fax.  If I change it back then do not log in to RC Desktop, the default printer doesn't change.  It is only when I log into RingCentral Desktop.

I opened a chat with support and they directed me to the community, saying they had no record of that being a problem and no troubleshooting steps.  The agent also offered that Windows 10 had not been out long and wasn't fully supported yet (isn't W10 a year old next week?) so this avenue appears to be my source of help.

Any assistance is greatly appreciated.
Photo of Bob Robinson

Bob Robinson

  • 1,642 Points 1k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Chris Verdin

Chris Verdin

  • 2,438 Points 2k badge 2x thumb

Any chance your default printer is not available all the time and so it defaults to RC printer when the default is not available? 

Try changing your default printer to something else that is always available.  I'm on Windows 8.1 doing what your doing but not experiencing the same issue. 

Photo of Bob Robinson

Bob Robinson

  • 1,640 Points 1k badge 2x thumb
Thanks for the suggestion.  The default printer I select is always available (I'm on a desktop PC and the default is a networked Ricoh SP 311SFNw).  And to be a bit more clear, it's not just logging into RC Desktop that is causing it.  I am logged in now and the default is what I have chosen.  Some action within RC Desktop is causing the issue.  However, if I do not launch or log in to RC Desktop, the default printer will stay in place until I change it.  I didn't use RC Desktop for a couple weeks and the printer never changed.  Logged in to RC Desktop yesterday and the printer changed.

I have turned off the Windows 10 "Let Windows manage my default printer" option is settings.
(Edited)
Photo of Kim

Kim, Alum

  • 43,000 Points 20k badge 2x thumb
Window's 10 is still in Beta, please "submit feedback" in the desktop app settings. 
But I'm interested to see if others are having this issue on Window's 10?
(Edited)