ringcentral with plantronics savi 7xx headset

  • 0
  • 6
  • Question
  • Updated 4 months ago
  • In Progress
i use a plantronics savi 7xx headset with my ringcentral account. this headset allows me to simultaneously connect both my desk phone and the softphone on my computer. i can pickup and initiate calls on either the desk phone or the softphone, routing audio through the headset. but there is a problem that i cannot figure out. outgoing calls initiated on the softphone makes me sound robotic. incoming calls sound fine, according to the person on the other end of the line. it's only when i make an outgoing call with the softphone that i sound robotic to the other person. does anyone have the same experience? and if yes, have you figured out a solution?
thanks.
Photo of Hue Tang

Hue Tang

  • 196 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 6
Photo of Big Papa J

Big Papa J

  • 514 Points 500 badge 2x thumb
Yep, exact same issue, and have been working to try and find a solution with no luck as of yet. Possibly thinking it may be a compatibility problem with softphone and Windows 10, but haven't confirmed that yet. Are you using Windows 10?
Photo of DanielB

DanielB

  • 326 Points 250 badge 2x thumb
Hello Hue,

In the past we've experienced something similar, but not quite the same. Occasionally we'll get that digitized/robotic sound and when we do, all we have to do place the call on hold for a second and pick it back up and that usually resolves the issue. 

Additionally, all of us just installed the Plantronics Hub software and updated the firmware on our headsets. We have not had the issue since - whether that's a coincidence or not, I'm not sure.

Hope that helps,

Daniel
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Hi Daniel, I'll add my comments here on this. We too have found that sometimes the hold trick does resolve the issue.
It is really only a "band-aid" though and not a true solution.
Photo of Hue Tang

Hue Tang

  • 196 Points 100 badge 2x thumb
hi. i'm using windows 10. but i have not installed the plantronics hub software. i'll try the suggestion of putting the call on hold for a second and then resuming. i'll also install the plantronics hub software to see. i'll report back. thanks.
Photo of Big Papa J

Big Papa J

  • 514 Points 500 badge 2x thumb
In my case, I have installed the Hub software and updated firmware on headsets. Have also played with numerous variations on narrowband/wideband, HD on off, and lowered the range. None of these seemed to help. One test I did was actually record a poor quality voice call using the built in Windows 10 voice recorder. I then made just a voice recording without a call through the soft phone. Simply opened a headset channel to the PC and recorded some voice. This was crystal clear. I did several tests like this and couldn't get a single bad recording. Yet using the soft phone I was getting intermittent quality issues. I have also spent a lot of time working on Port triggering and QoS with our in house router/firewall and nothing seems to improve the quality issues there either. Lastly I had a Windows 7 laptop in the office that I installed the software on and hooked to the network. I couldn't get any bad call quality issues through that either, after several calls. This is why I'm pointing finger at a compatibility issue with Windows 10. My current Win 10 O/S build is Version 1703 (15063.674)
Photo of Hue Tang

Hue Tang

  • 196 Points 100 badge 2x thumb
the firmware update did not improve the situation. putting the call on hold and resuming did not help either. but i did find out that it's only happening on ringcentral to ringcentral calls, however. when i call a cell number, for instance, i do not sound robotic. and this happens even with inter-office calls where the phones are on the same network.

more info to add.
best call quality is from a plantronics savi headset to another savi headset. this is crystal clear.
next in quality is plantronics to a cell phone.
worst is from plantronics to a generic usb headset or to a ringcentral desk phone.

i don't know if the problem is with windows 10, the plantronics headset or ringcentral, or a combination of any of these three.
(Edited)
Photo of Luke

Luke, Training Specialist

  • 3,828 Points 3k badge 2x thumb
Hi Hue. Have you attempted an outbound call from the softphone to another RingCentral user without the headset?

If the issue is the same without the headset then it would mean there is an issue either with software on the PC or settings on the local network. If you do not get reports of distortion without the headset you may have to adjust the audio settings for the headset in the Plantronics hub software, or Plantronics support may have some suggestions to resolve the issue.

Let us know if this helps or you make any progress.
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
We have had this issue for months beginning with all versions after 8.3.6. They changed something in the software and how it integrates with the plantronics wireless headsets. We troubleshooted this for months. It was supposedly fixed in 9.3.3, however we have continued to experience the issue on 9.3.3 and 9.3.5. We are testing the newly released 9.4.1 with a couple of users and so far no occurrence (only 2 days of testing). However, I am not convinced yet that this is fixed.
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
Please keep us updated on this, it has been a fight for us as well and would appreciate any further feedback on how it works out with new version.
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Quite honestly, our experience has pushed us to use more wired headsets. Many users now prefer them because of the huge quality difference. However, the root issue is poorly written software, because the savi works fine with any other software program or physical desk phone.

Also, we did discover in our experience that if you toggle the "Plantronics headset" setting to off, the robot voice went away. However, that defeats the purpose of using the wireless headset because you lost the ability to answer/end a call with the button on the headset. This even further points to the softphone as the root cause of the issue.

Additionally I mentioned version 8.3.6. We downgraded most of our users to this version and they have no issues with the robot voice. Yet another data point to confirm that the software is at fault. However, as time has gone on, we see this version becoming more unstable and are being forced to upgrade some users.
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Confirmed that 9.4.1 does NOT resolve the "robot voice" issue. Users who are testing have been experiencing the issue throughout the day today.
Photo of Big Papa J

Big Papa J

  • 494 Points 250 badge 2x thumb
Thanks for update Aaron. I also did same test with disabling Plantronics integration a few weeks back and then enabling it again. If you do this while on a call, it actually clears the poor quality up. However, it does come back again right away on a new call.
Photo of Ryan Meyer

Ryan Meyer

  • 84 Points 75 badge 2x thumb

We recently rolled out RingCentral to our office of 200 users. I really like there service, but I too have the Robotic voice with my Savi 745 headset using the RC Desktop client. The issue does not occur on every call, but it does seem to happen to the same numbers (to both internal RC and external non-RC phones). It appears to be specific to my PC. When I moved my Savi headset to another laptop it did not have the issue. Both computers are running the latest 9.3.5 RC Desktop software on the same Windows 10 OS version. 
On the computer with the problem, I have found that unplugging and reconnecting the USB port during an active call fixes the Robotic voice issue 100% of the time. However, once that call ends I may need to redo that on the next active call. For callers I know I've spoken to with the issue, I have unplugged the USB and reconnected the USB, after initiating the call but before they have answered, so that active call will be clear. 
The Robotic issue never occurs when using the Savi 745 DECT to my VVX411 desk phone. I'm still looking for a permanent solution. I have borrowed a Savi 745 from one coworker that does not have the issue and using his Savi with my PC we had the issue. Moving my Savi to his PC, we did not have the issue. The computers are different models. Hopefully this gives RC support more information to find a solution.
UPDATE: I tried using the hold mentioned above, that did not work for me. I tried turning the 'Plantronics headset' off/on in RC Desktop Settings > Sound, and that worked for the active call, just like the USB method I mentioned above. The Plantronics headset off/on is faster if you already have the settings page opened.

(Edited)
Photo of Tyler D

Tyler D, Employee

  • 410 Points 250 badge 2x thumb
After some troubleshooting with a client we found that the 9.4.3 version of the RingCentral  for Windows Application (available on the Downloads page) is not exhibiting this robotic voice issue. 

After updating, If you are still experiencing issues, please open a new support case: http://success.ringcentral.com/RCContactSupp
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Hi Tyler, unfortunately this is not resolved in that version or any version newer up to the current 10.1.2.
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 528 Points 500 badge 2x thumb
Tyler, Are you suggesting we go backwards to an earlier version of the softphone?  I am inclined to agree with Aaron that the issue would not be resolved with that version and we have the most up to date version with 10.1.2. 
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 51,802 Points 50k badge 2x thumb
I would not suggest going back. When this thread first began, there was an older version out and then the 9.4.3 was the newest (at the time)
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 528 Points 500 badge 2x thumb
I see that now, thanks.  So, we are back to just reporting that the issue is not resolved and we are still looking for a solution.
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
We are having this issue with users on Savi 720 headsets using the desktop app version 10.1.2.31099  Same headset is not having issues when using RC through Polycom VVX 411.  Although the support has pointed to our network as being the issue, after reading this thread I believe this is a software issue that the integration with the Plantronics Savi headset.  Or just an overall software issue in general.  It does not seem to matter if it is Windows 10 or 7 pro as we have issues on both and the two machines experiencing the most frequent robotic calls have brand new machines and brand new headsets.  Glad I found this thread to investigate further.  I just wanted to point out that it is not solved. 
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Thanks for reporting, Sherri! We continue to experience the issue multiple times a day for various users as well.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 54,126 Points 50k badge 2x thumb
Hey Aaron and Sherri,

Please open a case (if you haven't already) so we can troubleshoot further. 
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
We have a case open for multiple Quality of Service issues.  I have not been satisfied with the support answers which is why I went searching again for my own answers and found this thread.  I will continue to work with the support team, but we are at a high level of frustration right now with this and I want to see who else in the community might have better solutions.  We also have an outside IT support team we are paying to check and double check all possible network and equipment and have been told we have it all set up the way it should be so I am back to assuming it is an incapability or issue with the RC software or problems with specific RC servers that the softphones are going to when they ring out.   
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 54,126 Points 50k badge 2x thumb
Hey Sherri, I'm sorry for the frustration. I've seen where things like this take some time due to it being caused by a hidden issue. Do other headsets behave the same on both computers? Have you checked to make sure the software/firmware on the Plantronics is current? Do you have a firewall program on your computers? Have you tested the same computer & headset on a different network? 
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
Plantronic firmware is current.  Firewall and all QoS settings along with fiber connection were verified yesterday by our outside IT person to be correct. Same computers and headsets behave the same way on different networks.  We have three locations experiencing the same problems.  Again, I think we have narrowed it down to either a problem with particular RC servers that have a high ping rate when the softphone is connecting to them or the RC softphone software is not working well with the Plantronics headset.  We are following both avenues to try to find the solution because the percentage of bad robotic calls our softphone users are experiencing is not going to work.
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Hi Saadet, We have had numerous cases opened and closed due to being unable to get them resolved. We have even had RC engineers on-site: Michael Cox, James Drabbant. We have also had multiple calls with other engineers as well as our account managers: Tino Martinez, Zach Hardy, Morgan Means, Dave Peter.

A lot has been tried over the course of about 10 months and this issue still exists.
We have spent too much of our own time troubleshooting and gathering data. Frankly, we have just gotten tired of the same run-around and waste of time that opening yet another support case brings.

Alas, we have simply been "dealing" with the issue. Our users here have a very poor impression of RingCentral and anytime the name is mentioned it is with much distaste and dissatisfaction.
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
We have been working on this since January/February time frame and have work with many of the same people and teams.  I will continue to update here as we attempt options.  It becomes more difficult as users give up and "deal" with it because they stop reporting it thinking nothing is going to be done to fix it.  We've also spoken with several other offices who are "dealing" with the issue or have gone back to their old VOIP provider.  One way or another we will get to a resolution because suffering in silence won't be the right option for us. Appreciate the input Aaron. Thank you.
Photo of Mike

Mike, Official Rep

  • 93,198 Points 50k badge 2x thumb
HI Sherri,  I located your open case, and it looks like they are making some progress. The notes indicate there was an issue with a patch cable.  Do you know what kind of cable that was?  In most cases you should have at least a Cat5e or Cat6 cable as they'll allow for greater bandwidth and have additional EMI shielding over Cat5 or older. A bad cable without EMI shielding could easily be enough to cause robotic sounds.

Even if you have a fiber connection, the fiber is only as good as the patch cables can handle.  

The case is still open so if you have more problems or feel like you aren't getting the service you need you can reply back here or email us at community.support@ringcentral.com
Photo of Mike

Mike, Official Rep

  • 93,198 Points 50k badge 2x thumb
Aaron,  I don't see an open case on your account at this time.  If you are still having issues please open another case clarifying the QoS issues you are having. We'll followup with you to make sure it gets handled correctly and escalated if needed. 

Also, the agents should be asking you if the issue has been resolved before closing the case. If this occurs please let us know asap.

Mike
(Edited)
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
Mike, the bad patch cable had nothing to do with any of the machines experiencing the robotic voice.  It was on a spare machine used to run Ping Plotter.  While I feel we are eliminating potential causes, it is frustrating almost every time we bring the issue up the tech script seems to be to say it is a problem on our end which I now don't believe is the case. I will continue to work through the case and the reason I started posting here is to try to gain extra information from the community.  What I see is a pattern of people getting so frustrated that it can not be solved that they give up on opening tickets, and Ring Central doesn't follow through to actually find a solution because there is no open ticket.  It becomes a never ending circle of dissatisfied customers. 
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 54,126 Points 50k badge 2x thumb
Hi Sherri, please keep us updated on how it's going. I know that extreme packet loss can cause issues with audio - and that is something usually caused by ISP or network issues. I'm curious to hear what your new Ping Plotters show.
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
We have ruled out ISP and network issues.  I took 3 users yesterday afternoon and turned off the Plantronics headset toggle setting in the RingCentral Settings Sound tab.  Since then none of them have reported robotic voice issues on calls.  Obviously, this is not a permanent solution because leaving that setting off takes away any Call controls from Plantronics headsets – mute, hold, pickup, hang up, next call and the One Touch answer and termination of calls etc.  I'm not sure how to proceed at the moment.  We will continue monitoring for the duration of tomorrow to be sure that is what was causing the call interference. 
(Edited)
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
So far our results show that if we keep the Ring Central Plantronics setting toggled off the robotic voice is not a problem.  As soon as it is toggled back on, we have intermittent robotic voice calls.  I'm not sure how there is anything we can do on our end to fix that.  The Hub firmware is up to date as is the RC softphone version. 
Photo of Aaron Hartzler

Aaron Hartzler

  • 470 Points 250 badge 2x thumb
Hi Sherri,We are testing this same thing today with two users. I will update here on what our results are. Thanks for sharing!
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
Yes, let me know. We are now going through gathering logs from a debug mode with tier 3 support.  I was able to show on a call how my voice goes from robotic to fine the minute I toggle off the Plantronics headset on the sound tab.  I will keep this thread updated with the status of that. 
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
As update.  We are told now this is considered a known issue and there is no update right now on when a fix will be implemented.  We will have to use a different headset other than the Savi 700 series and are researching a replacement now.  If anyone has an update or has suggestions please let me know.  We need a headset that is wireless and will work to answer and end calls from the headset buttons while using the Ring Central desktop app.  Thanks. 
Photo of Sherri Rodriguez

Sherri Rodriguez

  • 538 Points 500 badge 2x thumb
As update.  I was told by a tech support representative that they believe this issue of the robotic calls to be fixed as of the 10.2 and 10.3 versions.  It has not been fixed for us.  Anyone else still having these issues? The Jabra headset we tested did not work for us.  We lost the ability to use the Call controls from the headset, so Plantronics is still our only option it seems to get full integration and functionality. And the Savi series are the only ones with the range we need in our office. Any and all advice appreciated.