SalesForce Rincentral App Slow

  • 0
  • 2
  • Question
  • Updated 4 days ago
  • Acknowledged
Yesterday there was an email sent out by Ringcentral saying that they were going to be moving the Data Centers to Chicago, IL. This morning our Ring Central within Sales Force has been extremely slow. Making it hard to use our dispositions. Is ringcentral aware of this issue? Is there a fix? This is slowing our Sales team down.
Photo of Rene Arellano

Rene Arellano

  • 124 Points 100 badge 2x thumb
  • Frustrated

Posted 6 days ago

  • 0
  • 2
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 38,860 Points 20k badge 2x thumb
Hi Rene, are you still having issues today?
Photo of Rene Arellano

Rene Arellano

  • 124 Points 100 badge 2x thumb
Hello,

The problem as been fixed today.
Photo of Rene Arellano

Rene Arellano

  • 124 Points 100 badge 2x thumb
Actually spoke too soon. It started up again. With the same problem.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 38,860 Points 20k badge 2x thumb
Hmmm...please open a Support Case so we can investigate!

Photo of REED

REED

  • 80 Points 75 badge 2x thumb
We're seeing the same issue...running very slow. Like there isn't enough bandwidth to handle the task. I opened a case since there isn't a known issue or resolution here. I read the moving of data centers email as well.
Can you tell us what version of the RingCentral for Salesforce integration you are on? Go to Setup -> installed packages -> rc_sf_package

We are currently looking into this issue.
Also, let me know your case number so I can personally look into this. 
Photo of Jordan Richards

Jordan Richards

  • 102 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled RingCentral for Salesforce not working.

The RingCentral App for Salesforce has been acting up for the last 3 days. I have had to contact support multiple times and have received no response or updates. This is slowing down our whole sales team. Yes, I have tried multiple browsers. Yes, I have tried updating the software. Yes, my computer is plugged in. Please fix the software.
Photo of Rene Arellano

Rene Arellano

  • 124 Points 100 badge 2x thumb
I feel your pain. I did speak with support today and they said that they were going to escalate it. Not sure what that means as far as fixing this problem for what seems like all the users. I know this had to do with move Chicago, IL
Can you tell us what version of the RingCentral for Salesforce integration you are on? Go to Setup -> installed packages -> rc_sf_package

We are currently looking into this issue. 
Photo of Rene Arellano

Rene Arellano

  • 124 Points 100 badge 2x thumb

5.8.4