Salesforce suddenly showing "Click to dial is disabled"

  • 0
  • 1
  • Question
  • Updated 2 months ago
  • Answered
As of Monday, 4/9/18 we can no longer click-to-dial from within Salesforce. Previously all phone numbers within our Salesforce instance were formatted like a hyperlink (blue color with underlining) with a green phone icon next to the number to indicate click-to-dial. Now all numbers are formatted normally and the phone icon is grayed-out. When hovering over the phone icon the text says "Click to dial is disabled". 

We have not made any changes to our Salesforce permissions that I am aware of. We are using Salesforce Classic. Also, to clarify, the Ringcentral Salesforce app appears to be connecting to the Windows desktop application correctly for showing incoming/outgoing call information correctly and appears to be working in all other aspects.

Thus far I have tried the following without any improvement:
  • Ensure all necessary users have access to the Call Center within Salesforce.
  • Ensure the Call Center has the correct CTI adapter URL.
  • Log in/out of the RingCentral for Salesforce app. (on the sidebar of the Salesforce page)
  • Log in/out of the RingCentral for Windows desktop app.
  • Log in/out of Salesforce.
  • Update the Ringcentral for Salesforce app package (rc_sf_package) to version 5.10.1
  • Uninstall the Ringcentral for Windows desktop app and install the most current version, version 9.4.3
Photo of Dave Kruh

Dave Kruh

  • 202 Points 100 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Jitender Kumar

Jitender Kumar, Director Application Development

  • 1,476 Points 1k badge 2x thumb
Hello Dave, 
Thanks for the detailed information, very helpful.  I have had encountered issues where Windows update would create problem.  Can you please also check if the softphone launcher is working fine by typing in rcmobile://call?number=%2Bxy (replace xy with a valid phone #) in browser address bar.  Please create support ticket for same so our Softphone team can troubleshoot.  I hope you are able to use "Other phone" option meanwhile 
Photo of Dave Kruh

Dave Kruh

  • 202 Points 100 badge 2x thumb
Thank you for the reply Jitender. I used the URL you provided and it worked through the softphone correctly. The softphone appears to be working correctly. Even dialing a number directly in the Ringcentral for Salesforce App starts a call on the softphone like it should so I don't think there is any loss of functionality there. 

I think the issue is all within the Salesforce app itself. 
(Edited)
Photo of Jitender Kumar

Jitender Kumar, Director Application Development

  • 1,476 Points 1k badge 2x thumb
Hello Dave, 
We do not have any known issue for click to dial as you described. Could you please contact our tech support?  They will capture the JS Console logs as you do the click to dial.  
Photo of Dave Kruh

Dave Kruh

  • 202 Points 100 badge 2x thumb
Just in case anyone else has this issue in the future, RingCentral support was able to solve the problem by correcting the incorrect CTI adapter URL in our Salesforce call center. I thought I had already checked this but I did not. 

As it turns out, Salesforce moved our instance to the na49 server from the na42 server. The Call Center was trying to use an old URL with "na42" in it instead of "na49" which I had apparently overlooked when checking the URL.
Photo of Collin Toyn

Collin Toyn

  • 62 Points
Hello, I'm experiencing the same problem. How do I get in touch with support?
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 27,898 Points 20k badge 2x thumb
Hey Collin,

You can contact our Support Team a few ways :)