Soft Phone App doesn't launch. It remains in the task bar- (windows 10)

  • 183
  • 1
  • Question
  • Updated 2 months ago
  • In Progress
I click on my softphone Icon and it just loads in the taskbar but the soft phone does not appear. I've uninstalled and reinstalled. Same issue. Need this to work. I'm on windows 10. 
Photo of Kipp Gillian

Kipp Gillian

  • 70 Points

Posted 1 year ago

  • 183
  • 1
Photo of Devane


  • 484 Points 250 badge 2x thumb
Maybe a simple 'popup blocker' issue? 
Photo of Chris Verdin

Chris Verdin, Champion

  • 3,094 Points 3k badge 2x thumb
Maybe not a popup blocker because those usually pertain to Internet browser windows.  But, it could be your Anti Virus.  Try disabling your AV and launching The app again.  
Photo of Chris Verdin

Chris Verdin, Champion

  • 3,388 Points 3k badge 2x thumb
It works for me just fine on Windows 10.  If you double click the icon in the taskbar does it show up?  Curious if you somehow have the Run Application minimized in Settings, General.
Photo of Bond007DMC


  • 2,248 Points 2k badge 2x thumb
I would agree that this may be what's going on, but I don't remember run minimized being the default upon installation, and it sounds like he has reinstalled. Maybe it was set to minimize previously and a deinstall does not remove all settings. He may have the same issue I do. RC Phone loads and puts icon on task bar (regular running apps, not the background ones on far right or hidden in the little pop up window. If I click on the taskbar icon, nothing happens but app is running. If I double-click, I believe I get a message that says app is already running. If I double-click the smaller icon to the right (if hidden click arrow to reveal apps), then RC Phone shows right up. As a side note, the RC Phone app will not auto load upon computer restart, even though I have it set to do so. This only happens on my computer, and I'm the super admin.
Photo of Mark Bartoszek

Mark Bartoszek

  • 1,102 Points 1k badge 2x thumb
This has happened to me before. Try killing the app through task manager, and then open it again. 
Photo of Brenda Willey

Brenda Willey

  • 112 Points 100 badge 2x thumb
that worked  thank you
Photo of Shelly Roth

Shelly Roth, Champion

  • 2,102 Points 2k badge 2x thumb
I am running Windows 10 Pro edition.  This has happened to me before too and in fact, it happened again this morning.  I just X out of all applications and lock my computer at night and do not restart every night.  I did this last night and when i tried to open RC phone this morning it would not come up.  It showed in my task bar but didn't come up.  I had to restart my computer.  It works after a restart, but shouldn't be an issue in my opinion whether i restart or not.  i have also been getting crashes when trying to answer the phone periodically as well.  i keep trying to do the update (thinking that will resolve my issues) but keep getting an error message.  I am having my IT people look into getting the latest version downloaded.
Photo of Giacinto Busico

Giacinto Busico

  • 90 Points 75 badge 2x thumb
I also have this problem. RC ok after reboot but if minimised it is not possible to bring it back on the desktop.
I also run RCMeeting but that works fine
Photo of Mary Rose

Mary Rose, Official Rep

  • 4,092 Points 4k badge 2x thumb
Hello Glacinto,

Have you tried Mark's suggestion above? End the app on Task manager and open it again.
Photo of Giacinto Busico

Giacinto Busico

  • 90 Points 75 badge 2x thumb
yep, tried that, didn't work. The RC was not seen in my task manager list once it was minimised. I end it up reinstalling the RC app again and ok now.
I think I am running now RC classic.
Thanks for your comments.