Softphone Crash on Maximize

  • 4
  • 1
  • Question
  • Updated 1 year ago
Merged

This conversation has been merged. Please reference the main conversation: Upgrade to the latest version of RingCentral for Desktop (Crash or Failed Installation after upgrading to 8.4.5)

Computer:
Win 7 64 bit  - up-to-date

Account type (U.S., Canada, UK,  AT&T, Telus, BT)U.S.
Related case number (if applicable)

Detailed description of problem
Softphone crashes when trying to Maximize the application from a minimized state.

Goal
Fix crashing

Previous troubleshooting steps taken
Uninstalled / Reinstalled - No dice
Uninstalled, Deleted C:\Users\UUNAME\AppData\Local\RingCentral, Verified program files directory was gone, Deauthorized computer via website, reinstalled. - No Dice

Software version
8.3.4

Error Msg:
Problem: Halt on unexpected exception at location WinHook
Windows Exception EXCEPTION_ACCESS_VIOLATION (0xc0000005) at 0x1458ED2D; read 0x000000d0; 
* stack trace * 
<undef>
<undef>
<undef>
<undef>
<undef>
QOpenGLContext::currentContext
QSGBindable::clear
QSGBatchRenderer::Renderer::renderBatches
QSGBatchRenderer::Renderer::render
QSGRenderer::renderScene
QQuickWindowPrivate::renderSceneGraph
QSGRenderLoop::setInstance
QSGRenderLoop::setInstance
QCoreApplication::processEvents
QSGRenderLoop::setInstance

Details: Exception 
>>>
Halt on unexpected exception at location WinHook
Windows Exception EXCEPTION_ACCESS_VIOLATION (0xc0000005) at 0x1458ED2D; read 0x000000d0; 
* stack trace * 
<undef>
<undef>
<undef>
<undef>
<undef>
QOpenGLContext::currentContext
QSGBindable::clear
QSGBatchRenderer::Renderer::renderBatches
QSGBatchRenderer::Renderer::render
QSGRenderer::renderScene
QQuickWindowPrivate::renderSceneGraph
QSGRenderLoop::setInstance
QSGRenderLoop::setInstance
QCoreApplication::processEvents
QSGRenderLoop::setInstance

<<<
ESS::Assertion in thread 8824 @ ..\..\..\src\Utils\ErrorsSubsystem.cpp:383 in void __cdecl ESS::HaltOnUnexpected(const struct Utils::ExceptionInfo &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
* Stack trace *
ESS::BaseException::GetStack
ESS::BaseException::BaseException
ESS::HaltOnUnexpected
`anonymous namespace'::ExceptionFilter::UnhandledExceptionFilterProc
GetProfileStringW
RtlKnownExceptionFilter
RtlInitializeExceptionChain
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb

Posted 2 years ago

  • 4
  • 1
Photo of Andrew

Andrew, Champion

  • 378 Points 250 badge 2x thumb
Any time we have issues with softphone for us our our clients on Windows systems, the following steps usually resolve.

  1. Uninstall RC for Desktop
  2. Go to C:\Users\andre\AppData\Local\ and Delete the RingCentral Folder
  3. Reboot
  4. Reinstall RC for Desktop
Hope that helps!
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
Thanks for the reply Andrew - I saw the procedure you mentioned in other similar threads and did try that.

Previous troubleshooting steps taken
Uninstalled / Reinstalled - No dice
Uninstalled, Deleted C:\Users\UUNAME\AppData\Local\RingCentral, Verified program files directory was gone, Deauthorized computer via website, reinstalled. - No Dice
Photo of Andrew

Andrew

  • 378 Points 250 badge 2x thumb
I should have read your whole post first.  Whoops.
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
No worries  - thanks for the suggestion. :)
Photo of Mike

Mike, Official Rep

  • 91,038 Points 50k badge 2x thumb
Hi LeafVee, 

Did this just start when you moved ti 8.3.4?   

I'm emailing you a download link for 8.3.3 if you want to try that, then let me know if it still crashes with maximizing. 

Mike 
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
Hi Mike,

We are just getting started with RingCentral so I believe this user started with 8.3.4.

I tried the version linked and had the same result but the error message is slightly different.

Problem: Halt on unexpected exception at location WinHook

Windows Exception EXCEPTION_ACCESS_VIOLATION (0xc0000005) at 0x1563ED2D; read 0x000000d0;

* stack trace *

<undef>

<undef>

<undef>

<undef>

<undef>

QOpenGLContext::currentContext

QSGBindable::clear

QSGBatchRenderer::Renderer::renderBatches

QSGBatchRenderer::Renderer::render

QSGRenderer::renderScene

QQuickWindowPrivate::renderSceneGraph

QSGRenderLoop::setInstance

QSGRenderLoop::setInstance

QCoreApplication::processEvents

QSGRenderLoop::setInstance

 

Details: Exception

>>> 

Halt on unexpected exception at location WinHook

Windows Exception EXCEPTION_ACCESS_VIOLATION (0xc0000005) at 0x1563ED2D; read 0x000000d0;

* stack trace *

<undef>

<undef>

<undef>

<undef>

<undef>

QOpenGLContext::currentContext

QSGBindable::clear

QSGBatchRenderer::Renderer::renderBatches

QSGBatchRenderer::Renderer::render

QSGRenderer::renderScene

QQuickWindowPrivate::renderSceneGraph

QSGRenderLoop::setInstance

QSGRenderLoop::setInstance

QCoreApplication::processEvents

QSGRenderLoop::setInstance

 

<<< 

ESS::Assertion in thread 11012 @ ..\..\..\src\Utils\ErrorsSubsystem.cpp:383 in void __cdecl ESS::HaltOnUnexpected(const struct Utils::ExceptionInfo &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)

* Stack trace *

ESS::BaseException::GetStack

ESS::BaseException::BaseException

ESS::HaltOnUnexpected

`anonymous namespace'::ExceptionFilter::UnhandledExceptionFilterProc

GetProfileStringW

RtlKnownExceptionFilter

RtlInitializeExceptionChain

Photo of Mike

Mike, Official Rep

  • 91,038 Points 50k badge 2x thumb
LeafVee,  Just letting you know that I've created case # 05145474 for this issue so that it can be escalated.  You can use the link below to check the status of this case or add additional information. 


  
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
Thanks Mike!

Do you happen to know of any dependencies I can verify are installed properly? (Java, Visual C Runtimes, .NET, etc)
Photo of Mike

Mike, Official Rep

  • 91,038 Points 50k badge 2x thumb
For PCs the only think I'm aware of is the following (as of this date) : 

• 1 GHz (32-bit) or 2 GHz (64-bit) processor
• Minimum of 512 MB of memory
• 200 MB of hard drive space
• Microsoft Outlook 2010 or higher
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
Thanks for the info Mike. 

The case doesn't seem to be showing up for me. Did it get created successfully?
Photo of Mike

Mike, Official Rep

  • 91,038 Points 50k badge 2x thumb
Yes.. I double checked. It has a support agent assigned to it. When you log in to view the case, what exactly are you seeing? Do other cases show up, but not this one?  Or is there any issue logging in? 

Mike
Photo of LeafVee

LeafVee

  • 532 Points 500 badge 2x thumb
It is showing up now - thanks!
Photo of Amber Noelle

Amber Noelle

  • 70 Points
We are having the same issue with Ring Central.  We have tried to
  1. Uninstall RC for Desktop
  2. Go to C:\Users\andre\AppData\Local\ and Delete the RingCentral Folder
  3. Reboot
  4. Reinstall RC for Desktop

But that did not work.  Is there any other solution?

Photo of Shaun Eozzo

Shaun Eozzo

  • 70 Points
Mike, the rep and I spoke for an hour today. We scheduled a follow up tomorrow after I install all driver updates. The driver updates are installed and the issue is ongoing. The symptoms are the same as others experienced in this thread.
Photo of Ray Almanza

Ray Almanza

  • 72 Points
Any updates to this thread?I have three new hires having the same issue.
Photo of LeafVee

LeafVee

  • 512 Points 500 badge 2x thumb
Still no solution for my issues. I've only had two users so far and they aren't call queue members so buying them desk phones has worked.
(Edited)
Photo of Ray Almanza

Ray Almanza

  • 72 Points
Thank you for the information; however, I manage a team of remote users and for the first three months probation time we only provide RingCentral desktop to minimize incurring in physical equipment loss. It's incredible, that this issue has been going on for almost 5 months with many software updates in between and this is still an issue. 
(Edited)
Photo of LeafVee

LeafVee

  • 512 Points 500 badge 2x thumb
I hear ya, it's not a fix at all. A band-aid, on this end I can isolate the issue to Win 7 + Intel GPU and more a coincidence I believe a plugable dock / graphics adapter. The issue is def opengl compatibility.
Photo of Mike

Mike, Official Rep

  • 91,038 Points 50k badge 2x thumb
For anyone still having this problem, I"m going to merge this thread into a topic that has instructions for rolling back to a previous version while this being worked on.

Mike

This conversation is no longer open for comments or replies.