Softphone frequently lags when answering call

  • 1
  • 3
  • Question
  • Updated 7 months ago
  • Acknowledged
Beginning about a month ago, after I answer an incoming call with RingCentral for Windows, there will sometimes be about a 3-4 second delay before I can hear the person calling or talk to that person. It doesn't always happen, but it has been happening more frequently and at this point I'd say it happens on average about once a day.

During the delay, if I look at the "HD Voice" indicator in the top left of my smartphone, it will show red with one circle. Then it will recover and show green and I can begin the conversation.

I'm using version 9.4.3.29474 of RingCentral for Windows which appears to be the latest version. My co-worker also uses the Softphone app and I notice that the same thing occasionally happens to him.

I'm wondering if anyone has also had this problem and if there is anything I can do to fix it. I'm not sure whether it has to do with the app I'm using or if it is just a general problem with our service.
Photo of Mike Gomez

Mike Gomez

  • 90 Points 75 badge 2x thumb

Posted 7 months ago

  • 1
  • 3
Photo of Luke

Luke, U.S. Tier 1 Support

  • 3,814 Points 3k badge 2x thumb
Hi Mike,

Based on what you're experiencing I think the most likely cause is that the Quality of Service (QoS) settings on your network are not set up to make sure that RingCentral internet traffic is prioritized above other traffic.

If RingCentral traffic is not prioritized, then a web page, online video, or other content that is already coming into your network at the time could be delaying your RingCentral connection. Having the correct QoS settings on your network will make sure that your router knows that those other activities can wait a bit so that RingCentral audio comes through as quickly as possible.

Since your coworkers are also experiencing this, this solution seems likely, since you're all sharing the same network connection. I would recommend passing on this information to your IT/network admins so they can ensure your network is set up properly for RingCentral service.
Photo of Teresa Habeck

Teresa Habeck, Champion

  • 1,074 Points 1k badge 2x thumb
Funny, We have recently noticed the same thing. All network setting are as stated above correctly. We have not changed anything on our end and all was working before. Have there been any changes on RC's side?
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,580 Points 20k badge 2x thumb
Hi Teresa,

I'm not aware of any changes regarding Network Configuration. Is this happening all the time to everyone? Or is it specific people and only sometimes? Did your ISP have issues the day(s) that you were experiencing this?
Photo of Luke

Luke, U.S. Tier 1 Support

  • 3,814 Points 3k badge 2x thumb
As Saadet states, the issue can also be related to your ISP not prioritizing your traffic properly as well.

We have a feature called Quality of Service Reports which records the quality of all calls through your account and gives scores and identifies which part of the connections experienced issues. This feature can help you understand any issues related to your ISP, but does not identify local network issues.

If you have a RingCentral Office Premium or Ultimate account, check out our Quality of Service Overview article to understand how to use this feature.