Why can't I send a fax with a PDF file using the Softphone?

  • 0
  • 5
  • Question
  • Updated 5 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate. If you have questions or comments related to this to thread, please create a new topic, or post to ano

I am trying to send a fax with the Softphone. When I try to attach a PDF file, I get the error: "RingCentral FaxEditor. Unable to print. File: C:\MyDocument.pdf". The PDF document is not corrupt. It is 1.47 MB and it does not have any special characters in the file name. I get this error when I try to attach any PDF document.
Photo of George Edwards

George Edwards

  • 130 Points 100 badge 2x thumb

Posted 6 years ago

  • 0
  • 5
Photo of Desiree

Desiree, Alum

  • 7,270 Points 5k badge 2x thumb
Hi George,

In looking at the file path for the PDF file, it looks a bit weird:

C:\MyDocument.pdf

Is the document called "MyDocument.pdf"?

Can you try renaming it to something like "fax.pdf" and then save it to your Desktop. Then, try again?

Let me know.

Desiree


Photo of George Edwards

George Edwards

  • 130 Points 100 badge 2x thumb
Hi Desiree,

That's not the actual name of the document. I didn't want to post the real file name and path on a public forum, but it's a normal PDF saved on my desktop. As I said, I have tried with other PDFs and gotten the same error.

Thanks,
George
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
George, what is the version of the Softphone you are running?

4.75 001 .50

I just tried this on Windows 7 and attached a PDF with no issue.

Is your printer driver set to a PDF creator?

Just thinking out loud.

Chuck
Photo of George Edwards

George Edwards

  • 130 Points 100 badge 2x thumb
I am running build 4.75.001.50 on Windows 8. My default printer is set to my Adobe PDF creator.

Thanks,
George
Photo of brian park

brian park

  • 62 Points
i am having the same problem
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Hi all - anyone who is still having this issue, please make sure you're using the latest version of the softphone (look under About in the menu). We did address some Windows 8 bugs with recent softphone updates.
Photo of Sara Annette Bair

Sara Annette Bair

  • 62 Points
Using Build 5.16.001.50.  Still same problem
Photo of PeoplePhobic

PeoplePhobic

  • 64 Points
I had this problem for a long time. During install I would get the "Printer driver was not installed.  Operation could not be completed (error 0x00000002)." and the Ring Central Fax Printer driver would not install on my computer. There was a knowledge base article that suggested that I uninstall Service Pack 1, install softphone, then reinstall SP1. I was not willing to do this and have it mess up like everything else on my computer so I had been just attaching files on the website as a workaround. Over independence day weekend I needed to make a virtual machine to work on an unrelated project and I was using an older Windows 7 install disk which did not have any service packs (and I did not want to take the time to download and install them on this "throw-away" virtual machine). I forgot to delete it and had to send a fax and remembered the knowledge article and installed soft phone on the VM then used a a printer migration program that I used to use to back up printer configurations on an old server. Anyway, I was able to use this program to restore the RingCentral Internet Fax "printer"/driver to my office computer that is running Windows 7 Service Pack 1. Other than that I had to set my default program association from my (outdated) copy of Acrobat 9 Pro to the current version of Reader.

I don't know if this is the problem you are having. I was not able to attach any document of any kind via the softphone and the RingCentral Internet Fax "printer" was not present in my list of printers and when I attempted to add them manually I got that error mentioned above.  If the RingCentral Internet Fax "Printer" is present I would not attempt this.

This will make registry entries and stuff so you may not want to attempt it anyway... 

If you do decide to try this:  back stuff up, create a restore point, and beware: there may be dragons here.  I have not experienced any problems yet but that doesn't mean that you won't on your system.

I am mostly posting this solution in the hopes that RingCentral can use it to make a more elegant and user-friendly solution.

This conversation is no longer open for comments or replies.