Desktop App: Speaker Mode Missing

  • 0
  • 3
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)

Currently there is not easy way to put a call on Speaker mode on the RingCentral for Windows App. Apparently, the only way to do this is by opening the Audio Menu under Settings and manually switching the speakers to the computer speaker you want to use.

For users like ours, this is kind of a pain since we all use wireless headset. All the previous softphone I have used in the past offered the user the ability to set two sets of speakers. I could switch between my headset and speaker mode by just clicking a button (same way you do it on a desk phone).

Ringcentral for Windows is way more advanced than any of the softphone I have used and for it to be missing that functionality seems silly to me. This is a no brainer.

You guys are great at improving the app (thanks for the last round of features made available on the latest release). Can you look into this and make it happen?

Thanks!

Photo of Juan Sanchez

Juan Sanchez

  • 132 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 0
  • 3
Photo of Peter Gysegem

Peter Gysegem

  • 74 Points
I second the motion.
Photo of Mike

Mike, Official Rep

  • 91,080 Points 50k badge 2x thumb
You can toggle between your computer speakers and a headset by going to Settings > Audio and you'll see the window below. Just select the desired speaker/headset from the drop-down menu and then click the X in the top right corner to close the window. 

Mike 

(Edited)