The caller can't hear me when using the RingCentral app on my iPhone 7+.

  • 1
  • 2
  • Question
  • Updated 3 weeks ago
  • Answered
I've deleted and reinstalled the app several times with no luck.   My microphone works fine with any other app.  It seems like the app is not asking for permission to use the microphone.  Under Settings>Privacy>Microphone there are no apps listed requesting access to the microphone. 
Photo of Jim Westman

Jim Westman

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
  • 2
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
Hey Jim,

Is this happening on the RingCentral Mobile App (similar to the softphone) or the RingCentral Meetings App (the mobile version)?

Could you share a screen shot of the Settings section where the microphone should be?
Photo of Jim Westman

Jim Westman

  • 120 Points 100 badge 2x thumb
I'm using the RingCentral phone app.  I've attached screenshots of the app and the settings section for the microphone.  
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
Hmmm....that's odd since mine is showing up. I have an iPhone 8 with iOS 11.2.1

Which iOS are you on?
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
Also, what options do you see when you go to Settings -> RingCentral

Do you see the microphone option?
Photo of Jim Westman

Jim Westman

  • 120 Points 100 badge 2x thumb
I'm on 11.2.1.  

Here's a screenshot of the RingCentral settings. 
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
Well shoot....We definitely need to investigate this. 

To get a case to our developers please follow the instructions below:
  1. Tap profile icon
  2. Tap About
  3. Tap Send Feedback
  4. Include the issue description and feature requests in the body of the message
Make sure to include your account phone number and the best contact for yourself as well. Feel free to keep us posted!
Photo of Jim Westman

Jim Westman

  • 120 Points 100 badge 2x thumb
Thanks, I'll give that one more try, but I've been through that before and was told to contact Apple.  My phone isn't the problem.  
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
I let them know to expect your case :)
Photo of Saadet

Saadet, Employee

  • 68,830 Points 50k badge 2x thumb
Quick question, Jim! What do you have for: Settings – General – Restrictions – Microphone – Allow Changes? Could you share a screen shot?
Photo of Jim Westman

Jim Westman

  • 120 Points 100 badge 2x thumb
Ding! Ding! Ding!  - That's it - problem solved!  I switched the slider from "Don't Allow Changes" to "Allow Changes" and now I can hear the callers.  

Thank you so much,
Jim
(Edited)
Photo of Saadet

Saadet, Employee

  • 68,736 Points 50k badge 2x thumb
Hooray!!!!
Photo of Amanda Wollman

Amanda Wollman

  • 140 Points 100 badge 2x thumb
Hello,
I'm having the same problem as above:
Under Settings>Privacy>Microphone there are no apps listed requesting access to the microphone. 

I tried your fix however under "Settings-General", I do not have the option "Restrictions – Microphone – Allow Changes". 

As I know this thread is outdated can you provide an update? I'm also on an iphone 7
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 11,514 Points 10k badge 2x thumb
Hi Amanda, 

This is now under Settings - Privacy - Microphone - and ensure that RingCentral is on. 
Photo of Amanda Wollman

Amanda Wollman

  • 140 Points 100 badge 2x thumb
thanks jessica however ring central does not show up in this list.
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 11,514 Points 10k badge 2x thumb
Are you on the latest version of the app? 
Photo of Amanda Wollman

Amanda Wollman

  • 140 Points 100 badge 2x thumb
I've tried both the new 'R' app and the RC phone app.  No luck with either.
 
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 11,514 Points 10k badge 2x thumb
When you go to settings for the app under Settings - RingCentral in your phone settings, do you have the microphone enabled? 
Photo of Amanda Wollman

Amanda Wollman

  • 140 Points 100 badge 2x thumb
The option for microphone does not show up in the list.
(Edited)
Photo of Amanda Wollman

Amanda Wollman

  • 140 Points 100 badge 2x thumb
Figured it out!
"settings - screen time - content and privacy restrictions " 
Photo of Eric Amundson

Eric Amundson

  • 60 Points
Using iPhone 11 (SX max) with latest iOS. When I answer a call in the Ring Cental App I can hear the caller but they can't hear me. If they call my cell directly there is no problem. Microphone is enabled for Ring Central in the Privacy > Microphone settings. Microphone doesn't work on video call either. Check Screen time preference and all is fine there. Any ideas?
Photo of Mary Rose

Mary Rose, Official Rep

  • 1,092 Points 1k badge 2x thumb
Hello Eric,

Can you try to uninstall/reinstall your RingCentral App?