Unable to enable Auto Launch on Startup

  • 0
  • 2
  • Question
  • Updated 8 months ago
  • Answered
Whenever I go to the setting to enable launch on startup i get the error "Cannot change automatic launch option at the moment. There is no permission to modify operation system preference".

What the heck does this mean exactly?

I'm the admin on my PC.

Photo of Donovan Jones

Donovan Jones

  • 90 Points 75 badge 2x thumb
  • frustrated

Posted 8 months ago

  • 0
  • 2
Photo of Brandon

Brandon, Champion

  • 18,532 Points 10k badge 2x thumb
It sounds like it has to be a permissions issue with your machine.  Windows?  Version?  Are you joined to a domain and do you have access to change permissions or maybe ask your IT?
Photo of Donovan Jones

Donovan Jones

  • 90 Points 75 badge 2x thumb
Windows 10, I do have access to change permissions, any suggestions on which permissions i should change?
Photo of Sam - U.S. Support

Sam - U.S. Support, Employee

  • 1,558 Points 1k badge 2x thumb
Hello Donovan Jones,


This issue seems to be stemming from the app having limited permissions, even though you are logged in as a system admin.


Let's start off with the simplest option, and work our way down:


The first thing I would ask is to have you logout of the app, and then exit the app from the system tray.


Could you then select your start menu, search softphone.exe.


When you right click on softphone.exe, is there an option to run as administrator?

If so, can you then navigate to the settings and enable to automatically launch on startup? (if you can't locate softphone.exe when searching, navigate to:

c:/users/USER/appdata/local/ringcentral/softphoneapp/ (Note: USER will be the current logged in user).


If you are still unable to enable the option when ran as an administrator, could you locate your task manager via the start menu, right click and run as administrator if the option is available.


Select the startup tab within task manager.

Is RingCentral for Windows a row in this table?

If so, under the startup column, is it disabled / are you able to right click and enable it?


If you are unable to locate RingCentral for Windows under the Startup tab in task manager, it will need to be added to the startup folder.


To add RingCentral for Windows to the Startup folder:


Press the Windows Logo Key + R simultaneously


In the Run window type shell:startup, and then select OK. This opens the Startup folder. Minimize the folder for now, we’ll circle back to this.


Select the Start Button and search for softphone.exe (alternatively you can search RingCentral for Windows if you are unable to locate softphone.exe)

Right click, and select open file location.

If for some reason this brings you to an incorrect location, softphone.exe can be found in c:/users/USER/appdata/local/ringcentral/softphoneapp/ (Note: USER will be the current logged in user)


Locate and select softphone.exe from within the file location folder, right click and select copy.


Open up the previously minimized Startup folder.


Right click within the folder and paste a shortcut. (Note: in the previous step, you must right click and paste as a shortcut, instead of a normal paste which would copy the entire .exe). This should now allow RingCentral for Windows to start automatically.


Hopefully one of the above solutions gets you on the right track! If for some reason the app still will not start automatically, from the settings menu within the app use the submit feedback button. In the comments section give a brief description that it will not allow you to enable the setting to automatically launch on startup and the error message received. If possible, please the best possible callback and email information when submitting feedback via the app.


For a quicker response, I would also recommend giving our phone support a call at 888-898-4591 option 3, and an agent could try and assist 1 on 1.


Thanks,

Sam
(Edited)