Unable to log in to RingCentral Meetings from one Mac. Problem is identical to Eduardo's

  • 112
  • 40
  • Question
  • Updated 5 months ago
  • Acknowledged
  • (Edited)
About 4 days ago, RingCentral Meetings on one of my Macs (MacMini i7, 16GB, running OSX 10.11.6)  started exhibiting the same behavior as reported in the community forum by at least a half dozen users now. Every time I try to log in, RC Meetings reports I am not connected to the Internet, and I need to check my network connection. My Internet connection works just fine because I can connect to every other Internet service or website I use. I can even connect to the RingCentral Glip app. Because I can't log in, I am unable to connect to meetings and the floating window with Join Meeting / Start Meeting buttons won't load. FYI: I am running RC Meetings for Mac version 6.3.135305.1213, which is the most recent version as reported by the application itself.

At first, I thought the issue might be an account problem, but my tests demonstrated that wasn't the case. I was able to log in to my account from the web at service.ringcentral.com. Next, I attempted to use RC Meetings from my Mac laptop. Everything worked perfectly.

Now for the real clincher, I can log in to RC Meetings, and it works beautifully on the same Mac where I'm experiencing this issue when I boot the Mac from an external SSD running a slightly earlier version of MacOSX (version 10.10).  The only variation I have noted is a report by the MacOS network traffic inspection utility, Little Snitch, which reports RC Meeting's digital signature is different when running from the external SSD partition than when booting from my primary internal SSD. Little Snitch's messaging is a bit cryptic, but it suggests the application isn't signed on the Mac partition I can't log in from. I opened the application package and did some snooping around, and I discovered this in the plist XML:

It kind of looks like there might be something missing, don't you think? Of course, I might be barking up the wrong tree, but I've given you a whole bunch of information to investigate and resolve this issue.

Let's review. I eliminated all of these possible variables:

  • Not a firewall issue: No firewall in operation; no ports are blocked.
  • Not an account issue: I can log in to my account from service.ringcentral.com. I can log in from my Mac laptop. I can log in on the Mac I'm experiencing the problem on when booting from an external SSD with an alternative version of the OS.
  • Not a router or ISP issue: All testing has been accomplished using the same router and ISP.
  • Not a computer hardware issue: I can connect from the same Mac that can't connect when booting a slightly earlier OS version from an external drive.

Jessica - If you are reading this I would argue you haven't been doing your job (or a very good job) by directing folks experiencing this issue to submit tickets to tech support. I have a free account, and I haven't found a way to submit a ticket or interact the support team on chat. I wanted to expedite resolution of this issue so I tried to buy a paid subscription two nights ago. I tried two different credit cards, but RC's payment gateway reported it couldn't process my cards. It wasn't telling me it could authorize charges to my card (which my bank would have notified me about) so it sounds like Ring Central' payment processing might be offline. No help there.

As a community evangelist, it's your role, Jessica, to act as a facilitator who elevates customer concerns so they get the visibility within your support organization necessary for quick resolution. I am very glad to see that you created a ticket for Edoardo Tuo, who IMHO was treated in a condescending, unhelpful manner by J.B. Ferguson, who, again in IMHO, is not the kind of person you want representing RingCentral and its brand.

Right now, I have a very lukewarm opinion of RingCentral's customer service and support organization, which is a great opportunity for you to convert me from a skeptic to a fan. I'd start by forwarding my email to your executive response team so they can connect with your developers in hopes of getting this issue resolved quickly and easily for everyone experiencing it. 

Please send me the ticket number if you create a ticket for me. Thank you, and I look forward to hearing from you or someone else at RingCentral.

Len F. 
Photo of Len Fischer

Len Fischer

  • 580 Points 500 badge 2x thumb

Posted 1 year ago

  • 112
  • 40
Photo of JessDR


  • 250 Points 250 badge 2x thumb
Official Response
The 19.4 update finally fixed this!  I am now able to log in with my number and password and with my company Google account.

If you're looking for it, it's available at: