Unable to log in to RingCentral Meetings from one Mac. Problem is identical to Eduardo's

  • 21
  • 37
  • Question
  • Updated 6 days ago
  • Acknowledged
  • (Edited)
About 4 days ago, RingCentral Meetings on one of my Macs (MacMini i7, 16GB, running OSX 10.11.6)  started exhibiting the same behavior as reported in the community forum by at least a half dozen users now. Every time I try to log in, RC Meetings reports I am not connected to the Internet, and I need to check my network connection. My Internet connection works just fine because I can connect to every other Internet service or website I use. I can even connect to the RingCentral Glip app. Because I can't log in, I am unable to connect to meetings and the floating window with Join Meeting / Start Meeting buttons won't load. FYI: I am running RC Meetings for Mac version 6.3.135305.1213, which is the most recent version as reported by the application itself.

At first, I thought the issue might be an account problem, but my tests demonstrated that wasn't the case. I was able to log in to my account from the web at service.ringcentral.com. Next, I attempted to use RC Meetings from my Mac laptop. Everything worked perfectly.

Now for the real clincher, I can log in to RC Meetings, and it works beautifully on the same Mac where I'm experiencing this issue when I boot the Mac from an external SSD running a slightly earlier version of MacOSX (version 10.10).  The only variation I have noted is a report by the MacOS network traffic inspection utility, Little Snitch, which reports RC Meeting's digital signature is different when running from the external SSD partition than when booting from my primary internal SSD. Little Snitch's messaging is a bit cryptic, but it suggests the application isn't signed on the Mac partition I can't log in from. I opened the application package and did some snooping around, and I discovered this in the plist XML:

It kind of looks like there might be something missing, don't you think? Of course, I might be barking up the wrong tree, but I've given you a whole bunch of information to investigate and resolve this issue.

Let's review. I eliminated all of these possible variables:

  • Not a firewall issue: No firewall in operation; no ports are blocked.
  • Not an account issue: I can log in to my account from service.ringcentral.com. I can log in from my Mac laptop. I can log in on the Mac I'm experiencing the problem on when booting from an external SSD with an alternative version of the OS.
  • Not a router or ISP issue: All testing has been accomplished using the same router and ISP.
  • Not a computer hardware issue: I can connect from the same Mac that can't connect when booting a slightly earlier OS version from an external drive.

Jessica - If you are reading this I would argue you haven't been doing your job (or a very good job) by directing folks experiencing this issue to submit tickets to tech support. I have a free account, and I haven't found a way to submit a ticket or interact the support team on chat. I wanted to expedite resolution of this issue so I tried to buy a paid subscription two nights ago. I tried two different credit cards, but RC's payment gateway reported it couldn't process my cards. It wasn't telling me it could authorize charges to my card (which my bank would have notified me about) so it sounds like Ring Central' payment processing might be offline. No help there.

As a community evangelist, it's your role, Jessica, to act as a facilitator who elevates customer concerns so they get the visibility within your support organization necessary for quick resolution. I am very glad to see that you created a ticket for Edoardo Tuo, who IMHO was treated in a condescending, unhelpful manner by J.B. Ferguson, who, again in IMHO, is not the kind of person you want representing RingCentral and its brand.

Right now, I have a very lukewarm opinion of RingCentral's customer service and support organization, which is a great opportunity for you to convert me from a skeptic to a fan. I'd start by forwarding my email to your executive response team so they can connect with your developers in hopes of getting this issue resolved quickly and easily for everyone experiencing it. 

Please send me the ticket number if you create a ticket for me. Thank you, and I look forward to hearing from you or someone else at RingCentral.

Len F. 
Photo of Len Fischer

Len Fischer

  • 550 Points 500 badge 2x thumb

Posted 8 months ago

  • 21
  • 37
Photo of Charles Ingalz

Charles Ingalz

  • 60 Points
Looks like I'm in the same boat.  I can only use this in my phone now, all our Macs are now down after what appears to be a recent RM update.  This is on both OSX 10.13.6 and 10.14.  I am updating one machine to 10.14.2, but from what I see here, it probably wont work. Will need to buy another meeting account to get by for now as getting right apps/sharing to appear on new user will be too cumbersome.
Photo of Nic NC

Nic NC

  • 90 Points 75 badge 2x thumb
 [I am on a Mac (OS X 14.3) and RC Meetings ver. 6.315305.1213]

This is a poor workaround, but for me has been effective. Hopefully the issue can be resolved, but I have found that when I log in on my standard computer user account, I could not log in. I created a second user account and found I could log in. But, soon after, had the issue reappear on the new user account. So, then I tried using the guest account, and since documents and settings are not saved, I am able to log in to my account via the desktop application (for now, that is). 
Photo of Craig Chapman

Craig Chapman

  • 124 Points 100 badge 2x thumb
I only just started experiencing this issue today on a meeting I ended up rescheduling. I'm able to log in as host on my iOS devices and also on a Mac that I rarely use for meetings which has an older version of the RC Meetings app on it.

The other weird thing is that I can log in using my Zoom.us account as a host (this is the company RingCentral licenses their Meetings technology through), so clearly this is an issue with the latest version of the RC Meetings app.

Sorry, but I'm not going to be creating a separate user account on my Mac just for this. It's less of a pain for my phone to act as host and then my Macbook to log on as a user.

Hopefully, we'll see a fix soon.
Photo of John Sutcliffe

John Sutcliffe

  • 84 Points 75 badge 2x thumb
Is there any update on this? This just started to happen for me last last week (March 26 or so). Starting the app via the command line using SUDO works, but is not a great solution for my users. 

How close is the fix for this? It looks like a new release was expected at the end of March. 

Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,558 Points 50k badge 2x thumb
Sorry, John. There is no update on a fix yet
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
Hello ! This is going in for a while now and is not good for the business at all, when do you plan to fix this ? Thanks
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 65,558 Points 50k badge 2x thumb
Sorry, Richard. There are no updates at this time :(
Photo of Andrew Stansbury

Andrew Stansbury

  • 64 Points
Hopefully, you guys fix it soon. I can connect from the mobile app but not my Mac it just says  "Please check your network connection and try again" 
Even though I can  connect to other websites
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
So we should request for a credit on our account because of the service that we pay for and it is not working.
Photo of Matt Decker

Matt Decker

  • 190 Points 100 badge 2x thumb
LOL.. this company is a joke .... I said 2 months ago RingCentral had no interest in fixing their problem or supporting Mac and people jumped on my case telling me I was wrong  ... and gee guess what I was right ...  these guys have done nothing but dick everyone along  for months feeding lip service and lies ... you people at RingCentral should be embarrassed and ashamed ... the only up side to this whole fiasco is that the market place will correct the problem in time when Ring Central goes belly up.... I am guessing this big operation with its tier 3 tech support is nothing more than 2 uneducated hicks in some single wide trailer in Wewoka Oklahoma ... no offense to anyone who may live there .. i am sure it has its good points too  even tho  it is #1 for the worst cities  in Oklahoma 2019..... whats that sucking sound I hear ... its RingCentral going down the toilet ...you may be growing now but with such a flawed business model and blatant disregard and distain for Mac users and piss poor customer support it won't sustain its self for very long ... Doubt my posting will stay up long before its pulled down because I am not conforming to company policy about pumping sunshine  but hopefully it stays long enough to help some other poor folks who may buy into this colossal waste of valuable time and energy ... best of luck Ring Central ....  I dare you ... prove me wrong with a viable update that rectifies your planned and premeditated problem 
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
I’m a customer for more than 8 years in Canada. I was always happy with the service and I sent several customers to RingCentral. Now for 2 months, we are not able to use Ring Central for Meeting on our Mac. We need this tool everyday and we are loosing deals because of this.

I’ve been told that end of march that would le be fixed, we are now almost end of April and it’s not fixed yet. I consider cancel my service in a couple of days if there is not fix.

Good luck everyone.
Photo of Aaron McCloy

Aaron McCloy

  • 74 Points
I've already told the start up I work with not to use Zoom or Ring Central. It's not possible because it doesn't work. The support has been embarrassingly bad. I've gotten the run around for 90 minutes only to find that this thread has been around for months with no updates. They need to tell their customers and users that there is no solution. I'll never use Zoom/Ring Central again. 
Photo of Back Email

Back Email

  • 60 Points
Time to delete the app and move on. RingCentral are clearly not going to fix this.
Photo of Trevor Parks

Trevor Parks

  • 114 Points 100 badge 2x thumb
Pretty much.  The saddest and most telling part is the support representatives stopped replying or commenting on this thread over 2 weeks ago.  What is the 1 thing worse than not fixing the issue? Abandoning the issue and affected customers to avoid it. The way this issue has been handled is a case study on how to end your business. Seriously, although it doesn't affect every customer, this response signals major trouble if more customers discover how it has been handled. Primary concerns include:

  • RC not having been prepared for a change that has been long communicated
  • RC spending months working on a "solution"
  • When the solution arrives, it works for nobody
  •                This is particularly concerning, because this would imply that RC never tested their                   solution or worse, explicitly lied about a solution being developed in the first place
  • The defensive comments from RC representatives instead of empathetic words or gestures, eventually ending with the abandonment if the issue by RC

These actions have never had a good outcome for any company, but especially a technology company the wants to specialize in communications products.  

Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 64,682 Points 50k badge 2x thumb
Hi Trevor, I understand how frustrating this issue is. Thisissue does not only affect RC users but also Zoom users and our Product Team isworking with Zoom on this issue.

Our Community team is listening and reporting back to theappropriate teams internally. Unfortunately, we do not have an update at thistime. As I’ve mentioned previously, we will let you all know when we do.
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
I did some research and I’ve been told by a trusted contact at zoom that they are not using the same version as RC and they do not have any issues with MAC. We are looking at several replacement right now...It’s not easy to decide to leave a company that you are in business with since 2012, but after 2 months, it’s really difficult to manage and we have frustrated customer that can not get online demo and training as it should be.
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
Any news on a fix or a new ring central meeting version ?
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 7,452 Points 5k badge 2x thumb
Not yet! 
Photo of Richard Fortin

Richard Fortin

  • 202 Points 100 badge 2x thumb
Any news on a fix or a new ring central meeting version ?
Photo of Kris


  • 294 Points 250 badge 2x thumb
My Meetings works now, version 7.013.  I logged in to Ringcentral on the web, went to Settings/Meetings/Download and there is a new version.

Works fine, 64 bit, etc.
Photo of Saadet - Community Moderator

Saadet - Community Moderator, Official Rep

  • 66,160 Points 50k badge 2x thumb
Official Response
Hi all, our Product Team is working with Zoom to get a fix established in Q4 of this year. If that changes, I'll let you know!
Photo of Lucky Star

Lucky Star

  • 60 Points
Hi:  any progress towards solving this problem.  I just installed Catalina hoping the problem would be fixed but same result.