Unable to Start Meeting Using RC Meeting on a Mac

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • Acknowledged
Hi

I am unable to start or schedule a meeting using RC Meetings App on a Mac.  It did work about a month ago, but when I tried to either start a meeting ad hoc or schedule, nothing happens.  I am able to join someone else's meeting without issue.

OS X Mojave 10.14.2
RC Meetings:  6.3.135305.1213

Steps & Outcomes:

1.  Start up RC Meetings
2.  Sign in using my email address
3.  All of the circle buttons appear with a blue ring
4.  If I hit Start Without Video, nothing happens.  No new window, no indication any event happened.  
5.  If I attempt to schedule a meeting, the window pops up, but it won't stick.  No meeting shows up on my calendar.
6.  When someone attempts to join a meeting with my Personal ID, RingCentral says they can not join and kicks them out.

I have tried a new installation.  Deleted the app, ran the installer.  It doesn't provide feedback that it was successful, except launch RC Meeting.

I'm looking for how to fix the issue of not being able to start or schedule a meeting.

Thanks
-Mike
Photo of Mike Maurer

Mike Maurer

  • 70 Points

Posted 9 months ago

  • 0
  • 1
Photo of Jessica - Community Moderator

Jessica - Community Moderator, Official Rep

  • 7,884 Points 5k badge 2x thumb
Hi Mike, 

If you are scheduling through Outlook, you'll need the latest download for Mac, available here. I would open a case with Support for some further troubleshooting regarding the other issues.