VVX600 Assited Provisioning

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I'm based in the UK and have just got a load of Polycom VVX600 phones to replace the desktop app, mainly as they are supported on RingCentral and our Bluetooth headphone work seamlessly with them.

The problem I have, is that none work guide the assisted provision steps.  I have to use the manual process. 

I have upgraded one phone to the very latest  Polycom Firmware and still no joy.

Does the assisted process provide additional features/integration with the RingCentral server, that you do not get when manually provisioning them?
Photo of Chris Farmer

Chris Farmer

  • 152 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Nathan Malone

Nathan Malone, U.S. Tier 2 Support

  • 4,720 Points 4k badge 2x thumb
Hello Chris,

When you look at the phones on the account are they labeled as a VVX600 phones or are they labeled as "Existing Device"?

If the phone is registered to our system and labled as a VVX600 then you have all the features for the phones. If they are registered as an "Existing Device" then the phone will not have full features.
Photo of Chris Farmer

Chris Farmer

  • 152 Points 100 badge 2x thumb
Hi Nathan,

I tried both options, but when saying the model, using the assisted method, the phones would boot, but the line would have a red x on and it would also say that a configuration error:Missing Files,config, reverted/  So to get the phone to work, I have to select the other option.

If you have some diagnostic steps I could use, I willing to try the assisted method once again,
Thanks

Chris
Photo of Nathan Malone

Nathan Malone, U.S. Tier 2 Support

  • 4,720 Points 4k badge 2x thumb
Hello Chris,

The VVX600 is not fully supported, but if we have a config file for it, it should work.

Try this for me, log into the phone's IP address and reset the phone to factory defaults if not already done. You can reset to factory by going to "Utilities", "Phone Backup and Restore", "Global Settings", "Restore".

Once the phone has been factory defaulted, go to "Settings", "Provisioning Server", Under the "Provisioning Server" tab set the "Server Type" as HTTPS, set the "Server Address" as pp.ringcentral.com/pp, make sure that the "Server User" and "Server Password" fields are empty so delete anything that you may see in there.

Then under the "DHCP Menu" tab set the "Boot Server" to Static. Once these settings are entered press Save at the bottom of the page.

You will have to set to phones from "Existing Devices" to VVX600's in order for this to work, make sure you enter the serial number of the phone correctly in the system.

Let me know if that works.