Web Phone Unavailable / Please grant RingCentral for Google to access your audio.

  • 0
  • 1
  • Question
  • Updated 2 weeks ago
  • Answered
  • (Edited)
After the latest update, I can no longer initiate calls in my browser. Anyone else experience this?

I do not have a webcam or microphone on my machine, but I used to be able to click on a phone number in a Chrome browser and have the system dial out from my desk phone. Now, the RingCentral window opens and generates the above error message.
Photo of jesse

jesse

  • 216 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Mark Ryan

Mark Ryan

  • 334 Points 250 badge 2x thumb
Hi.
Most likely you have to tell the new extension what device you want to use to make browser calls. I had the same issue.

Top right, click on three lines (hamburger) then to bottom of list Setting (gears) then "Calling" then  "Make my calls with" change to My RingCentral Phone.

Hope that helps,
Mark
Photo of jesse

jesse

  • 216 Points 100 badge 2x thumb
Thanks! It wasn't under the Chrome three-dot settings, but I looked around and found a menu in the RingCentral window that allowed me to change it from "Make calls in my browser" to "Make calls with my RingCentral Phone". That did the trick.
Photo of jesse

jesse

  • 216 Points 100 badge 2x thumb
This function has quit working again with the latest update, and I can no longer find the menu option to turn off the "Make calls in my browser" default. The new menu only allows me to control which websites are blacklisted from the Quick Access menu. I do not have a Chrome setting for "Calling" either.

Does anyone know if/where these settings can be changed? 
Photo of Jessica - Community Support

Jessica - Community Support, Official Rep

  • 270 Points 250 badge 2x thumb
Hi jesse, 

You should be able to click the red banner that says "Web Phone Unavailable", and approve microphone access in the same type of popup.

If that doesn't work, you will have to go through the Chrome settings directly. You can see your microphone settings by navigating to chrome://settings/content/microphone?search=microphone in Chrome. If you see RingCentral for Google in the "Block" list, you will have to remove it by clicking the trash can icon to the right, then quit and reopen Google Chrome and the RingCentral for Google extension. When the extension opens you should be prompted for access to the microphone again, or you may have to click the red error message again.

There's more information on Google Chrome's microphone settings and troubleshooting tips at their Use your camera & microphone page as well :) Let me know if that does the trick! 
Photo of jesse

jesse

  • 216 Points 100 badge 2x thumb
Thanks, but I've tried this before, and it does not help. 

When I click on the "Web Phone Available" banner, it just brings up a message saying "Please grant RingCentral for Google to access your audio" [sic]. Clicking on that message does nothing, and there is no option to grant access to audio devices.

When I cut and paste the Chrome settings link you provided, it shows me that no sites are blocked from microphone access. If it matters, there is no microphone plugged into this machine. 

When this problem occurred a few months ago, I was able to fix it by changing the "Make calls in my browser" setting within the RingCentral app, but that setting no longer seems to be accessible in the latest update.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 42,580 Points 20k badge 2x thumb
Hi jesse, I would try what Jessica mentioned again after a complete uninstall/reinstall and clearing cache and cookies. If you're still having issues I would try a different computer as well - this will help narrow down if it's somehow machine related. I would also open a case so that our Integrations Team can take a look and help you out!