Calls to cell phone # interrupt the connected call on Mobile App.

  • 6
  • 46
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
We can be chatting away to a customer, when a new call comes in. It puts the call we were on, on hold while giving the option to accept or decline the new call.Aren't all calls supposed to go to voicemail??? This is a pain, we are coming across as RUDE.
Photo of Stephanie Leman

Stephanie Leman

  • 510 Points 500 badge 2x thumb

Posted 6 years ago

  • 6
  • 46
Photo of Kim

Kim, Alum

  • 43,854 Points 20k badge 2x thumb
Official Response
If you are on a call on the RingCentral iPhone App and a call comes into your regular cell phone carrier, the call on the RC App will get pushed to the background.  The RC app acts like any other app and the primary call to your cell phone will always that priority and close (move to the background) any other app that you are have open.  

Think of it like this....if you are playing on the Angry Birds App and a call comes into your primarily cell phone, the Angry Birds App moves to the background and the call takes priority.  
Same concept applies to the RC App.

This is the design of the cell phone. 
(Edited)
Photo of Ted

Ted, Product Manager

  • 870 Points 500 badge 2x thumb
Official Response
Hello.  

Chuck and Kim are correct that the behavior is controlled by the native operating system.  As the OS takes over control of the app running in the foreground, it will also take control over the audio stream.  It will only release the audio stream once the native (cellular) incoming interruption has completed its task.


Apple does not provide VoIP app developers with API’s to be able to control and prevent native interruptions.  Starting with iOS 8, Apple has started to introduce some functionality specific for VoIP apps, but unfortunately still no capabilities to prevent native interruptions.  We’re hoping this is a sign that Apple will one day provide API’s to allow VoIP apps to have full control in a future iOS release.


In the interim, here’s some options to continue to use your RingCentral number for calling (inbound and outbound) and not have to give out your personal cellular number.  Your inbound and outbound calls will be cellular calls, not VoIP, so if you receive an incoming native call to your personal cellular then iOS will give you control to handle the call as you’d like.


Inbound Calling Setup:

1) Setup a call forwarding rule to your personal cellular number.  You can do this in the “Call Handling & Forwarding” setting in the RingCentral mobile app by going to Settings->Extension Settings->Call Handling & Forwarding 

   Or from the service.ringcentral.com website by going to Settings-> ->Call Handling & Forwarding

2)   To make it easy to identify this is a business call to your RingCentral number you can do the following.

From the RingCentral mobile app go to Settings->Extension Settings->Call Handling & Forwarding->Incoming Call Information

Or from service.ringcentral.com go to Settings-> ->Call Handling & Forwarding->Incoming Call Information

   a) Add a prefix to the beginning (or end) to the incoming caller ID. 

   b) If you want, you can control it so it only displays the prefix on non-RingCentral phones, like your mobile device.

Outbound Call Setup:  Use our RingOut functionality, by turning off “VoIP Calling” in Settings in the RingCentral mobile app. When you place a phone call from the app, it will place the call as a cellular phone call, but will continue to show your RingCentral phone number as the Caller ID (not your personal cellphone number).

P.S.  Google Voice forwards inbounds calls over the cellular network and places outbound calls as cellular calls.  The Google Voice app does not place VoIP calls.  Since they are cellular calls this is why incoming native cellular calls
(Edited)
Photo of Benjamin Nwosu

Benjamin Nwosu

  • 60 Points
I found a way to temporarily stop this interruption for those using iPhone. Go to setting, then go to Do Not Disturb and turn on the manual button or you can schedule a time you do not want to receive native calls. If you do this there will not be any interruption with your app or VoIP calls when there is an incoming native call. Remember to go back and turn off Do Not Disturb when you are done with app or VoIP calls or else you will not be able to receive any incoming native calls. Repeat this whenever you want to make app or VoIP calls with your iPhone. I hope this helps. Good luck. Ben
(Edited)
Photo of Ronda Tappan

Ronda Tappan, Champion

  • 878 Points 500 badge 2x thumb
If you turn off VOIP calling and turn off call waiting on you mobile device, your calls will NOT be interrupted.  For instructions:  http://www.tappansolutions.com/ringcentral-call-interruptions-mobile/#more-538  Not for everyone... but a simple work around.
Photo of Ronda Tappan

Ronda Tappan, Champion

  • 878 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Turn off call waiting on iPhone to stop interruptions on the RC App.

If you are using your iPhone regularly rather than the softphone on your PC/Mac, you may want to turn two features off to avoid call interruptions from people calling you on your mobile device.  You need to ensure inbound and outbound calls will be cellular calls, not VoIP. 

On the iPhone disable call waiting.  This will send all callers to voicemail if your cell line is active.
  • Go to Setting
  • Phone
  • Call Waiting
  • Disable Call Waiting
Turn off VoIP in the RincCentral App

  • Launch the RingCentral App
  • Click on the your profile picture, or the icon
    to the left of your name to go into your profile
  • Turn off VoIP Calling
By turning off VoIP, you are forcing the RingCentral  calls to go out on the cellular network.  So you are using your cell phone to make the call.  The callers only see your  RingCentral Caller ID.  RingCentral logs the calls as normally.
Photo of Michael Larssen

Michael Larssen

  • 366 Points 250 badge 2x thumb
The work around does not work for me because the whole reason I got RingCentral is for VOIP. My cell services is not as reliable or as clear as my VOIP. Help!!!For people who do not want to be tethered to a desk this is very important!!
Photo of Joshua Tagg

Joshua Tagg

  • 218 Points 100 badge 2x thumb
Hi Michael - When I wanted to use VoIP exclusively, without worrying about incoming calls working, I simply forwarded my cell phone to the RC number. As far as I can tell, that is the only way to avoid this issue, and actually use VoIP. Unfortunately, this isn't a problem that RC will ever be able to fix on iPhone because Apple sandboxes applications, and the application "Phone" always take precedent over any other app. I think on certain Android installations you might be able to change the default app for dialling out, but the incoming call issue is the same as Apple. That is why call forwarding your incoming calls is the only way to avoid incoming calls.
Photo of Victor Paolo Lopera

Victor Paolo Lopera

  • 114 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Mobile App: call waiting ios (iPhone).

  1. Account type  - US
  2. A brief description of the business - n/a
  3. A high level description of the product or feature being requested - call waiting for IOS mobile apps
  4. A typical use case scenario explaining how your business would use the feature - n/a
  5. Benefit of such feature - Feature will allow customer to receive calls from Ringcentral even if his iphone is currently engaged in a call
  6. Include any related case number if applicable - n/a
Photo of Michael Antonio

Michael Antonio

  • 426 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Create a setting in RC app so native mobile phoen calls do not cut off your RC ap....

Call to mobile numbers on iPhone interrupt and disconnect RC app phone calls. Its very disrupting, there needs to be a setting where I can choose that I want my native mobile calls to go to voicemail if I am on a call on RC app and do not want to be disconnected by my native mobile calls.
Photo of RC-Installer

RC-Installer, Champion

  • 27,736 Points 20k badge 2x thumb
Hey Guys, I have talked to RC Engineering on this one a while back and the fact of the matter is that Apple will NOT let any other service or app get in the way of a call coming directly to their phone.  The call to the cell directly always gets priority.

On the Android platform (Just so you know, it does not work that way and you get the choice to answer or ignore the call.  I am not sure if anything has changed but knowing Apple  this is how it is.

The only thing I could think of is either forward your cell phone to to RC so all the calls come in that way.  (not ideal for most people but may work)

You should do your home work before switching because unless RC is not being truthful, others will have the same issue.  Since, it works on the Android platform I would say it is a Apple limitation.

Do you own testing.

My 2 Cents

Chuck
Certified RC Installer
Photo of ZWILLING

ZWILLING

  • 196 Points 100 badge 2x thumb
How do you do it on an Android? 
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 37,222 Points 20k badge 2x thumb
Zwilling,

Depending on which Android phone you have and which operating system version it is using, it does not have the same issue as Apple does. On my Android phone (Droid Turbo) using the most up-to-date OS (v5.1) it rings separate of the RingCentral application. It gives me a small pop-up at the top of the screen giving me the option to "Dismiss the call" (and send it to voicemail) or to "Answer the call" (and put the current call on HOLD).


Photo of Amy Gartman

Amy Gartman

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Turning off automatic hold when incoming cell phone call.

This idea is coming from a US based insurance financial company. Ringcentral has a phone app where we can make and receive work calls through the app. However, if we get an incoming call to our cell phone it will automatically put the Ringcentral call on hold (with no warning) so that
we can answer the actual cell phone call. It would be great if we were able to turn this feature off, or at least have the option to answer it or not. This would be extremely helpful because then we wouldn't need to worry about work calls being put on hold in the middle of a potentially important conversation. 
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 37,222 Points 20k badge 2x thumb
Amy,

You don't indicate whether you, or others in your office, are using iPhones or Android phones.

If your users are using Android phones and depending on which Android phone you have and which operating system version it is using, it does not have the same issue as Apple does. On my Android phone (Droid Turbo) using the most up-to-date OS (v5.1) it rings separate of the RingCentral application. It gives me a small pop-up at the top of the screen giving me the option to "Dismiss the call" (and send it to voicemail) or to "Answer the call" (and put the current call on HOLD).

Photo of Shurhold

Shurhold

  • 804 Points 500 badge 2x thumb
YES, IOS10 fixes this.  Please update your app ASAP!
Photo of Jesus Anaya

Jesus Anaya, Champion

  • 898 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Mobile App: Call to mobile number rings over an ongoing call in the RingCentral A....

This happens on both Android and Iphone devices. Is this a settings / misconfiguration on my part or is this an issue with the mobile OS? This also happens in the Chrome Extension/Google integration. 
Photo of Mike

Mike, Official Rep

  • 93,998 Points 50k badge 2x thumb
Official Response
Just letting everyone following this thread that there is now some new CallKit functionality.  You can view these new articles for details. 

Call Interruption on iOS

iOS10 CallKit Support
(Edited)
Photo of Cecile Glassy

Cecile Glassy, Champion

  • 21,546 Points 20k badge 2x thumb
Mobile App v8.4.1 on Android Samsung S7 Galaxy Phone:   On active Ring Central Call - another incoming Ring Central call rings over and interrupts the active call.   This is not the situation where it is a carrier call (Verizon) incoming on top of the active call.     This really needs a fix. It seems like turning off VOIP calling will disable all incoming Ring Central calls?  That is not a viable solution for us. 
Photo of Mike

Mike, Official Rep

  • 93,998 Points 50k badge 2x thumb
Creating new topic thread.

Please reference the new conversation here: On active Ring Central Call - another incoming Ring Central call rings over and i...
Photo of Rick Dhatt

Rick Dhatt

  • 346 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Carrier Incoming call interrupts ringcentral call on Android.

Hi,

Account type: Canada

My employee is using an android google pixel and when using the ringcentral app to make a voip call it gets interrupted with a carrier incoming call.  The iphone app uses integrated calling. Is there a setting or way to have android behave in the same way as iOS integrated calling without getting interrupted?
Photo of Jauvarie Lewis

Jauvarie Lewis

  • 274 Points 250 badge 2x thumb
Has this been updated yet because it s really annoying.
Photo of Luke

Luke, Training Specialist

  • 3,828 Points 3k badge 2x thumb
Hi Jauvarie,

Referring to what Kim stated originally about the RingCentral Phone app on iPhone, this issue was resolved when Apple released iOS 10 in 2016, which allows 3rd party apps to receive calls the same way that the native phone app does. What this means is if you are currently on a RingCentral phone call, and you receive another inbound call, you should see the options to End & Accept, Send to Voicemail, or Hold & Accept.

In order to use this feature on an iPhone you need to ensure that the "Integrated Calling" feature is turned on in the settings of the RingCentral Phone app. See our RingCentral Integrated Calling article for more information.

I am unable to test on an Android device at the moment, but I will get some testing done when I can and let you know what to expect there.
(Edited)
Photo of Luke

Luke, Training Specialist

  • 3,828 Points 3k badge 2x thumb
I did some testing on a Samsung Experience Android device on Android 7.0. While on a call using the RingCentral app, a call was placed to the cellular number and I was able to see the same options asking how to handle the new inbound call.

It's possible the issue resides in the settings or configuration of the Android device. Are there any updates available for either the RingCentral Phone app on the device or the operating system?
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 37,222 Points 20k badge 2x thumb
Your comment about the iPhone and iOS10 is only correct insofar as receiving any calls to the cellular number. RingCentral still has an issue with the functionality of Call Waiting with the Mobile App on iPhones.

I started a case in February 2017 and I was advised it would be taken care of in the next release. There have been numerous releases since then (now 14 months later) with no resolution.
Photo of Luke

Luke, Training Specialist

  • 3,828 Points 3k badge 2x thumb
Correct Jan,

we have an idea post going for the call-waiting feature on the mobile app here:

https://community.ringcentral.com/ringcentral/topics/add-call-waiting-as-a-feature-for-the-mobile-app
Photo of J.B. Ferguson

J.B. Ferguson, Champion

  • 37,222 Points 20k badge 2x thumb
Luke... The long and short of it is that this should not just be an idea. It is capable in the android mobile application and should be also capable in the iOS mobile application. I know for a fact that it is not in iOS issue because I know personally of three other VoIP providers that do indeed have this functionality of call waiting in their mobile applications on the iOS platform. This is what is so frustrating.

It hit me personally in February 2017 after I learned that I lost a potential client as an RC Partner because I was on a call with a current client while out of the office on the RingCentral mobile app when they tried to call me. Because I did not answer the call and for whatever reason they did not leave a message it turns out, I learned later, that they went to another provider. I lost out and so did RingCentral. That’s one I submitted my case, which has since been closed because they turned it into an idea.... and idea that nothing has happened on for over 13 months.
Photo of Michael Larssen

Michael Larssen

  • 366 Points 250 badge 2x thumb
They keep telling me it’s the way the phone works and they can’t correct it!