Zendesk Integration

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Answered
Unable to make or take calls via Zendesk app.
Says Unable to connect.
The call appears to go to my RingCentral number (softphone) (only when dialed from Zendesk)
and there is notanswer option when a call comes in.
Photo of Vineesh Menon

Vineesh Menon

  • 160 Points 100 badge 2x thumb
  • frustrated

Posted 4 months ago

  • 0
  • 1
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
Hello Vineesh,

I would suggest contacting our Support Team as well as Zendesk's. It may be something on their side or ours, but won't know until investigated.
Photo of Vineesh Menon

Vineesh Menon

  • 160 Points 100 badge 2x thumb
I found this in User guide , Help me understand the workflow. We dont have desk phones, we use only softphone.
There are only two options to set. You can get to these options by clicking on the gear icon in the top navigation bar. 1. Direct Number: This is the number from which outgoing calls will be made. This field cannot be left blank. 2. Press 1 To Start A Call: When you make an outgoing call, RingCentral will first call you at your RingCentral Direct Number. Once you answer the call, you will have an option to press “1” before the call is connected to the other party. If this option is not enabled, then RingCentral will call your number and the dialed number simultaneously. Click the “Save” button to save your settings. These settings are cleared when the user logs out of the Softphone application, but will persist if the user logs out from Zendesk instance without logging out from the application and had also selected the option “Remember Me” on the login screen while logging in.
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
Can you please share the User Guide you found?
Photo of Vineesh Menon

Vineesh Menon

  • 160 Points 100 badge 2x thumb
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 33,194 Points 20k badge 2x thumb
Thanks, Vineesh.

Basically, when making outgoing calls you have the option of Zendesk simply calling your softphone (from which you answer) or you can set it up so that when Zendesk calls your softphone, you have to press 1 in order to accept the call. It's user preference. The User Guide continues to talk about this preference when going over how to place outbound calls
Photo of Vineesh Menon

Vineesh Menon

  • 160 Points 100 badge 2x thumb
What I dont understand is when I am making an outbound call to a customer, why is it calling my softphone? And how can press 1? when I am actually dialing out?
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 24,200 Points 20k badge 2x thumb
Hi Vineesh, Zendesk simply integrates with us. The calls will still be going through the RingCentral system, therefore, it uses the Softphone in order to complete the call. If you don't want to press 1 you can set it up so that Zendesk calls your softphone and all you have to do is answer. If you are having issues getting this set up, it would be more beneficial for yourself to speak with someone live. You can either contact our Support Team or Zendesk's Support Team for more information.
Photo of Vineesh Menon

Vineesh Menon

  • 160 Points 100 badge 2x thumb
Okay. I think I need to contact support. Zendesk could not help. Still confused as to why is Zendesk calling softphone. The integration is supposed to make the calling out experience seemless. Why should I answer a call in softphone to be able to connect to a customer