Question

"Please install the RingCentral audio device" message after Catalina update

  • 11 February 2020
  • 6 replies
  • 699 views

After updating to Catalina, I keep getting this same message every time I try to share my screen in a meeting. I can't figure out why this is happening. Please advise!


To share your computer audio, please install the RingCentral Meetings audio device. Please restart your audio sharing application, such as the media player, after install to continue sharing computer sound.



6 replies

Hey John, 

What happens when you enter your password to allow the app to restart? 
Thanks for replying! Once I type in my password, it prompts me to enter the meeting ID - which works but previously - it would often just detect which meeting or room I was in and immediately start sharing my content. Also - nothing really restarts. I'm being prompted with this every time I attempt to share my screen. 



Currently working on this issue as well with a deployment to my users. My users do not have administrator credentials so they cannot get by this screen.

It seems like the audio drivers do not self install, they are located in  /Applications/RingCentral Meetings.app/Contents/PlugIns/ZoomAudioDevice.driver which needs to be copied to the /Library/Audio/Plug-Ins/HAL/ directory.

We achieved this with the terminal command (note do not have a trailing / at the end of ZoomAudioDevice.driver):
sudo cp -r /Applications/RingCentral Meetings.app/Contents/PlugIns/ZoomAudioDevice.driver /Library/Audio/Plug-Ins/HAL/

If you reboot then everything should work fine.

If you would like to avoid rebooting use the commands:
sudo kill $(ps -eaf | grep "RingC" | grep -v grep | awk '{print $2}')
sudo killall coreaudiod

Then open RingCentral Meetings again and you should be good to go.



I need to share a video WITH SOUND in RingCentral Meetings (in a couple of days) and I am getting this same message that I need to install the RingCentral Audio Device. I am just using a MacBook Air with Catalina 10.15.3. Not using RCRoom, just a laptop wanting to share a video in RCMeetings playing video with default Quicktime. When prompted, I type my admin password, but nothing happens and the sound from the video does not get shared - only the video image. PLEASE THIS IS URGENT I NEED TO SHARE AN IMPORTANT VIDEO WITH SOUND VIA RCMEETINGS IN A COUPLE OF DAYS. (yes, I am shouting)

Hi Everyone,

I am getting this same error message. I can locate  /Applications/RingCentral Meetings.app/Contents/PlugIns/ZoomAudioDevice.driver but cannot locate to copy it to. I also tried entering a meeting from GLIP and that still gave me the error message to install the audio device. Does anyone else have anything that's working for them?

Jen

I have this problem now with new MacOS update. Please helpscreen-shot-496.png

Reply