News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
ringcentral with plantronics savi 7xx headset
Tags: hardware
Nov 2, 2017 at 4:07pm   •   13 replies  •  0 likes

i use a plantronics savi 7xx headset with my ringcentral account. this headset allows me to simultaneously connect both my desk phone and the softphone on my computer. i can pickup and initiate calls on either the desk phone or the softphone, routing audio through the headset. but there is a problem that i cannot figure out. outgoing calls initiated on the softphone makes me sound robotic. incoming calls sound fine, according to the person on the other end of the line. it's only when i make an outgoing call with the softphone that i sound robotic to the other person. does anyone have the same experience? and if yes, have you figured out a solution?


13 Answers
answered on Dec 30, 2019 at 1:41pm  
We are also experiencing this issue as of today, 12/30/2019. 

answered on Sep 25, 2019 at 3:11pm  
We are still having tons of issues with ringcentral and plantronics headset robotic sound. 

answered on Jan 23, 2019 at 10:52am  
As update.  I was told by a tech support representative that they believe this issue of the robotic calls to be fixed as of the 10.2 and 10.3 versions.  It has not been fixed for us.  Anyone else still having these issues? The Jabra headset we tested did not work for us.  We lost the ability to use the Call controls from the headset, so Plantronics is still our only option it seems to get full integration and functionality. And the Savi series are the only ones with the range we need in our office. Any and all advice appreciated.

answered on Jul 17, 2018 at 1:25pm  
We are having this issue with users on Savi 720 headsets using the desktop app version  Same headset is not having issues when using RC through Polycom VVX 411.  Although the support has pointed to our network as being the issue, after reading this thread I believe this is a software issue that the integration with the Plantronics Savi headset.  Or just an overall software issue in general.  It does not seem to matter if it is Windows 10 or 7 pro as we have issues on both and the two machines experiencing the most frequent robotic calls have brand new machines and brand new headsets.  Glad I found this thread to investigate further.  I just wanted to point out that it is not solved. 

answered on Feb 7, 2018 at 2:52pm  
After some troubleshooting with a client we found that the 9.4.3 version of the RingCentral  for Windows Application (available on the Downloads page) is not exhibiting this robotic voice issue. 

After updating, If you are still experiencing issues, please open a new support case:

answered on Feb 2, 2018 at 1:18pm  

We recently rolled out RingCentral to our office of 200 users. I really like there service, but I too have the Robotic voice with my Savi 745 headset using the RC Desktop client. The issue does not occur on every call, but it does seem to happen to the same numbers (to both internal RC and external non-RC phones). It appears to be specific to my PC. When I moved my Savi headset to another laptop it did not have the issue. Both computers are running the latest 9.3.5 RC Desktop software on the same Windows 10 OS version. 
On the computer with the problem, I have found that unplugging and reconnecting the USB port during an active call fixes the Robotic voice issue 100% of the time. However, once that call ends I may need to redo that on the next active call. For callers I know I've spoken to with the issue, I have unplugged the USB and reconnected the USB, after initiating the call but before they have answered, so that active call will be clear. 
The Robotic issue never occurs when using the Savi 745 DECT to my VVX411 desk phone. I'm still looking for a permanent solution. I have borrowed a Savi 745 from one coworker that does not have the issue and using his Savi with my PC we had the issue. Moving my Savi to his PC, we did not have the issue. The computers are different models. Hopefully this gives RC support more information to find a solution.
UPDATE: I tried using the hold mentioned above, that did not work for me. I tried turning the 'Plantronics headset' off/on in RC Desktop Settings > Sound, and that worked for the active call, just like the USB method I mentioned above. The Plantronics headset off/on is faster if you already have the settings page opened.

answered on Dec 20, 2017 at 11:40am  
We have had this issue for months beginning with all versions after 8.3.6. They changed something in the software and how it integrates with the plantronics wireless headsets. We troubleshooted this for months. It was supposedly fixed in 9.3.3, however we have continued to experience the issue on 9.3.3 and 9.3.5. We are testing the newly released 9.4.1 with a couple of users and so far no occurrence (only 2 days of testing). However, I am not convinced yet that this is fixed.

answered on Nov 4, 2017 at 10:02am  
Hi Hue. Have you attempted an outbound call from the softphone to another RingCentral user without the headset?

If the issue is the same without the headset then it would mean there is an issue either with software on the PC or settings on the local network. If you do not get reports of distortion without the headset you may have to adjust the audio settings for the headset in the Plantronics hub software, or Plantronics support may have some suggestions to resolve the issue.

Let us know if this helps or you make any progress.

answered on Nov 3, 2017 at 2:51pm  
the firmware update did not improve the situation. putting the call on hold and resuming did not help either. but i did find out that it's only happening on ringcentral to ringcentral calls, however. when i call a cell number, for instance, i do not sound robotic. and this happens even with inter-office calls where the phones are on the same network.

more info to add.
best call quality is from a plantronics savi headset to another savi headset. this is crystal clear.
next in quality is plantronics to a cell phone.
worst is from plantronics to a generic usb headset or to a ringcentral desk phone.

i don't know if the problem is with windows 10, the plantronics headset or ringcentral, or a combination of any of these three.

answered on Nov 2, 2017 at 4:27pm  
In my case, I have installed the Hub software and updated firmware on headsets. Have also played with numerous variations on narrowband/wideband, HD on off, and lowered the range. None of these seemed to help. One test I did was actually record a poor quality voice call using the built in Windows 10 voice recorder. I then made just a voice recording without a call through the soft phone. Simply opened a headset channel to the PC and recorded some voice. This was crystal clear. I did several tests like this and couldn't get a single bad recording. Yet using the soft phone I was getting intermittent quality issues. I have also spent a lot of time working on Port triggering and QoS with our in house router/firewall and nothing seems to improve the quality issues there either. Lastly I had a Windows 7 laptop in the office that I installed the software on and hooked to the network. I couldn't get any bad call quality issues through that either, after several calls. This is why I'm pointing finger at a compatibility issue with Windows 10. My current Win 10 O/S build is Version 1703 (15063.674)

answered on Nov 2, 2017 at 4:13pm  
Hello Hue,

In the past we've experienced something similar, but not quite the same. Occasionally we'll get that digitized/robotic sound and when we do, all we have to do place the call on hold for a second and pick it back up and that usually resolves the issue. 

Additionally, all of us just installed the Plantronics Hub software and updated the firmware on our headsets. We have not had the issue since - whether that's a coincidence or not, I'm not sure.

Hope that helps,


answered on Nov 2, 2017 at 4:10pm  
Yep, exact same issue, and have been working to try and find a solution with no luck as of yet. Possibly thinking it may be a compatibility problem with softphone and Windows 10, but haven't confirmed that yet. Are you using Windows 10?

answered on Nov 2, 2017 at 4:21pm  
hi. i'm using windows 10. but i have not installed the plantronics hub software. i'll try the suggestion of putting the call on hold for a second and then resuming. i'll also install the plantronics hub software to see. i'll report back. thanks.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us