News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Plantronics Hub - Target Softphone selection? (Device Controls Disabled)
Tags: hardware
Jul 22, 2019 at 9:13am   •   4 replies  •  1 likes

Using latest Plantronics Hub (Ver 3.13.2 build 41952) with Voyager Focus UC. Under Settings - Software Settings - Target Softphone there is no option for RingCentral. What should I select? I'm having constant issues with the popup "Plantronics Device Controls Disabled". RingCentral KB ID 10726 is not helpful at all. I'm thinking that the proper selection of "Target Softphone" with the Hub software might help.

4 Answers
answered on Jul 23, 2019 at 3:25pm  
I have applied the setting recommended above however I still randomly get "Plantronics Device Controls Disabled"...of course right when I'm trying to answer a call.  When I go to Settings - General and slide the "Plantronics headset" slider off and then back on I can't, I get the "...Controls Disabled" again.  I have to fully close both RingCentral Desktop App and Plantronics Hub down and restart before the slider will re-engage.   Any thoughts???

answered on Jul 23, 2019 at 5:10am  
I use Plantrionics Hub and have my 'target softphone' set to 'None' and just changed the sound settings as Nicole has said - works well for me.

answered on Jul 22, 2019 at 9:37am  
Thanks Nicole, switching from "Same as System" now and will give it a go.

answered on Jul 22, 2019 at 9:22am  
You actually don't need to tell HUB about the Target Softphone for that error that comes up.

In the RingCentral Phone application go into Settings > Sound and make sure your microphone and speakers (and ringer too, if that's what you prefer) are set to the Voyager direct (not "Same as System"). Also make sure the Plantronics headset option is turned on (blue). 

If that doesn't help, I think that your issue might be that the headpiece is losing connection with the computer (going to sleep?), but once it reconnects/wakes up it should figure itself out and re-enable the setting above.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us