News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Meeting doesn't start
Tags: meetings
Jul 26, 2019 at 9:16am   •   7 replies  •  0 likes
Celal Aslan

We're using the RingCentral App (Glip Only).

We have been experiencing a lot of problems lately since RC decided to limit the functionalities and also changing the way it works.

Today we noticed that we can't start a meeting from the desktop app.

When tried to start a call w/ a colleague call never prompts to browser therefore never initiate the RC meeting app.

Is there anyone else experiencing this issue?

7 Answers
answered on Apr 9, 2020 at 3:52am  
This will all ve mute if RCVideo become the default application in GLIP. 

answered on Apr 8, 2020 at 1:23pm  
Well we have the same issue. It's like RingCentral and RingCentralMeeting don't communicate. It's been 7 months. Any news on this?

answered on Sep 6, 2019 at 12:13pm  
Hi Joe,

Glad that the app started working for you!

I assumed it's because Glip Only account restrictions but this is not how it should be.. Indeed a funny configuration mistake I believe. This issue started happening two months ago and its all the same for 50+ people in our team. We're still waiting for a fix.

answered on Sep 6, 2019 at 10:37am  

The problem still persists. We can't initiate a call from the desktop app. Noticed now that I can't even click any button produced on glip desktop app such as JOIN button for a meeting.
Everybody is using on chrome browser due to this error. 

I have already a ticket created on the glip dev team. They're looking into it.
It's been more than a month and I haven't heard back from them yet.
When I follow-up they keep saying that they'll get back to me when they have a solution.

answered on Sep 6, 2019 at 12:03pm  
Funny we were having this same experience but the app started working properly once we logged in via Chrome and initiated a video call from that account. Note that this problem doesn't seem to exist for the RingCentral Office account, so wondering if it is related to the GLIP-only account protocols integrating with the app rather than the app itself. Hopefully tech support will be able to solve this issue for everyone. 

answered on Sep 6, 2019 at 5:36am  
We had this same issue on one of our MacBooks that had a GLIP ID only (no RIngCentral Office account). We solved the issue by logging into the GLIP (RIngCentral) account through a browser and launching a video call from the browser. After successfully launching the video call through the browser, launching a call from the OSX app started working again. 

answered on Aug 6, 2019 at 8:32am  
Hi Celal, 

It looks like others on the Community are not experiencing this. If you're still experiencing this issue, make sure to open a case with our Tech Support team! 

Open support case online 


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us