News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Asana integration fails
Tags: integrations
Nov 15, 2019 at 8:13pm   •   3 replies  •  0 likes


Let's face it... Glip sucks the big one when it comes to task management. And it doesn't look like it's going to improve any time soon (or at all). Hello... product managers??

Because of this, I've been entertaining the thought of returning to Asana to manage our to-dos. Today, I attempted to integrate Asana with my Glip account and was met with the attached error message.

I tried again on another computer/browser... but I get the same message. In Asana, I can see that Glip is listed in the connected apps, but there is no communication happening between the two apps. Whether it's Glips fault or Asana's fault, who knows. All I know is that it doesn't work. Any insights here?

Account type:

A brief description of the business: Non-Profit

Include any related case number if applicable: N/A

Number of Users and/or Digital Lines: 80-ish

3 Answers
answered on Jul 29, 2020 at 9:32pm  
Yay, Tyler! Thanks for pitching in here!

answered on Nov 20, 2019 at 2:54am  
Howdy Timm, 

You're not alone! 

I'm a RingCentral Employee and also a big Asana user. I'm getting the same error when I attempt to turn on the integration from both the desktop and web apps: 

{"error":{"message":"An unexpected server error occurred.","code":"server_error","should_retry":true,"http_status_code":500,"details":"API server failure"}}

If you haven't already I would recommend contacting support  to get a ticket open, I plan on doing the same internally. If you do get a case open please email me your case number and I'll work some magic: please put "Asana integration fails" and the case # in the subject 

Just a guess here: "API server failure" is hopefully something quick we can fix like an expired key or maybe we're hitting a limit on Asana API calls. 


Tyler Dickey 

answered on Nov 18, 2019 at 5:37pm  
Can anyone from RC provide any insight on this?


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us