Question

API Outage - Post Mortem - January 2017

  • 14 January 2017
  • 0 replies
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  • Anonymous
  • 0 replies

Overview

On the morning of January 12 from 3:00am PST to 8:50am PST, a small number of West Coast United States RingCentral customers experienced intermittent API availability. This incident manifested as intermittent HTTP 503 Service Unavailable error responses.

Customer Impact

For the affected customers, production API requests other than OAuth would have returned intermittent 503 Service Unavailable error responses.

Root Cause

The incident was caused by process issues during a planned maintenance window.

Actions and Lessons Learned

To resolve the incident, the maintenance tasks were rolled back. We will be addressing the process issues and adding additional post-maintenance checks to prevent these issues in the future.



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