News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
oauth/token endpoint says my client id is invalid, but it matches exactly what I have in console
Tags: authentication
Jun 15, 2019 at 3:00am   •   5 replies  •  0 likes


When I call this endpoint, I get the following error:

	"error": "invalid_client",
	"error_description": "Invalid client: {
	"errors": [
			"errorCode": "OAU-153",
			"message": "Invalid client: {
			"parameters": [
					"parameterName": "client_id",
					"parameterValue": "{

When I switch back to using the sandbox environment endpoint ( everything works perfectly.

I know I have different credentials for both the production and sandbox environments.

I took my Client ID & Client Secret for my Production Environment and base64 encoded them in the format { {client_id}}:{ {client_secret}} from

These are the same exact steps that worked successfully for me in the sandbox environment but it says my client id is invalid in production... I did a string comparison for the { {my_client_id}} value returned in the error response above and compared it to my Production Environment Client ID in the web console and they match exactly, so I am not sure what to do at this point.

I thought that it was maybe because I am trying to access this production environment endpoint shortly after graduating my app to production, but after a few hours, it still does not work.

5 Answers
answered on Aug 17, 2019 at 1:28am  

I have a similar problem, but only in my sandbox environment. Can someone confirm the API Server URL is:

I am also receiving this response: OAU-153 Invalid client: ZQKpuJrXQ82jGxt0_4w-4A

And this client reported is exactly the same one as in my sandbox console. In the past I would only get this error if the client ID was incorrect OR the API server URL is incorrect. But I have copy - pasted them from the console.

What do I check now?

answered on Jul 2, 2019 at 11:58pm  

Since the solution you mentioned is no where documented and most of the user is also not aware about the url format you mentioned in the solution, request ringCentral team to justify the solution and document somewhere so that it can be referred in future.

answered on Jul 2, 2019 at 1:44pm  

The issue is that I should be using as the url to call, not (which is what is listed in my developer console).

This answer came as a result of a tech support session with RingCentral engineers, and several days worth of them troubleshooting the issue. I did not find this answer, or any reference to this URL, anywhere in this forum.

Hope this can help others avoid some headaches when moving their app to production.

answered on Jun 24, 2019 at 10:49am  

Still having this issue. Submitted a support ticket & tried talking with a tech named Tim who had me send him all my info and screenshots. Still nothing. Any ideas anyone, or should I just give up?

answered on Jun 15, 2019 at 11:34pm  

My production client ID is: VHRj3VEQTneWtcbGw9obMw

I login with my email and password(not a phone number if that makes a difference) and my username/password for production is the same as my sandbox credentials.

I receive a 404 error for the link you provided when I try to open it in my browser, however I am able to login to the admin portal with the exact same username/password as my developer account.

Also, if I change my user credentials to be incorrect, I receive the error "Invalid resource owner credentials", so it seems like it is getting past my user credentials and failing when it checks my client id.

answered on Jun 15, 2019 at 11:22pm  

Can you confirm if you login the production environment with:

1. Client id and client secret for the production environment

2. User name and password of a user under the production account (not the same as the user under the sandbox)

3. The server url is

If all the login credentials are correct and you still get the same error message, please post just the client id here so I can help to check your app.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us