News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Mobile App Not Ringing
Tags: mobile app
Apr 15, 2021 at 1:13pm   •   10 replies  •  2 likes
Jon Criste

As the title expresses, several users in my organization aren't receiving calls specifically on the mobile app - with zero changes to the system. It was working flawlessly earlier today. The desktop app still functions properly and the desk phones still work for those who use them. Anyone else have this issue? Any suggestions? Currently on hold with chat support (I've been waiting 30 minutes already..), and can't call in because the phone system tells me that my PIN for my voicemail is incorrect - when I know for a fact that it is not.

on Apr 23, 2021 at 9:38am   •  0 likes

We've also been experiencing this issue for a couple of months now. We want deskphone and mobile app to ring simultaneously, but lately sometimes the deskphone will ring only and sometimes the mobile app will ring only.

on Apr 21, 2021 at 12:12pm   •  0 likes

We appreciate everyone for updating here about this issue. It will help other customers who are experiencing the same problem. We are also monitoring this JIRA and will update this post once it's resolved.

on Apr 21, 2021 at 11:29am   •  0 likes

Update: Confirmed with RC Support that this is a Service outage, starting on 4/15 affecting both IOS and android. They don't have an ETA but said likely end of week or into next week. At the same time, there is a known defect with IOS devices that exhibits very similar behaviour. That defect has been around for a year with no ETA.

on Apr 21, 2021 at 9:08am   •  2 likes

We've been going back and forth with RC support on this with no success. Per their request, we saved and sent in logs from the mobile app, and then RC said the logs were too big. Then they said it was a service outage that was later resolved. They're now (as of 4/20) claiming this is a known bug defect with no ETA for resolution.

on Apr 21, 2021 at 9:34am   •  0 likes

Hey Matt, I really appreciate the insight on this - you just saved me a good few hours of jumping through loops today. I had a user last night experience this issue after RingCentral supposedly "fixed" this problem.

on Apr 16, 2021 at 1:08pm   •  1 likes

I did uninstall/reinstall yesterday and it didn't work. But, it seems to be working correctly this afternoon.

on Apr 15, 2021 at 2:11pm   •  1 likes

@Jon Criste Try communicating with and check if they can help

on Apr 15, 2021 at 2:16pm   •  0 likes

Thank you for that recommendation, I sent them an email.

on Apr 16, 2021 at 11:38am   •  0 likes

Did anyone ever get anywhere with RC support? I have a user that is having the same issue. Wasn't sure if this was something that RC broke on their end.

on Apr 16, 2021 at 1:11pm   •  0 likes

For those who are encountering this issue, please reach out to our Tech Support Team to check the user's web portal and see where the problem is. You can open a case online or call our 24/7 Customer Support at 1-888-898-4591.

on Apr 16, 2021 at 1:12pm   •  1 likes

I did but they haven't said anything yet

on Apr 16, 2021 at 1:15pm   •  0 likes

Brady, please provide your case number so I can follow up.

on Apr 15, 2021 at 1:43pm   •  1 likes

Same thing happening to us. Please let us know what support says. Based on what you are saying Jon, I wonder if I should have our users uninstall the app and then reinstall. Thoughts?

on Apr 15, 2021 at 1:47pm   •  0 likes

Hey Renee, I tried uninstalling and reinstalling my app with no luck. So it probably isn't worth the hassle. I'm still on hold with chat(over an hour at this point), still can't get through to phone support, and the case portal won't allow me to submit a new case. I'm really up the creek without a paddle right now. A real shame their support is so below par.

on Apr 15, 2021 at 1:26pm   •  2 likes

Same thing happening with me and least one other use. Call is being forwarded, it just doesn't ring through the app.

on Apr 15, 2021 at 1:29pm   •  0 likes

Yeah, I tried forwarding it to my cell number just to test. It rings my cell after it is "finished" ringing my mobile app. Unfortunately we have a few users without desk phones, so we have to rely on the desktop app for now I suppose.

I did test uninstalling the new ringcentral app and downloading RC Phone, and even though the interface is blocked for me, saying that I am required to upgrade to the new app - a call did successfully come through the old RC Phone app. Something must be up with the new app and the mobile ringing policies.

A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us