News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
Cannot Fetch Access Token
Tags: authentication
Nov 10, 2017 at 8:58am   •   8 replies  •  0 likes

I have tried requesting the access token via both the Postman library found here:

as well as via a CURL request. In each case I get a different error but still cannot generate an access token.

I am using my Client ID and Client Secret found under the credentials area (Are these right?).

Any who,

CURL Request:

curl -X POST "
8 Answers
answered on Jul 6, 2019 at 12:26pm  

First you need to go through using OAuth with Authorization code grant_Type and need to know how to put Authorization header .

Please check here:

answered on Mar 29, 2018 at 1:12am  
you forgot to use an Authorization header indicated in this doc

answered on Feb 20, 2018 at 6:59am  

answered on Feb 20, 2018 at 6:57am  

answered on Feb 20, 2018 at 6:57am  
Hello Guys,
I am facing the same error but my username,password and extension number are correct Below are the screenshot could anyone help me out in this regard

answered on Nov 10, 2017 at 1:42pm  

I agree with you on the error message that we should provide for this particular 'use case'. I will convey this to my team. Thanks for the feedback!

Happy Coding!

answered on Nov 10, 2017 at 1:34pm  
Hello to any future readers,
Thanks to the help of Anil @ RingCentral, I realized I was just making a dumb mistake by not reading documentation properly!

In the developer site there was a top level account phone number, I was trying to authenticate with this number and extension as opposed to my developer number (not this is a test account). 

I do feel the error message that was returned could be improved as it did not necessarily address the case I was running into. 

Issue is resolved however by using the right darn phone number!

answered on Nov 10, 2017 at 11:24am  
Hi Jordan,

Could you please check the application type, login to developer portal ( ) and click on the application and under settings you should see the "Platform Type". If the platform type is any one of below :
  • Browser-Based
  • Server-Web
  • Server-Only
Then you would need to follow the OAuth 2.0 Code flow for authentication. 

Please look up this discussion for more information.

Let us know if you have any question.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us