question

Leah Wright avatar image
Leah Wright asked mary-community-moderator commented

SOLVED: Issues swapping between computer audio and Galaxy Buds2

I recently connected Samsung Galaxy Buds2 to my Windows 10 laptop via Bluetooth, but I find I'm having to jump into settings and change them on the fly if I swap between computer audio and the Buds2 because the RingCentral Windows App is not transitioning between them cleanly. The Buds2 stay on my desk in the case, disconnected, unless a call comes in or I'm making a call. More times than not when I activate the Buds 2, either I can't hear the other participant or they can't hear me until I change a setting.

My computer audio is default unless the Buds2 are on. The Buds2 have multiple options under microphone source and speaker source, and that's where my issue lies. Is there a best practice for forcing the right connection automatically and which connection under each is the correct one that will function accurately 100% of the time?

Any help is appreciated! This is a frustrating issue that I'm sure probably has a simple solution.


The attached photos show the options with the Buds2 on and off. Synaptics is the computer audio. Disregard the HP X24in sources. They refer to my monitors, but I do not use the headphone jacks built into them.

Microphone Source - Buds2 off

microphone-source-buds2-off.jpg


Microphone Source - Buds2 on

microphone-source-buds2-on.jpg

Speaker Source - Buds2 off

speaker-source-buds2-off.jpg


Speaker Source - Buds2 on

speaker-source-buds2-on.jpg


ringcentral appsettings
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Anirban avatar image
Anirban answered Leah Wright commented

Can you please check with RC technical support team ?

They can analyze the issue and should have a solution.

You can submit a ticket here.

1 comment
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I haven't yet. I was hoping someone else had experienced the same and could provide a quick solution. I've not had the time this week to engage with Tech Support.

0 Likes 0 ·
Leah Wright avatar image
Leah Wright answered mary-community-moderator commented

Thanks to a great experience with Jann in tech support this morning, I now have a fix for this. It's below for anyone else having the same issue.


  1. Connect your headset/earbuds and verify they are visible in the Speaker/Microphone options in the RingCentral app.
  2. Click the Windows search and search for Sound Settings. Click on it.
  3. At the very bottom, click on App Volume and Device Preferences.
  4. Under RingCentral, select the connected headset or earbuds as default for output and input. If it's listed more than once under either, you might have to play with settings to determine which one is correct. For the Buds2, I selected the Output option that starts with Headset and the Input option that starts with Headphones. The other selections with similar names did not work in my experience.
  5. Exit RingCentral and reopen it.

It should grab the headset/earbuds as default when it's connected and default back to the computer when not. For a wired headset that stays connected, the Ringer Source needs to be set to All Audio Sources in the RingCentral settings so it rings to both the headset and the computer. Otherwise, it may ring to only the headset when it's connected because the Windows settings tend to override the RC settings.

1 comment
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Customer Spaces

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.


Get the new RingCentral app