News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
Meetings Recordings API constant 504
Tags: rest api, meetings
Nov 23, 2021 at 8:41am   •   5 replies  •  0 likes
Bradley Bristow-Stagg

Hey folks,

I sent this email over a month ago and got no response, so going to assume that you're no longer monitoring that address. Also, the link you supply to check my tickets ends up in a complete loop and ends up routing me to RC England which doesn't accept my login.

PS Yes I am still getting this error and I have submitted tickets about it as well.

From: Bradley Bristow-Stagg
Sent: Thursday, 14 October 2021 9:52 AM
Subject: Service Temporary Unavailable on Get Account Meetings Recordings

Hey folks,

For the last three days, if I make a request to: with a single meetingId field I get the following response:


"errorCode": "CMN-201",

"message": "Service Temporary Unavailable"


HOWEVER if I specify a meetingStartTimeFrom and or meetingStartTimeTo I get returned data, though they are not filtering correctly either. Example:
I have a known meeting I am trying to find by the StartTimeFrom/To, here is the raw data of the meeting:


"meeting": {

"id": "1448743814",

"topic": "McCartney Electrical Solutions - SESSION - INVOICING - Karen",

"startTime": "2021-08-10T23:00:15Z",

"uuid": "ULfWTpD3RDe+doRQQwoxaw=="


"recording": [


"id": "ac0eaeb2-c010-4e4f-905c-738125bd95c6",

"contentDownloadUri": "",

"contentType": "video/mp4",

"size": 104587835,

"startTime": "2021-08-10T23:00:17Z",

"endTime": "2021-08-11T00:09:23Z",

"status": "COMPLETED",

"uuid": "ULfWTpD3RDe+doRQQwoxaw=="




Now, if I set meetingStartTimeFrom: 2021-08-10T23:00:00Z which is 15 secs before the startTime listed above I get no results:


Changing the page number doesn’t change any of the returned data either:


on Nov 23, 2021 at 8:48am   •  0 likes

Your attachments do not show up?

on Nov 25, 2021 at 1:48pm   •  0 likes

Can you see them now?

4 Answers
answered on Dec 6, 2021 at 4:13pm  

@Bradley Bristow-Stagg I just checked the meetingID that you posted in the previous post, I couldn't find the meeting related to that ID. May I know where did you get that ID from?

Also , I checked other IDs that are available on your logs and the url works Fine for those IDs

for example:

GET /restapi/v1.0/account/~/meeting-recordings?meetingStartTimeFrom=2021-05-10T23:00:00Z&meetingId=1440295829 HTTP/1.1
Content-Type: application/json
Accept: application/json
Authorization: Bearer [token]

returns 200 OK response with the body of meeting ID : 1440295829

For fetching meeting for specific ID as well , the meetingStartTime is required field

Do you have another examples of missing meeting IDs? Can you share?

For invalid meetingID I got a 404 response with msg :

{ "errorCode": "CMN-102", "message": "Resource for parameter [meetingId] is not found"}

I just checked the support ticket link to create a ticket and it works just fine . Can you please retry ?


on Dec 6, 2021 at 5:19pm   •  0 likes

You documentation SPECIFICALLY says; EITHER OR, does NOT specifiy BOTH as required.


See above the highlighted section. Why should I need to provide BOTH when a meeting can only have ONE ID? It is a UNIQUE identifier.

Also, I did not say that the create link does not work, but I showed that your support portal to view/review tickets is broken.

on Dec 6, 2021 at 5:01pm   •  0 likes

"For fetching meeting for specific ID as well , the meetingStartTime is required field"

Internal identifier of a meeting. Either meetingId or meetingStartTime/meetingEndTime can be specified

So no, if you specify the meeting id, you don't need the meetingStartTimeFrom param. Does not make sense if this is really required!

@Bradley Bristow-Stagg Now, I also notice that the meeting id you posted here is not strange. Where did you get it from?

As I said earlier, I don't have a meeting recording so I cannot verify. But form the API reference, the sample response shows that the meeting id is a long number as string

"meeting": {
      "uuid": "cH8KxkWpR1ea+SvPYeCwoQ==",
       "id": "12345678",
       "topic": "Meeting Topic",
       "startTime": "2018-07-02T10:30:00Z",
on Dec 6, 2021 at 5:20pm   •  0 likes

Not sure what is wierd about the meetingID 1444451455. Where are you seeing something different in what I have posted?

on Dec 6, 2021 at 5:29pm   •  0 likes

Sorry, I picked the wrong id, the recording id "ac0eaeb2-c010-4e4f-905c-738125bd95c6".

And if I used that recording Id, I got the same error "Service Temporary Unavailable" as your. But now if I use any other id as number string, the response is "Resource for parameter [meetingId] is not found"

on Dec 6, 2021 at 5:41pm   •  0 likes

Yea you can't use the recordingID :)

on Dec 6, 2021 at 8:00pm   •  0 likes

I know. That is why I said I picked the wrong id. What do you get when you passed the meeting id "1448743814". The error should not be "Service Temporary Unavailable", right?

on Dec 6, 2021 at 8:48pm   •  0 likes

I SHOULD get the recording and meeting data as described in the OP

on Dec 7, 2021 at 7:36am   •  0 likes

I know you did not get that. But based on your original question where you wrote


For the last three days, if I make a request to: with a single meetingId field I get the following response:


"errorCode": "CMN-201",

"message": "Service Temporary Unavailable"



I want to confirm what error do you get. You don't need to reply to my question anymore. I will let the dev support team help you from now.

answered on Dec 5, 2021 at 8:15pm  

OMG Even your support portal is INOP!


on Dec 6, 2021 at 8:48am   •  1 likes

Let me ping the support team and ask them to contact you.

For your original question, I think the RCM get meeting recordings list API really has an issue. I got the same error "Service Temporary Unavailable" on my test with an invalid meeting id.

on Dec 6, 2021 at 2:24pm   •  0 likes

It has honestly been broken for months and because of which I am very much considering moving to a different provider (I'm looking right now actually). The level of support recently has been woeful.

on Dec 6, 2021 at 3:06pm   •  0 likes

Fully understand your frustration. I am trying my best to help you and I already alert the support team about the ticket issue. I also talk to the PM asking him checking with the dev team. Please stay tuned.

Meanwhile, have you company migrated and used RCV instead of RCM for meetings?

on Dec 6, 2021 at 5:18pm   •  0 likes

We cannot use your half-baked implementation of RCV because it is missing several fundamental issues that I have already brought up with your team.

answered on Dec 5, 2021 at 8:11pm  

This is STILL not working!

answered on Nov 23, 2021 at 10:26pm  

The right email ID to reach to devsupport is , however we are ending email based supports. So you will need to open a support ticket using the link below:

Can you please open a support ticket and provide the API Request Headers , Request body and Response and the team will investigate it further and will get back to you ?

on Nov 23, 2021 at 10:26pm   •  0 likes

Please expect some delay in the response due to Thanksgiving holidays. The team will be back on Monday morning.

A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us