Jonathan O'Neill avatar image
Jonathan O'Neill asked jesse-carter commented

Click to Dial - Salesforce not working RESOLVED

Hello. On Monday it became unable to use the Salesforce Click to Dial plugin/extension. This is happening in both Edge and Chrome. In Edge, phone number not underlined (like a link to call) but when hovering, we see Click to Dial is disabled. In Chrome, phone numbers look as they should, but same thing when hovering, Click to Dial Disabled.

The version of the CTI adapter we have installed, listed in the RC app in SF window, is v 6.23.0 (13). While I don't think it matters here, we are using v22.2.34.4527 of the RC client in Windows.

It seems the default settings we use in the RC app in SF (Call to RC App and Auto Log SMS) reverted to being uncheck (not True) on Monday as well. Hard to ignore the timing.

We updated the Salesforce App from SF yesterday, no impact of fixing the problem.

Has anyone else experienced this problem?

salesforceactivity log
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Steve Castillo avatar image Steve Castillo commented ·

Is it an extra paid feature to enable click-to-dial?

0 Likes 0 ·
mary-community-moderator avatar image mary-community-moderator ♦♦ Steve Castillo commented ·

Hi Steve, Click-to-dial is not an add-on feature. You can check the KB article link below to learn more.

0 Likes 0 ·
Jonathan O'Neill avatar image
Jonathan O'Neill answered Matt Ondish commented

Hello. Self updating here in the event it helps others in the long run. We have a custom Salesforce Domain/URL. But Salesforce moved our org from one SF instance to another. There are very few settings that contain URL that need to be tweak when our Instance is changed....this is one of them. So this was not a RingCentral was a Salesforce setting issue.

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mary-community-moderator avatar image mary-community-moderator ♦♦ commented ·

Thanks for sharing @Jonathan O'Neill

0 Likes 0 ·
Tanner Lehmann avatar image Tanner Lehmann commented ·

@Jonathan O'Neill can you explain where you had to make this change? I also am having this issue.

0 Likes 0 ·
Colleen Conover avatar image Colleen Conover Tanner Lehmann commented ·

I was having an issue with click to dial not working, after enabling enhanced domain in SF. I had to update the CTI Adapter URL in our RingCentral Call Center and that fixed the issue. I changed our CTI Adapter URL to:

2 Likes 2 ·
Matt Ondish avatar image Matt Ondish Colleen Conover commented ·

I was experiencing the same issue and this exact update fixed it on my instance as well. Great comment @Colleen Conover - thank you!

1 Like 1 ·
Yang avatar image
Yang answered

We have a new SF org, which has been set up with the 'My Domain' thing turned on.

The interesting part is that when we first set up the Ringcentral integration in SF, the click to dial feature dose not work, even though the CTI Adapter URL is showing the correct format

We ended up just re-type in the exact same CIT Adpater URl and save it in the call center, and it is now working properly... Really don't know why but just want to share this with anyone who is having the same issue when first time set up Ringcentra in SF.

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Matt avatar image
Matt answered jesse-carter commented

This fixed my Click-to-Dial in Salesforce!! Here are the steps I took to resolve Disabled Click-to-Dial:

1. Click the gear icon

2. Click setup

3. Quick-find "Call Centers"

4. Locate RingCenntral and click "Edit"

5. Under "CTI Adapter URL," copy the address into a notepad. Change the URL based on the below example: (this is the OLD, pre-populated URL) (this is the NEW, changed URL)

6. Click "Save"

7. Kill all instances of your browser, reopen the browser, and log back in

8. Click to dial is now enabled!!

Thank you all so much for getting this solved! You guys rock, I've struggled with this for 2+ months. This is going to create a LOT of process efficiencies for my organization.

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Melissa Loudon avatar image Melissa Loudon commented ·

Heads up to those that come here and do this - this did not work for me and it -broke- being able to use RingCentral in Salesforce so I had to change it back.

0 Likes 0 ·
jesse-carter avatar image jesse-carter commented ·

This fixed our org's issue exactly.

0 Likes 0 ·
Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.

Get the new RingCentral app