question

Jonathan O'Neill avatar image
Jonathan O'Neill asked Colleen Conover commented

Click to Dial - Salesforce not working RESOLVED

Hello. On Monday it became unable to use the Salesforce Click to Dial plugin/extension. This is happening in both Edge and Chrome. In Edge, phone number not underlined (like a link to call) but when hovering, we see Click to Dial is disabled. In Chrome, phone numbers look as they should, but same thing when hovering, Click to Dial Disabled.

The version of the CTI adapter we have installed, listed in the RC app in SF window, is v 6.23.0 (13). While I don't think it matters here, we are using v22.2.34.4527 of the RC client in Windows.

It seems the default settings we use in the RC app in SF (Call to RC App and Auto Log SMS) reverted to being uncheck (not True) on Monday as well. Hard to ignore the timing.

We updated the Salesforce App from SF yesterday, no impact of fixing the problem.

Has anyone else experienced this problem?

salesforceactivity log
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Jonathan O'Neill avatar image
Jonathan O'Neill answered Colleen Conover commented

Hello. Self updating here in the event it helps others in the long run. We have a custom Salesforce Domain/URL. But Salesforce moved our org from one SF instance to another. There are very few settings that contain URL that need to be tweak when our Instance is changed....this is one of them. So this was not a RingCentral issue...it was a Salesforce setting issue.

3 comments
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for sharing @Jonathan O'Neill

0 Likes 0 ·
Tanner Lehmann avatar image Tanner Lehmann commented ·

@Jonathan O'Neill can you explain where you had to make this change? I also am having this issue.

0 Likes 0 ·
Colleen Conover avatar image Colleen Conover Tanner Lehmann commented ·

I was having an issue with click to dial not working, after enabling enhanced domain in SF. I had to update the CTI Adapter URL in our RingCentral Call Center and that fixed the issue. I changed our CTI Adapter URL to:

https://MyDomainName--rcsfl.vf.force.com/apex/OpenCTIIndex

0 Likes 0 ·
Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.


Get the new RingCentral app