News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Mitel / Shoretel IP 400 series ( 480G / 485G ) provisioning guide - from shoretel to RC
Tags: ip phone
Dec 27, 2022 at 2:13pm   •   6 replies  •  2 likes

How to provision a Mitel 480G/485G with Shoretel firmware (v802/803) to ringcentral

These phones are now supported on RC with autoprovision phone per ( However, the instructions given by the RC admin portal wizard and also on will not work if your phones are on older shoretel firmware. I spoke with Mitel SIP phone support and here are the steps that worked. Sharing for anyone who is trying to convert these phones to RC.

  1. Make sure the phone is added as a device in the RC admin portal using the mac address and selecting the correct model - see steps 1-7 only on if you aren't familiar with adding devices to RC admin.

  2. Factory reset your 480G/485G by pressing Mute then 25327# while on the idle screen. It will pop up asking if you're sure you want to clear the configuration. Press Clear softkey.
  3. The phone will reboot.
  4. When back to the idle screen, press Mute then 73887# to access settings
  5. Navigate to Services > Config server
  6. Clear any existing provisioning/config servers and put in this IP address: This is a conversion server that Mitel SIP phone support team gave me which hosts the ringcentral firmware for these phones.
  7. Press save and back out of settings until you see an Apply softkey on the bottom of the display at the main settings menu. Press Apply.
  8. The hone will reboot. Allow it to reboot fully, it may do so a few times.
  9. Eventually you will see a message in the top left of the phone that says "Dial 400 to switch to RC", and extension number 1000 in the top right.
  10. Lift handset or use speakerphone to dial 400 and press DIAL/CALL.
  11. The phone will say call failed and give a busy signal, but it will also say "Upgrading" in top left corner. Do not press anything or power down while it downloads the firmware. This will take several minutes (~10+ min) and reboot numerous times.
  12. After the 1st or 2nd reboot, you'll notice your phones switch from showing the Shoretel logo during boot to the Mitel logo on a dark blue background. This is how you know you're on track.
  13. Once it's done with the 3rd or 4th reboot, the phone will come up provisioned!
on Jan 23, 2024 at 11:56pm   •  0 likes

Does anyone know if there is a similar server set up for older 6900 series phones that don't support assisted provisioning? Or is there a different reason that they need to be set up manually?

on Apr 12, 2023 at 7:31am   •  0 likes

Thank you for posting this. Worked like a charm.

on Jan 4, 2023 at 8:59am   •  0 likes

Great information, @Jake! Thanks for sharing this!

on Jan 3, 2023 at 5:19pm   •  0 likes

@Jared Allen Hmm, not sure as the phones I tried it on were 485g's and all running 802 or 803. I would suggest calling Mitel SIP Phone Support - most likely you'll get John who is an expert magician. 800-574-1611

on Jan 3, 2023 at 4:40pm   •  0 likes

Hi @Jake

Thank you for sharing these instructions. I've tried registering a IP480g with RingCentral using these steps, but the phone is stuck at "Initializing firmware update 1000".

I've checked the phone and its current firmware version is 804.2109.1000.0.

Do you know if there is a different process for the v804 firmware?


on Jan 4, 2023 at 11:53am   •  1 likes

Just had the same issue. You may need to whitelist more IPs on your firewall. Once the initial config file hits, it changes some other server information. RC also has a different IP address to use as the Config server. They use or

Here are all the IPs my firewall blocked, and I had to whitelist for this to work:

1 Answer
answered on Feb 5, 2024 at 7:44am  

Thank you! Was having trouble finding this information via web searches. Worked perfect for me on a Mitel IP 485G.

answered on Apr 24, 2023 at 4:55pm  

If you get "No service" after entering the config server and rebooting, try this instead: after the phone reboots in step 3, watch the phone boot up. When it says something like "press any key to enter setup", press any key. Then continue from step 5 and enter the config server address.

answered on Apr 12, 2023 at 7:30am  

Worked like a charm. Thank you for posting.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us