News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
Cannot create meetings in developer sandbox account - why am I receiving [Meetings] permission required error?
Tags: rest api
Sep 28, 2017 at 8:21am   •   7 replies  •  0 likes


I'm using the sandbox account for testing api.

I tried to create meeting using API, but I'm getting this error

[errorCode] => CMN-408   [message] => [Meetings] permission required    I have granted my app the permission to access and update Meetings. but still no luck.  

Also there is not option for meetings in UI too.

7 Answers
answered on May 7, 2021 at 10:58am  

Hi, can anyone provide guidance for my account ? I am facing the same error on my sandbox account. Thanks


Hi there, i face the same error, can anyone verify my account (i.e. to see if my sandbx can create meetings) ? thanks a lot

on May 7, 2021 at 11:12am   •  0 likes

Please submit your question by creating a support ticket.

answered on Apr 18, 2020 at 2:46pm  

I don't even see a Meetings section in my Sandbox developer environment.

answered on Sep 29, 2017 at 2:14pm  
Hi Altaf,

You got that error because your sandbox account is not enabled to access meetings feature.
Can you let us know the type of your account. Is it a free developer account or are you a RingCentral customer/partner?

Kind regards,

answered on Sep 29, 2017 at 4:35am  
It's just an example of getting meetings list. I'm getting the same error when try to create meeting with POST endpoint

answered on Sep 29, 2017 at 4:27am  
The HTTP method you are using is a GET. 

Kindly refer to this link to see how to 'Create Meeting' using the API's :!/Meetings_%5BBeta%5D/createMeeti...

answered on Sep 29, 2017 at 12:59am  
Please see below Request and Response


curl -X GET --header "Accept: application/json" --header "Authorization: Bearer U0pDMTFQMDFQQVMwMHxBQURpeTJNM

Request URL

Response Body
{   "errorCode": "CMN-408",   "message": "[Meetings] permission required",   "errors": [     {       "errorCode": "CMN-408",       "message": "[Meetings] permission required",       "permissionName": "Meetings"     }   ],   "permissionName": "Meetings" }

Response Code 403

Response Headers
"date": "Fri, 29 Sep 2017 07:56:45 GMT",
"x-rate-limit-limit": "50",
"routingkey": "SJC11P01PAS02",
"x-rate-limit-remaining": "49",
"content-length": "247",
"rcrequestid": "bd5277fe-a4eb-11e7-a9b5-005056bb594d",
"content-language": "en-US",
"x-rate-limit-group": "light",
"content-type": "application/json;charset=UTF-8",
"x-rate-limit-window": "60" }

answered on Sep 28, 2017 at 1:44pm  
What is the meetingType that you are trying to create? Could you provide the API request ( including the HTTP body)? 


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us