News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
salesforce classic outgoing call
Tags: salesforce
Jan 4, 2018 at 11:17pm   •   4 replies  •  0 likes
Test Aspire

I am very new to Ringcentral. When I go by Click to dial, it shows me, "Your call could not be completed. Please try again later". Is it something about, Ringcentral issue ? Any suggestions appreciated. Thanks

4 Answers
answered on Feb 23, 2018 at 8:28am  
Yea, you're right.

It's working for me perfectly me now. Both the desktop softphone for RingCentral and dialing out to my cell phone.

I'm having no other problems, so it looks like the integration is working perfectly :)

Thank you!

answered on Feb 23, 2018 at 7:52am  
Hello Byron, 
This error may not be relevant to click to dial. You may be aware that RingCentral App requires a RingCentral phone to be able to make calls.  There are two options for phone making an outbound calls from Salesforce App, You can either use the RingCentral Desktop software phone(aka softphone) or your desk phone.  The App basically makes two legs of incoming phone call, one to your RingCentral phone and other to the party you trying to reach. In this case your RingCentral phone is not reachable.  Can you please double check your setup to make sure your RingCentral phone device (Softphone or deskphone) are able to take incoming call. 

answered on Feb 22, 2018 at 3:03pm  
I'm getting the same error. It happens whenever I try to dial by clicking a lead's phone number in Salesforce.

Here's a screen:

I dug a bit deeper and found this error in Google Chrome's Developer Tools Window:

Refused to execute JavaScript URL because it violates the following Content Security Policy directive: "script-src 'self' 'nonce-bb3def57-5b49-00d4-88e3-4e60bb19b80f' chrome-extension: 'unsafe-inline' 'unsafe-eval' *. 'unsafe-eval'". Note that 'unsafe-inline' is ignored if either a hash or nonce value is present in the source list.

I tried Click To Dial on both Chrome and Microsoft Edge and received the exact same error as well.

So I'm wondering if this is something the RingCentral engineering team might have to address?

I'm not sure. Let me know if there's something I need to do on my end.

Thank you!

answered on Jul 29, 2020 at 8:25pm  
Hello! Could you share a screen shot?


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us