News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Developers
Integration Jira - stop working
Tags: integrations
Sep 26, 2019 at 12:54am   •   7 replies  •  0 likes
Mira Hybl


We're using Jira Integration in Glip and it stops working after 11.9.2019 the payload is sent from Jira but I'm getting the following error

{"status":"error","message":"Your request was accepted, however a post was not generated","error":"Invalid Custom payload: no supported fields","validation":[]}

So they probably changed the format or you added strict validation.

Best Regards,

7 Answers
answered on Jul 31, 2020 at 2:00pm  

I fixed this problem by setting the `Content-Type` HTTP header to "application/json".

answered on Oct 7, 2019 at 12:57am  

Our Dev-Team uses Jira integration with RingCentral and we have exactly the same problem described in this thread. There is an official answer from RingCentral staff about this? This feature it's vital for our daily workflow.

answered on Sep 30, 2019 at 11:42pm  

I setup new webhook in Jira just to catch what sending Jira using this cool site and then I tried to send that payload using curl into Glip webhook and I'm getting that validation error what I sent in the first post.

Here is an example of payload from Jira

{"timestamp":1569410826788,"webhookEvent":"jira:issue_created","issue_event_type_name":"issue_created","user":{"self":"","accountId":"5b0bfbcc6c27b84d00ce96d0","emailAddress":"\"?\"","avatarUrls":{"48x48":"","24x24":"","16x16":"","32x32":""},"displayName":"Petr","active":true,"timeZone":"Europe/Berlin","accountType":"atlassian"},"issue":{"id":"12139","self":"","key":"NIM-2052","fields":{"statuscategorychangedate":null,"issuetype":{"self":"","id":"10004","description":"A problem which impairs or prevents the functions of the product.","iconUrl":"","name":"Bug","subtask":false,"avatarId":10303},"timespent":null,"project":{"self":"","id":"10000","key":"NIM","name":"Nimpee","projectTypeKey":"software","simplified":false,"avatarUrls":{"48x48":"","24x24":"","16x16":"","32x32":""}},"fixVersions":[],"customfield_10033":null,"customfield_10034":null,"aggregatetimespent":null,"resolution":null,"customfield_10035":null,"customfield_10036":null,"customfield_10037":null,"resolutiondate":null,"workratio":-1,"watches":{"self":"","watchCount":0,"isWatching":true},"lastViewed":null,"created":"2019-09-25T13:27:06.683+0200","customfield_10020":null,"customfield_10021":null,"customfield_10022":null,"customfield_10023":null,"priority":{"self":"","iconUrl":"","name":"Medium","id":"3"},"customfield_10024":null,"customfield_10026":null,"labels":["!acl","!e2e","@cisco","api","discovery"],"customfield_10017":null,"customfield_10018":[],"customfield_10019":null,"timeestimate":null,"aggregatetimeoriginalestimate":null,"versions":[],"issuelinks":[],"assignee":null,"updated":"2019-09-25T13:27:06.683+0200","status":{"self":"","iconUrl":"","name":"Reported","id":"10017","statusCategory":{"self":"","id":2,"key":"new","colorName":"blue-gray","name":"New"}},"components":[],"timeoriginalestimate":null,"description":"","customfield_10010":null,"customfield_10011":"1|i005hj:","customfield_10012":null,"customfield_10013":null,"timetracking":{},"security":null,"customfield_10008":null,"aggregatetimeestimate":null,"attachment":[],"customfield_10009":{"hasEpicLinkFieldDependency":false,"showField":false,"nonEditableReason":{"reason":"PLUGIN_LICENSE_ERROR","message":"Portfolio for Jira must be licensed for the Parent Link to be available."}},"summary":"E2E path lookup - ACL vs. object-groups evaluation","creator":{"self":"","name":"petr","key":"5b0bfbcc6c27b84d00ce96d0","accountId":"5b0bfbcc6c27b84d00ce96d0","emailAddress":"","avatarUrls":{"48x48":"","24x24":"","16x16":"","32x32":""},"displayName":"Petr","active":true,"timeZone":"Europe/Berlin","accountType":"atlassian"},"subtasks":[],"customfield_10040":null,"customfield_10041":null,"customfield_10042":null,"reporter":{"self":"","name":"petr","key":"5b0bfbcc6c27b84d00ce96d0","accountId":"5b0bfbcc6c27b84d00ce96d0","emailAddress":"","avatarUrls":{"48x48":"","24x24":"","16x16":"","32x32":""},"displayName":"Petr","active":true,"timeZone":"Europe/Berlin","accountType":"atlassian"},"aggregateprogress":{"progress":0,"total":0},"customfield_10000":"{}","customfield_10001":null,"customfield_10004":null,"customfield_10038":null,"customfield_10039":null,"environment":null,"duedate":null,"progress":{"progress":0,"total":0},"votes":{"self":"","votes":0,"hasVoted":false}}}}

answered on Sep 30, 2019 at 11:07am  

We're seeing the same thing on our side. Our dev's sent us the text below on their efforts so far.

Between September 10th5pm and September 11th8am the integration between Glip and Jira stopped functioning. I have done testing and have confirmed that Jira is indeed sending out its webhooks. I took one of these hooks and manually called them against the URL provided for the Jira integration in Glip. The web server responded with “Status: OK” but did not post any messages to the conversation where the integration was enabled. There is no configuration of the integration on Glip’s side except “Add integration” and setup from there is passing the URL it provides into Jira, so we are confident that this is not a misconfiguration at fault, especially since it was working autonomously for a couple of months before failing without any modifications by us.

We’ve tried deleting/re-adding the integration multiple times to no avail. We have also tried applying the integration to other conversations than our “Jira Activity” conversation also to no avail. Can we please engage RC support and figure out next steps on this? Thanks!

answered on Sep 30, 2019 at 5:52am  

Just adding to this thread that we are having the same issue with our JIRA cloud integration with Glip.

I checked this morning and the webhook link in JIRA and in Glip match, and I return a 'Status:OK' message but no updates are posted in our glip rooms. Here is one example attached

answered on Sep 29, 2019 at 11:31pm  

Just try to add integration into channel and type "jira" into search field. There is only one integration called Jira.

answered on Sep 26, 2019 at 10:59am  

Could you please post some screenshots, I am still not very clear of which JIRA integration you are talking about.


A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us