question

Ted Hewitt avatar image
Ted Hewitt asked ·

Graduation Requirements not updating

I have made calls attempting to meet requirements for graduation, however, the system is not refreshing. As of this post it shows last refresh was 2020-10-20, 16:23:15 UTC, but currently its 2020-10-20T19:07:56. Site statues updates every 15 minutes, or in some places says an hour. Either way, its been a very long time, how can I get this refresh to happen?

graduation
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Phong Vu avatar image
Phong Vu answered ·

Can you give your latest update about this problem? If it's still not updated, give me the app client id so I can have a look at it.

1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Ted Hewitt avatar image
Ted Hewitt answered ·

It finally updated, but the tooltips that explain that the data is updated every hour, x minutes, etc... those are not accurate. This should actually updated on the hour as it states, or dont provide a refresh interval. Or possibly add a manual refresh option.

1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Mike R. avatar image
Mike R. answered ·

we're seeing the same issue as well.. we're trying to push through so we can use our RC app on production data. is there a way to manually refresh this? the work we're doing is time sensitive and it would be helpful if we can see the updates occur at a faster rate.


app client ID 8fAkPK8_Qcab6zD9QgtR0Q in sandbox



3 comments
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

You call the get media/recording just once and that is why. Your app is a private app and has enough API calls for other API. So I graduated it manually for you. It is a Browser-base app and I don't see a correct OAuth redirect URI though. You still can provide the URI after the app is graduated though.

0 Likes 0 ·
Mike R. avatar image Mike R. Phong Vu ♦♦ ·

thank you very much Phong! You're assessment is correct, when we created the app and set the app type, i incorrectly set it to "web-browser" instead of "other non-ui" which doesn't require Auth Code and Implicit auth flows. our app is for internal company use only with a very limited scope.


we created a new staging app with app client ID YTMl6DcdQne84WdAnnzrnA


since we've made dozens of calls to various endpoints from the previous staging app that you pushed to production we were able to quickly place new calls under the new staging app above and you should see that we've met all requirements to graduate the app. can you please help us push the app through to production?


Thank you very much in advance!

0 Likes 0 ·

No need to create a new app. You should have let me know. I changed the old app platform type to password flow. So use the old app and keep the new app for next version development.

0 Likes 0 ·
Tom Copenhaver avatar image
Tom Copenhaver answered ·

Having a similar issue. Can you push this client app id forward to production?

IbsCeEwGSt-Qo-Z5OWBaeA

Thanks!

Tom

1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hzo avatar image
Hzo answered ·

Same thing here app id: m6s_XGo1Trq2N57E6CyR9A and app id: t2A8tbqeSRuRCnkJV9lM_A

Thank you.

1 comment
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Be patient. One of the app's submit button is enabled so you can submit yourself. The other app still not satisfy the requirements. Call API at least 5 times to exercise the permissions.

0 Likes 0 ·
Hzo avatar image
Hzo answered ·

Got it thank you.

One is done moved to production


t2A8tbqeSRuRCnkJV9lM_A

Has more request than five per endpoint, I'm not sure what else is required, thanks again.

screen-shot-2021-03-23-at-52616-pm.png


2 comments
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Any update on this?

Thank you.


0 Likes 0 ·

Done

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Developer sandbox tools

Using the RingCentral Phone for Desktop, you can dial or receive test calls, send and receive test SMS or Fax messages in your sandbox environment.

Download RingCentral Phone for Desktop:

Tip: switch to the "sandbox mode" before logging in the app:

  • On MacOS: press "fn + command + f2" keys
  • On Windows: press "Ctrl + F2" keys