question

AARON BELLINGHAM avatar image
AARON BELLINGHAM asked ·

sandbox user disppeared from portal

I was doing the sandbox test. it was fine yesterday but today when I logged in I saw my portal looks like this...

I suddently lost the production credantials and sandbox user.


sandbox
1581097137109.png (37.8 KiB)
6 comments
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Mine too, would love to know what's going on!

0 Likes 0 · ·

did that also happen to you today?

0 Likes 0 · ·
Shanon Hart avatar image Shanon Hart AARON BELLINGHAM ·

yes, i believe so because suddenly today i'm getting"Invalid resource owner credentials" and when i checked my sandbox user was gone. I also can't authenticate it through the ringcentral API pages, so i know it's not my app.

0 Likes 0 · ·
Show more comments

What is your app client id?

0 Likes 0 · ·

AAigs_4nSXOjOOBlhqzu-Q

0 Likes 0 · ·
Phong Vu avatar image
Phong Vu answered ·

Hi Aaron,

I see you have 2 apps, both of them are still in sandbox mode and have never been graduated. That is why the production credentials are empty. I also look at your app analytics and see a few red crosses and that is why the Apply for Production button is disabled. Just exercise more API calls until you see the button enabled then click it to graduate your app to the production.

Let me know if you see something else.

1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Phong

I just created second API to see if I can get sandbox user back. but it gives me error when i created second API. Now I deleted it.

yes we did have red cross and I guess it might related to the none ssl site we used. we just moved the site to SSL this morning. But the sandbox user was disappeared probably last night.

the not graduate cross shouldn't make my sandbox user got deleted.


here is the error when I try to create a new API.

0 Likes 0 · ·
1581105953200.png (59.6 KiB)
Phong Vu avatar image
Phong Vu answered ·

Hold on, I see the same problem across other sandbox accounts. We are working on fixing it asap.

Stay tuned!

1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

do you have an ETA of when this can be fixed?

0 Likes 0 · ·
Phong Vu avatar image
Phong Vu answered ·

The problem is fixed. However, if you still don't see your sandbox credentials, click on the the Sandbox Accounts tab on the left-hand side. Now, if you still see the "Create Sandbox Account" button instead of your sandbox account information, which means that your sandbox account was removed during the outage last Friday.

Action: please post your sandbox main company number here so I can pass it to the admin team to see how they can track and restore your sandbox account manually.

My apologies for any inconvenience!

+ Phong

3 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi,

My sandbox User Account password is stating "inactive" in the User Account Credentials section of the portal.

My application is also receiving 400 Bad Request responses.

My sandbox main company number is +19294586417

Please let me know.

Thanks Phong

0 Likes 0 · ·

I still see the same thing and I do not see where is the option to create sandbox


in the sandbox user field I use to have user name: +19294746817

please check if this user got removed


0 Likes 0 · ·
1581367867292.png (80.9 KiB)

you are right, my sandbox account did get removed last Friday. Please help to add it back in

sandbox main company number: +19294746817




0 Likes 0 · ·
1581374289179.png (19.5 KiB)
1581374378501.png (19.5 KiB)
AARON BELLINGHAM avatar image
AARON BELLINGHAM answered ·

today is tuesday, My sandbox account still hasn't been fixed

1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi Aaron,

The team is trying to figure out how to restore the lost sandbox account. They are working on it.

Meanwhile, if this is urgent for you, you can click the button to create a new sandbox account and test your app. When the old sandbox account is restored, you will have 2 sandbox accounts.


Also can you provide me the username (phone number) for your RingCentral Developer portal (the one you login this site https://developers.ringcentral.com)

Thanks

0 Likes 0 · ·
MTI DATA avatar image
MTI DATA answered ·

Hi Phong,

My account is also still not working.

When can we expect a resolution? Is there a phone number I can call? This is taking too long.

1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

My sandbox account was also disappeared and it is restored today. So the team could figure out how to fix it. They need some info from developer in order to restore the account. Please provide me with these info:

1. Your RingCentral developer portal login user name (the phone number)

2. Your sandbox account main company number.

Alternatively, you can send these numbers to devsupport@ringcentral.com and mention sandbox account restoration.

Your patience is much appreciated!

0 Likes 0 · ·
AARON BELLINGHAM avatar image
AARON BELLINGHAM answered ·

yes, my sandbox account was back this morning. Thanks Phone

Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.