News & Announcements User Community Developer Community

Welcome to the RingCentral Community

Please note the community is currently under maintenance and is read-only.

Make sure to review our Terms of Use and Community Guidelines.
  Please note the community is currently under maintenance and is read-only.
Home » Users
Multiple RingCentral websites have certificate errors (,, etc)
Tags: log in
Jul 5, 2021 at 8:34am   •   9 replies  •  0 likes
Wayne Folta

For those of us behind a firewall that checks certificate validity, the site has an error, which makes it inaccessible. Please fix this.

I want to submit a ticket regarding an RC Yealink that's giving choppy audio under certain circumstances, and under those circumstances the RC iPhone app does not suffer the problem. I captured a PCAP on the firewall and all the stats appear to be perfect, but you can clearly hear choppy audio -- starting with the second ring -- and this only occurs with a Yealink, not the iPhone app. It also appears that RTP down is not encrypted (I can listen to it in Wireshark's RTP playback) but RTP up is encrypted (It appears empty in Wireshark's RTP playback).

on Jul 6, 2021 at 1:18pm   •  0 likes

Here's another example. I go to and look at my tickets. I click on Create a Case and it says I'm not logged in. (I am, but it thinks not.) It pops up a small browser window and prompts me to login. After I enter the password, it tries to jump to and somehow is involved and I get a certificate error. Here is a screenshot from Safari with the Web Inspector at the bottom of the page. Note that the certificate is, which I do not have bookmarked and do not explicitly type in. Note at the bottom that is also involved.

So this is a show-stopper for me where I cannot submit a ticket and I've been asked by RC -- on a VoIP issue to open a NEW ticket. (That's a matter for another day, but I've been able to deal with this so far because I could update tickets by email reply. I cannot make a new one. The original was created due to a phone call to support, not by me.)


on Jul 6, 2021 at 1:20pm   •  0 likes

Thanks again Wayne. You'll be happy to know there's a fix for that already in the works and should be released very soon.

on Jul 6, 2021 at 1:25pm   •  0 likes

Glad it got to the right channels. Thanks Michael and Mary. Not sure how long that will take, so I'll see if we can disable certificate-checking firewall-wide for enough seconds for me to make the ticket I need to make today. (They made several recordings of calls involving an overseas connection.)

on Jul 6, 2021 at 1:40pm   •  0 likes

I'd add that the login takes me on the World English-Speaking Tour: from through, then, then, and finally back to with detours to along the way. A temporary workaround on our end let me get to the ticketing system.

on Jul 5, 2021 at 5:40pm   •  0 likes

This is crazy. I'm just trying to login to update a ticket and it keeps bouncing me around the world. So now it sent me to and that also causes certificate error. Perhaps the error is due to this bouncing around the world. So RC is not going to advance my ticket because it's waiting my input but I can't login to address it. (As opposed to logging in to the forums, logging in to my account, etc.

on Jul 6, 2021 at 7:09am   •  0 likes

Hi Wayne, to troubleshoot, please clear cache and cookies. Let us know if it's still the same.

on Jul 6, 2021 at 7:20am   •  0 likes

I deleted all RingCentral cookies and cleared the cache entirely and I still get the error on This was in Safari, and I also tried Firefox and got the same issues, including not being able to login to my tickets. (It does this weird thing where I'm logged in, I can see my tickets, I clock on a ticked and it says I'm not logged in and pops up a small browser window where it wants me to login again. It is this second login that leads to the other certificate errors for

on Jul 6, 2021 at 7:23am   •  0 likes

It happens when you try to log in, right?

on Jul 6, 2021 at 7:21am   •  0 likes

The redirect problem could be with my browser. The certificate errors are being found by the firewall, so cookies and caches won't help there. The browser never sees the actual page at the other end.

on Jul 6, 2021 at 8:30am   •  0 likes

I can access without problem, but as I navigate the site, it likes to redirect to pages like or which have certificate errors.

It's a secondary problem, but when I go to and go to My Cases and click on a case, it tells me I am not logged in and requires me to login. When I do so, it redirects briefly to a website that mentions "force" in the URL, then immediately to and the certificate error pops up. I think it's taking me to a website for the ticketing system, but it flashes by quickly.

As I mentioned, the redirecting might be due to caching at my end, but I just did this in Firefox instead of my usual Safari and had the same issues. So I suspect that there's a bunch of redirection occurring in, by design, and it's only because of the certificate errors that I'm stopped short of my destination and notice.

on Jul 6, 2021 at 7:30am   •  0 likes

To clarify: Simply going to the URL causes the problem. That site has a problem with its TLS certificate.

I ALSO have the same problem if I am trying to access a ticket, which ends up redirecting me to and that site also has a problem with its TLS certificate. So in this case there are two problems: a) why am I directed to Canada to login, and b) a TLS certificate problem.

Sorry to confuse the issue. The weird jump to Canada is puzzling, but I mention it mainly to point out a second RingCentral website with a subtle error in its TLS certificate chain. My browser or a non-strict firewall probably doesn't catch it, but our firewall is set to reject invalid TLS certificates. The Sophos Community post lays out the error.

Mary: Thanks so much for looking into this. If you're saying that RingCentral did something to fix the original problem and I should be seeing the fix, it's probably a matter of time if something's cached in the CA realm or the firewall. Has nothing to do with the browser, where I can clear caches, etc. (The redirect could be due to caching in the browser, etc, but I think the clearing and the second browser make that less likely. But it's a secondary issue.)

on Jul 6, 2021 at 8:24am   •  0 likes

Wayne, can you access instead.

on Jul 5, 2021 at 5:34pm   •  0 likes

Please add to the trouble list. For some reason my ticket requires me to login to that site and it has basically the same problem.

on Jul 5, 2021 at 9:06am   •  0 likes

I asked about the error in the Sophos Community (it's a Sophos Firewall appliance) and one of their moderators analyzed it beyond my capabilities: and it appears to be an obscure oversight by the website. (The error message makes the certificate look okay to my eyes, but there are interactions happening. Interactions that don't bother your browser, but a firewall set for strict checking rejects it.)

on Jul 5, 2021 at 9:04am   •  0 likes

@Mary-Community_Moderator it looks like:


on Jul 5, 2021 at 8:45am   •  0 likes

@Wayne Folta , can you please take a screenshot of the error you're getting?

1 Answer
answered on Jul 6, 2021 at 8:58am  

Sorry for any confusion with those two domains. The domain "" is an old decommissioned site which is why it is throwing errors. All of the current support material is now found at

Please delete all old bookmarks containing "". If you do find any URL with the "success" subdomain, and it does not redirect you to a "" URL, please copy and paste that URL, or the URL for the page in which the link is located, to this thread so we can address it. Thank you!

on Jul 6, 2021 at 1:19pm   •  0 likes

I have posted an answer and screenshot, below. This is a show-stopper involving certificate errors and your ticketing system.

on Jul 6, 2021 at 9:53am   •  0 likes

Was this deprecation recent? Could your load balancers, etc, have cached the old stuff? if so, I probably won't find anything if I retrace my steps. I did just find in

a link click to view the wireshark file which goes to

on Jul 6, 2021 at 12:08pm   •  0 likes

Thanks for sharing that broken link. We'll get it fixed. Thank you!

on Jul 6, 2021 at 9:03am   •  0 likes

There are still links in that point to I wasn't using old bookmarks. Similarly, I am not explicitly going to (which appears to have the same kind of certificate issue, but I'm not sure). So it's good to hear that the certificate issue (for that site) is confirmed, but it's not quite as easy as me going to old bookmarks. This could also be an issue with Google Searches still pointing to the old site.

on Jul 6, 2021 at 9:17am   •  0 likes

Can you tell us where you found those links so we can get them fixed?

on Jul 6, 2021 at 9:46am   •  0 likes

I'll poke around. I was doing a lot of research on VoIP issues, so some were probably through the RC website, some may have been via Google. None of the bookmarks that I have are invalid, so I'll have to look through documents and try clicking links in them. I'll post what I find.

Does this also affect (I.e. have you eliminated country-wise support and consolidated it at, so this link is also deprecated? In that case, it's totally repeatable for me: go to My Cases, click on a case link, get asked to login, then end up at with a certificate error.)

A new Community is coming to RingCentral!

Posts are currently read-only as we transition into our new platform.

We thank you for your patience
during this downtime.

Try Workflow Builder

Did you know you can easily automate tasks like responding to SMS, team messages, and more? Plus it's included with RingCentral Video and RingEX plans!

Try RingCentral Workflow Builder

Developer Platform
Integrated Apps
App Gallery
Developer support
Games and rewards

Resource center
Product Releases
App Download
RingCentral App login
Admin Portal Login
Contact Sales
© 1999-2024 RingCentral, Inc. All rights reserved. Legal Privacy Notice Site Map Contact Us