question

Leah Wright avatar image
Leah Wright asked mary-community-moderator commented

SOLVED: RingCentral app not remembering sound source settings

I use RingCentral on my work computer, but I do not wear my headset the entire day. I've set the audio sources up as shown in the screenshot below, but they randomly change during the day and default back to the computer sources. Is there a way to set these and have the settings hold so I'm not scrambling to send the sound back to my headphones if I get a call?


1622643250631.png

ringcentral app
1622643250631.png (41.0 KiB)
5 comments
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Sound settings should not change unless you sign out and back into the app or restart their machine. Our Product Team would like to collect your logs. Please go to Help & Support and click Report Issue.

screen-shot-2021-06-02-at-114929-pm.png

0 Likes 0 ·

The logs have been submitted. It's very possible there was a reboot prior to the change occurring. I shut down my computer every day and it sometimes experiences issues and has to be rebooted during the day.

0 Likes 0 ·

Thank you. I will let our Product Team know.

0 Likes 0 ·

Many users at our company have reported this same issue, some claim it happens without signing out of the app or shutting down the machine. Is there any other behavior that is acknowledged by RingCentral to cause these audio sources to change back to defaults?

Is there a way to prevent this behavior? User settings are usually persistent across restarts in most applications I've used... why is this different?

0 Likes 0 ·

Hi @Curtis K, please report issue in the app's Help & Support tab as well. You can also submit a case here.

0 Likes 0 ·

1 Answer

Leah Wright avatar image
Leah Wright answered mary-community-moderator commented

I swapped from a wired headset to Galaxy Buds2 recently and was experiencing the same issue. Thanks to a great experience with Jann in tech support this morning, I now have a fix for this. It's below for anyone else having the same issue.


  1. Connect your headset/earbuds and verify they are visible in the Speaker/Microphone options in the RingCentral app.
  2. Click the Windows search and search for Sound Settings. Click on it.
  3. At the very bottom, click on App Volume and Device Preferences.
  4. Under RingCentral, select the connected headset or earbuds as default for output and input. If it's listed more than once under either, you might have to play with settings to determine which one is correct. For the Buds2, I selected the Output option that starts with Headset and the Input option that starts with Headphones. The other selections with similar names did not work in my experience.
  5. Exit RingCentral and reopen it.

It should grab the headset/earbuds as default when it's connected and default back to the computer when not. For a wired headset that stays connected, the Ringer Source needs to be set to All Audio Sources in the RingCentral settings so it rings to both the headset and the computer. Otherwise, it may ring to only the headset when it's connected because the Windows settings tend to override the RC settings.
1 comment
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for updating this, @Leah Wright.

0 Likes 0 ·

Customer Spaces

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.


Get the new RingCentral app