Caller ID not working on mobile device

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Acknowledged
I have RC Glip downloaded to my phone, but when I receive a phone call through Glip it is not recognizing the contacts saved in Glip; it only displays the phone number.

This is on an iPhone 8 Plus. My coworkers have the same phone and same app, and their phones display the name of the caller. Also, on their phones it shows "RC Glip Audio" under the recent calls where mine does not.

I have tried downloading the RingCentral app itself with no change. I have also navigated through the settings (in the Glip App) to Phone|Extension Settings|Call Handling & Forwarding|Advanced|Incoming Call Information; the "Incoming number displayed to me:" is currently selected as "Caller ID".

As a last resort I deleted and re-downloaded the RC Glip App. The issue remains unresolved.
Photo of Mark Braaksma

Mark Braaksma

  • 100 Points 100 badge 2x thumb

Posted 4 months ago

  • 0
  • 1
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Hey Mark,

I'm not sure what's going on here :( I would suggest opening a case so we can take a closer look and investigate

Photo of Mark Braaksma

Mark Braaksma

  • 100 Points 100 badge 2x thumb
Ok, so I figured this out. The difference between me and my coworker is that I have a desk phone. Because of this I have my RC call handling set to inactive for my desktop & mobile apps; then I have it set to ring my desk phone before forwarding to my mobile number. Because of this, RC is never reaching my phone through the mobile app.

As far as I can tell, there is no way to separate the desktop and mobile apps on the call handling. I have zero use/desire to use the desktop app. 
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Oh I see. If you toggle on the Desktop/Mobile App section under Call Handling & Forwarding, it will only ring whichever you are logged into. For instance, if you never use the desktop app, it won't ring it because you are not logged in - but it will ring your Mobile App as long as you are logged in. This setting is different than simply forwarding to your cell phone number - which is why Caller ID isn't showing up the way you are expecting
Photo of Mark Braaksma

Mark Braaksma

  • 100 Points 100 badge 2x thumb
Excellent. Is there a way to get RC to ring my deskphone for 2-4 rings and then (sequentially) ring my mobile app for another 2 rings before forwarding to voicemail? That is the order I need to make my situation work. Thank you :) 
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Unfortunately, at this time you cannot rearrange the ring sequence of the mobile/desktop app. This is actually an active feature request.


Photo of Mark Braaksma

Mark Braaksma

  • 100 Points 100 badge 2x thumb
Second that request! The desktop app is completely unworkable for me; thus I need the desk phone. Thank you for your help!
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 43,480 Points 20k badge 2x thumb
Always happy to help, Mark. I'd still recommend flipping on the Mobile app toggle and log into the app so you can receive calls to it :) Like I mentioned, that setting only affects the desktop app if you're logged in