Desktop app high CPU usage on startup

  • 0
  • 1
  • Question
  • Updated 6 months ago
  • Answered
Hello,

the RingCentral desktop app CPU consumption is hovering around 5% while doing nothing on my laptop (process name "Softphone.exe *32"), when it is configured to start on computer startup.

It's fine if I kill the program and start manually, CPU is 0% when doing nothing.

Does anybody have the same experience? Any thoughts how to troubleshoot/debug this?

My configuration:
- Lenovo Thinkpad T440p
- Intel Core i7-4710MQ CPU @2.50 GHz
- 12.0 GB RAM
- 64-bit Windows 7 Professional w/ Service Pack 1
- RingCentral for Windows, version 9.3.5.28675

Thx
Photo of Eriza Fazli

Eriza Fazli

  • 100 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Cecile Glassy

Cecile Glassy

  • 14,180 Points 10k badge 2x thumb
12-20-2017 USA-based account 2287 Users 3800 DID lines 28 sites.......

This is very likely a Lenovo issue --- we have had this same problem with this specific model of Lenovo and the T430 and the Carbon X1 models (all three MB generations of Carbon)  Running both Win7Pro 64bit and  Win10 Ent 64bit
Photo of Cecile Glassy

Cecile Glassy

  • 14,180 Points 10k badge 2x thumb
Sorry we do not have a solution to you,  the issues we have had with Lenovo machines of all models caused us to standardize instead on Dell from June 2017 forward. We just stopped using that brand.  We are stuck supporting all the ones we still have in use until they go EndOfLife, but we standardized organization-wide on Dell E-5470 model and it has worked flawlessly with all our RingCentral Apps and all other software. I realize this is not a solution for all folks as they cannot just up and change their installed technology, but for future purchases, this may be useful info. 
Photo of Eriza Fazli

Eriza Fazli

  • 100 Points 100 badge 2x thumb
Hello Cecile,

apologies for the late reply, I didn't get any notifications.. Thanks for the info, it's useful in any case.


Cheers.