ghost calls, poly comm phone, frustrated

  • 0
  • 2
  • Question
  • Updated 5 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: We have archived this topic as it has either reached a resolution, has become inactive, or information contained in this thread is no longer accurate. If you have questions or comments related to this to thread, please create a new topic, or post to ano

In the last 36 hours, I have received more than 90 ghost calls from randon three and four digit callers, 101, 1000, 2001, 2013, etc. This represents more than 60 during the day yesterday and 37 overnight.

These calls are to the polycomm desk phone only, softphone/RC call controller is unaffected.

This is a variation on a problem that I had with the softphone / RC call controller but i changed the listening port per suggestion in community forum. softphone issue appears fixed.

My polycomm phone, however, gets these calls all the time, but never with this unrelenting frequency. NB, they appear in the phone's own call log, not in the call controller or in my online account activity log.

i need this fixed asap. it is either a security issue, SIP sniffing, or your system and you haven provided me with the necessary settings for the typical router firewall.

I have the desk phone plugged into a gigbit network and access to the internet through AT&T uverse max and my usability of the ringcentral service has been
good.

Another call from "1000" as I typing this. . . and another, taking up my rollover line, Who can help?
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
  • frustrated

Posted 6 years ago

  • 0
  • 2
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
wait, more calls, this time from 123456!
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
wait, more calls, this time from 123456!
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
John, call support and have them adjust the port numbers on the Polycom phone.

they need to move the phone off of 5060.

Only support could make this change as the end user could make the change on the soft phone.

I have seen this solve the problem

Keep us in the loop

Thanks

Chuck
Certified Ring Central Installer
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
John, call support and have them adjust the port numbers on the Polycom phone.

they need to move the phone off of 5060.

Only support could make this change as the end user could make the change on the soft phone.

I have seen this solve the problem

Keep us in the loop

Thanks

Chuck
Certified Ring Central Installer
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
thanks, chuck. no response from my support ticket. I'm calling them now.

JJR
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
Well, Chuck, calling support was entirely a waste of time. Per support, "this is a known issue" and "there is no timetable for resolution" and support will not change the port on my phone. Per support, changing the port will not resolve it so support refused to change the local port for me and would not acknowledge that changing the port on the phone would be a fix, however temporary.

So the message is suck it up and too bad. 90+ calls! That's right, 90+ calls.

Very disappointing, Ringcental. Seems like they would have a fix for this problem when it can be resolved by changing a port on the softphone/call controller.

Thank you, however, for your help, Chuck.

This was, allegedly, escalated to tier 3 support, whatever that means.
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Wow, I am surprised at that answer. I know it has solved the issue for the soft phone. I have always had to call for the IP phones.

In my conversations it is something local on the network that is causing the issue.

I talk to a lot of people but is your phone network on its own VLAN?

If there is a way to isolate the phones so that other local network traffic is not causing an issue.

Let me know

You could also contact me directly so we could figure something out.

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Wow, I am surprised at that answer. I know it has solved the issue for the soft phone. I have always had to call for the IP phones.

In my conversations it is something local on the network that is causing the issue.

I talk to a lot of people but is your phone network on its own VLAN?

If there is a way to isolate the phones so that other local network traffic is not causing an issue.

Let me know

You could also contact me directly so we could figure something out.

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
chuck

the phone is not on its own vlan. just router to switch and devices and desktop into switch. nothing fancy other than hp laser jet, desktop, etc and phone. all using
dhcp not static ip.

so you are thinking isolate the phone on vlan?

jjr
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Well, In my trouble shooting I like to get down to the bare minimum. because what is happening is that the phone is picking up something on the network that looks like a call.

Correct me if I am wrong but these calls are NOT showing up in the activity login on line. That tells me that the call is not originating from the RC system but the device it self is picking up something on the network.

Networks sounds simple so would you be able to just isolate the phone for a period of time to see if the problem still exists?

It is obviously something that is not easy to find so that is how I would move to solve this issue.

know what I mean?

Chuck
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Well, In my trouble shooting I like to get down to the bare minimum. because what is happening is that the phone is picking up something on the network that looks like a call.

Correct me if I am wrong but these calls are NOT showing up in the activity login on line. That tells me that the call is not originating from the RC system but the device it self is picking up something on the network.

Networks sounds simple so would you be able to just isolate the phone for a period of time to see if the problem still exists?

It is obviously something that is not easy to find so that is how I would move to solve this issue.

know what I mean?

Chuck
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
Hey Chuck, look at this: https://supportforums.cisco.com/threa...

and

http://www.mail-archive.com/voiceops@...

with polycom phone suggestion, including the author of sipVicious itself.

I wonder why tier 3 support hasn't seen?
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
Thanks Chuck, for your input, I just wanted to update that the calls have stopped for now, thankfully, but I've had no contact from tier 3 support, either by acknowledgment or apology since my call to them. my support case remains open. Not good customer service.
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb


sipvicious brute force attack?
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
Still no response or action from support. my case remains opened and customer service does not respond. very disappointing.
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
49 calls overnight from, 1002.
Photo of Will Hunter

Will Hunter

  • 120 Points 100 badge 2x thumb
Sorry for your troubles but thankful to know I am not the only one. I get 30+ calls a day like this. On one occasion, the call I was on was automatically put on hold and I was suddenly on the line with the ghost call. I've tried all of the solutions found in the forum but the calls keep coming. If anyone finds a solution I would love to hear it. Unfortunately, I don't have the option of switching because it is a business line I have no control over.

I've had a personal VOIP line with a couple other providers for 8+ years and never had such a problem.
Photo of RC-Installer

RC-Installer, Champion

  • 27,748 Points 20k badge 2x thumb
Will, try adjusting your firewall to only allow traffic from RC to the phones. What is happening is the SIP Vicious scanners looking for open sip connections to make calls out.

I have been trying to get a good router config from RC to help on the lock down but any good router person could adjust the firewall to ignore these requests.

This is what I would try to do. This is a hard thing to test as not all people have this issue. Since you are having it playing with the Firewall rules until it stops will help.

Some other VOIP providers use VPN type connections from the phone to theis service and that will not allow this stuff to happen..

RC should consider this.

Let us know if you are able to get a good FW rules to only let that traffic through

Chuck
Certified Ring Central Installer
ckfuscone@yahoo.com
Photo of John Radshaw

John Radshaw

  • 352 Points 250 badge 2x thumb
Chuck

they don't even reply to my case. I have the router configured correctly, and proper set up requires an update or setting change to the polycom phone. RC is not willing, not interested, or not able to make this change.

And did I mention they have ignored my case? And they don't respond to the issue here on the forums.

JJR
Photo of Will Hunter

Will Hunter

  • 120 Points 100 badge 2x thumb
Thank you Chuck for your prompt response. Unfortunately, I work from home and have a consumer grade router and it doesn't appear I have such granular control over port rules. I have another router with DD-WRT that I think has that option and will investigate if need be.

However, since posting, I was going through my router settings with a fine tooth comb and found something called "SIP ALG". After a bit of googling I found it is generally recommended to turn that off (on by default on my router).

Disabling has negated the need to have a forwarded port on my router (was needed for incoming calls to work). Now I've been able to close off the port so that my phone establishes communication with the endpoint properly thereby opening up communication only to RC on that port. Only time will tell but I'm hopeful this will work. I will follow-up in a few days to report this a success or failure. Thanks!
Photo of Ben Foster

Ben Foster, Alum

  • 6,124 Points 5k badge 2x thumb
Great suggestion, Will, thank you.
Photo of Will Hunter

Will Hunter

  • 120 Points 100 badge 2x thumb
Wow, time flies.  I meant to report back earlier but once things began working I forgot about it and Ben's comment above reminded me.  The solution I posted previously was a complete success.  I no longer have any problems with my RC line.  Everything is working great!
Photo of Gary Frerking

Gary Frerking

  • 70 Points
I've had this problem for months as well. It's EXTREMELY annoying. I have also asked RC for help to no avail. Polycom phones are essentially Linux boxes. Linux boxes have sophisticated firewalls built in that could *easily* be set to restrict incoming traffic to only that from the RC servers. But alas, RC has the control over the Polycom phone firmware and settings... and fail to take the simple step(s) of enabling the firewall. Worse, they have the phones locked down so consumers with the knowledge to do so can't go in on their own to make the necessary changes. Very very frustrating.

I'll take a look at Will Hunter's advice. If I remember right, the Polycom installation actually told us to enable SIP ALG.

My question to Will is - it almost sounds like this could cause a problem with incoming calls?? Or is that handled through a continuous link between the phone and the RC endpoint that is/was initially established by the phone?
Photo of Will Hunter

Will Hunter

  • 120 Points 100 badge 2x thumb
I have not seen any installation guides so I'm uncertain what is considered best practice in this area.  That said, I plugged my phone into the router and it mis-behaved immediately.  As I recall, I could make calls, but the audio was hit or miss, usually only one-way (don't recall which way).  I was only able to fix that issue by configuring port forwarding in my firewall.  While that fixed the audio, that is when I started getting the ghost calls.  I tried manually configuring different ports over the next few months with mixed results.  When using anything other than the default port I found that incoming calls would not always ring my phone.  Finally after many months of varying results (and continuous ghost calls), I decided to start from the beginning, which is when I found the SIP ALG setting.  Knowing that RC was using the SIP protocol, I decided to disable all port forwarding and toggle the setting to off (on by default on my router).  To my surprise, the audio worked, ring in worked, and the ghost calls stopped.  I have not had a problem since.

My understanding is that when the phone boots up, it establishes a connection to the RC endpoint which in turn provides communication back to the phone from RC (and only RC) through that port, therefore no need for port forwarding.  Port forwarding is what opened my phone up to the ghost calls.  My best guess is that the SIP ALG was somehow preventing the initial "handshake" from occurring properly.  I also read that SIP ALG is poorly implemented in many consumer routers... so maybe there is something to that.  

All I know is my RC line has been on par with any landline I've used since the change.  Good luck!
Photo of Gary Frerking

Gary Frerking

  • 70 Points
My router (which is combination cable modem & router provided by cable company) does not seem to have a SIP ALG feature. I did, however, have port triggering enabled for two ranges of ports. Everything worked OK except for the "ghost" calls - which came in frequently enough that I had to turn the ringer of my phone down. If I'm sitting at my desk, I can tell if it's a real call or not by looking at the screen. I got tired and frustrated running to the phone from elsewhere every time a ghost call came in.

Turning off the port triggering solved the ghost call problem. Now, legit inbound calls are hit-and-miss so they must rely at least partly on the port triggering and/or a recent solid socket connection with the RC servers. Sometimes the phone rings, sometimes I get the forward to my cell without the phone ringing at all. It's still not a good solution, and I'm still not happy. I've NEVER received an answer or suggestion from RC on this even though I've asked more than once.

As I said before, the phone itself is capable of blocking out these ghost triggers. RC has it locked down to the point I can't get in. I'd be happy if they just let me know how to ssh or telnet in to the phone and give me the needed server address ranges so I can set the phone's iptables appropriately.

I'm not happy. The IP phone they pushed me to upgrade to has limited value. I'm very busy with other things, but if/when I fin a better solution I don't have a problem giving RC the boot at this point.

This conversation is no longer open for comments or replies.